summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Zoffoli <xmerlin@gentoo.org>2005-10-08 14:35:03 +0000
committerChristian Zoffoli <xmerlin@gentoo.org>2005-10-08 14:35:03 +0000
commitda09a88f53c8afda7892d6cfdd2a969e2107267d (patch)
treecb7bd3af1cbb7d7b4988e0a5063988184d759e98 /sys-cluster/cman/cman-1.01.00.ebuild
parentNew version. (diff)
downloadgentoo-2-da09a88f53c8afda7892d6cfdd2a969e2107267d.tar.gz
gentoo-2-da09a88f53c8afda7892d6cfdd2a969e2107267d.tar.bz2
gentoo-2-da09a88f53c8afda7892d6cfdd2a969e2107267d.zip
New version.
(Portage version: 2.0.51.19)
Diffstat (limited to 'sys-cluster/cman/cman-1.01.00.ebuild')
-rw-r--r--sys-cluster/cman/cman-1.01.00.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/sys-cluster/cman/cman-1.01.00.ebuild b/sys-cluster/cman/cman-1.01.00.ebuild
new file mode 100644
index 000000000000..5b92026fdcbb
--- /dev/null
+++ b/sys-cluster/cman/cman-1.01.00.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/cman/cman-1.01.00.ebuild,v 1.1 2005/10/08 14:35:03 xmerlin Exp $
+
+MY_P="cluster-${PV}"
+
+DESCRIPTION="general-purpose symmetric cluster manager"
+HOMEPAGE="http://sources.redhat.com/cluster/"
+SRC_URI="ftp://sources.redhat.com/pub/cluster/releases/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND=">=sys-cluster/ccs-1.01.00
+ >=sys-cluster/cman-headers-1.01.00"
+
+RDEPEND="virtual/libc"
+
+S="${WORKDIR}/${MY_P}/${PN}"
+
+src_compile() {
+ ./configure || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+
+ newinitd ${FILESDIR}/${PN}.rc ${PN} || die
+ newconfd ${FILESDIR}/${PN}.conf ${PN} || die
+}