summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2008-11-01 12:46:54 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2008-11-01 12:46:54 +0000
commit6c321c8ae81a6cc9020f38a551fadea80256dd23 (patch)
tree76168fa6b2f63386023dc6a6171470b677160da0 /sys-boot
parentRevert xerces-c blocker back to dependency. Glest needs xerces-c (diff)
downloadgentoo-2-6c321c8ae81a6cc9020f38a551fadea80256dd23.tar.gz
gentoo-2-6c321c8ae81a6cc9020f38a551fadea80256dd23.tar.bz2
gentoo-2-6c321c8ae81a6cc9020f38a551fadea80256dd23.zip
Add a magic flag GRUB_STATIC_PACKAGE_BUILDING which along with USE='static -ncurses' is used to build grub-static tarballs from now on.
(Portage version: 2.2_rc12/cvs/Linux 2.6.28-rc2-07920-g65fc716 x86_64)
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/grub/ChangeLog6
-rw-r--r--sys-boot/grub/grub-0.97-r6.ebuild18
2 files changed, 21 insertions, 3 deletions
diff --git a/sys-boot/grub/ChangeLog b/sys-boot/grub/ChangeLog
index 1b4799059223..d8d4f2a1c44a 100644
--- a/sys-boot/grub/ChangeLog
+++ b/sys-boot/grub/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-boot/grub
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/ChangeLog,v 1.101 2008/08/16 15:27:59 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/ChangeLog,v 1.102 2008/11/01 12:46:54 robbat2 Exp $
+
+ 01 Nov 2008; Robin H. Johnson <robbat2@gentoo.org> grub-0.97-r6.ebuild:
+ Add a magic flag GRUB_STATIC_PACKAGE_BUILDING which along with USE=static
+ -ncurses is used to build grub-static tarballs from now on.
16 Aug 2008; Mike Frysinger <vapier@gentoo.org> grub-1.96.ebuild:
Require lzo-1 #234182 by Kyle Elbert.
diff --git a/sys-boot/grub/grub-0.97-r6.ebuild b/sys-boot/grub/grub-0.97-r6.ebuild
index 84521e0fbe97..cbc3bac9811a 100644
--- a/sys-boot/grub/grub-0.97-r6.ebuild
+++ b/sys-boot/grub/grub-0.97-r6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-0.97-r6.ebuild,v 1.8 2008/07/07 08:48:08 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-0.97-r6.ebuild,v 1.9 2008/11/01 12:46:54 robbat2 Exp $
# XXX: we need to review menu.lst vs grub.conf handling. We've been converting
# all systems to grub.conf (and symlinking menu.lst to grub.conf), but
@@ -90,7 +90,15 @@ src_compile() {
# Per bug 216625, the emul packages do not provide .a libs for performing
# suitable static linking
if use amd64 && use static ; then
- die "You must use the grub-static package if you want a static Grub on amd64!"
+ if [ -z "${GRUB_STATIC_PACKAGE_BUILDING}" ]; then
+ die "You must use the grub-static package if you want a static Grub on amd64!"
+ else
+ eerror "You have set GRUB_STATIC_PACKAGE_BUILDING. This"
+ eerror "is specifically intended for building the tarballs for the"
+ eerror "grub-static package via USE='static -ncurses'."
+ eerror "All bets are now off."
+ ebeep 10
+ fi
fi
# build the net-bootable grub first, but only if "netboot" is set
@@ -146,6 +154,12 @@ src_install() {
dodoc AUTHORS BUGS ChangeLog NEWS README THANKS TODO
newdoc docs/menu.lst grub.conf.sample
dodoc "${FILESDIR}"/grub.conf.gentoo
+ prepalldocs
+
+ [ -n "${GRUB_STATIC_PACKAGE_BUILDING}" ] && \
+ mv \
+ "${D}"/usr/share/doc/${PF} \
+ "${D}"/usr/share/doc/grub-static-${PF/grub-}
insinto /usr/share/grub
doins "${DISTDIR}"/splash.xpm.gz