summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoseph Jezak <josejx@gentoo.org>2012-05-12 03:20:41 +0000
committerJoseph Jezak <josejx@gentoo.org>2012-05-12 03:20:41 +0000
commit56f8368791f4e6de3f2b2e206599aba461b8bfff (patch)
tree9b505e62eb2c217edfb5fb25b4bd9dd6fbeb90b4 /sys-boot
parentkeyword ~amd64-fbsd (diff)
downloadgentoo-2-56f8368791f4e6de3f2b2e206599aba461b8bfff.tar.gz
gentoo-2-56f8368791f4e6de3f2b2e206599aba461b8bfff.tar.bz2
gentoo-2-56f8368791f4e6de3f2b2e206599aba461b8bfff.zip
Added patch to fix devspec path on newer kernels.
(Portage version: 2.1.10.57/cvs/Linux x86_64)
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/yaboot-static/ChangeLog8
-rw-r--r--sys-boot/yaboot-static/files/new-ofpath-devspec.patch28
-rw-r--r--sys-boot/yaboot-static/yaboot-static-1.3.17-r1.ebuild31
3 files changed, 66 insertions, 1 deletions
diff --git a/sys-boot/yaboot-static/ChangeLog b/sys-boot/yaboot-static/ChangeLog
index 188fb15eb5f6..373ca3042284 100644
--- a/sys-boot/yaboot-static/ChangeLog
+++ b/sys-boot/yaboot-static/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-boot/yaboot-static
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/yaboot-static/ChangeLog,v 1.26 2012/02/24 15:18:55 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/yaboot-static/ChangeLog,v 1.27 2012/05/12 03:20:41 josejx Exp $
+
+*yaboot-static-1.3.17-r1 (12 May 2012)
+
+ 12 May 2012; Joseph Jezak <josejx@gentoo.org>
+ +yaboot-static-1.3.17-r1.ebuild, +files/new-ofpath-devspec.patch:
+ Add patch to fix devspec location.
*yaboot-static-1.3.17 (24 Feb 2012)
*yaboot-static-1.3.16-r1 (24 Feb 2012)
diff --git a/sys-boot/yaboot-static/files/new-ofpath-devspec.patch b/sys-boot/yaboot-static/files/new-ofpath-devspec.patch
new file mode 100644
index 000000000000..eec840ee10fe
--- /dev/null
+++ b/sys-boot/yaboot-static/files/new-ofpath-devspec.patch
@@ -0,0 +1,28 @@
+--- usr/sbin/ofpath.bak 2012-05-09 12:24:51.709911981 -0400
++++ usr/sbin/ofpath 2012-05-09 12:32:19.661560544 -0400
+@@ -85,11 +85,20 @@
+ [ "$DEBUG" = 1 ] && echo "Devpath is: $DEVPATH"
+
+ ### Get the OF Path of the controller
+-case ${DISK_NAME} in
+- sd*|sg*|sr*) CONTROLLER_PATH=$(cat ${DEVPATH}/../../../devspec) ;;
+- hd*) CONTROLLER_PATH=$(cat ${DEVPATH}/../../devspec) ;;
+- *) CONTROLLER_PATH="" ;;
+-esac
++if [ -e "${DEVPATH}/../../devspec" ]; then
++ ### /dev/hd*
++ CONTROLLER_PATH=$(cat ${DEVPATH}/../../devspec);
++elif [ -e "${DEVPATH}/../../../devspec" ]; then
++ ### /dev/sd* on kernel <3.3
++ CONTROLLER_PATH=$(cat ${DEVPATH}/../../../devspec);
++elif [ -e "${DEVPATH}/../../../../devspec" ]; then
++ ### /dev/sd* on kernel 3.3+
++ CONTROLLER_PATH=$(cat ${DEVPATH}/../../../../devspec);
++else
++ ### None of the above...
++ CONTROLLER_PATH="";
++fi
++
+ if [ -z "$CONTROLLER_PATH" ]; then
+ echo "Unable to determine controller path!"
+ exit 1
diff --git a/sys-boot/yaboot-static/yaboot-static-1.3.17-r1.ebuild b/sys-boot/yaboot-static/yaboot-static-1.3.17-r1.ebuild
new file mode 100644
index 000000000000..e11b59b31884
--- /dev/null
+++ b/sys-boot/yaboot-static/yaboot-static-1.3.17-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/yaboot-static/yaboot-static-1.3.17-r1.ebuild,v 1.1 2012/05/12 03:20:41 josejx Exp $
+
+EAPI=2
+
+inherit eutils
+
+DESCRIPTION="Static yaboot ppc boot loader for machines with open firmware"
+### Generated by using quickpkg on a ppc32 machine, compiled with -O2 -pipe
+
+HOMEPAGE="http://penguinppc.org/projects/yaboot/"
+SRC_URI="mirror://gentoo/yaboot-static-${PV}.tbz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~ppc64"
+IUSE="ibm"
+DEPEND="!sys-boot/yaboot
+ sys-apps/powerpc-utils"
+RDEPEND="!ibm? ( sys-fs/hfsutils
+ sys-fs/hfsplusutils
+ sys-fs/mac-fdisk )"
+
+src_prepare() {
+ # Fix the devspec path on newer kernels
+ epatch "${FILESDIR}/new-ofpath-devspec.patch"
+}
+
+src_install() {
+ cp -pPR "${WORKDIR}"/* "${D}" || die "cp failed"
+}