summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuy Martin <gmsoft@gentoo.org>2005-11-26 15:14:10 +0000
committerGuy Martin <gmsoft@gentoo.org>2005-11-26 15:14:10 +0000
commit49390c00228fb9ec587955f382eede967965ecd7 (patch)
tree3bd29b51afca883f0a163aa32b51f751446d10e2 /sys-boot/palo
parentcleanup (diff)
downloadgentoo-2-49390c00228fb9ec587955f382eede967965ecd7.tar.gz
gentoo-2-49390c00228fb9ec587955f382eede967965ecd7.tar.bz2
gentoo-2-49390c00228fb9ec587955f382eede967965ecd7.zip
Version bump.
(Portage version: 2.0.51.22-r3)
Diffstat (limited to 'sys-boot/palo')
-rw-r--r--sys-boot/palo/ChangeLog7
-rw-r--r--sys-boot/palo/Manifest2
-rw-r--r--sys-boot/palo/files/digest-palo-1.10_pre200510121
-rw-r--r--sys-boot/palo/palo-1.10_pre20051012.ebuild44
4 files changed, 53 insertions, 1 deletions
diff --git a/sys-boot/palo/ChangeLog b/sys-boot/palo/ChangeLog
index 74e1afb716cd..7d8beb483664 100644
--- a/sys-boot/palo/ChangeLog
+++ b/sys-boot/palo/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-boot/palo
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/palo/ChangeLog,v 1.12 2005/07/18 08:17:57 gmsoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/palo/ChangeLog,v 1.13 2005/11/26 15:14:10 gmsoft Exp $
+
+*palo-1.10_pre20051012 (26 Nov 2005)
+
+ 26 Nov 2005; Guy Martin <gmsoft@gentoo.org> +palo-1.10_pre20051012.ebuild:
+ Version bump.
18 Jul 2005; Guy Martin <gmsoft@gentoo.org> palo-1.8_pre20050523.ebuild:
Stable on hppa.
diff --git a/sys-boot/palo/Manifest b/sys-boot/palo/Manifest
index 6d6710737de1..a32797f47c0c 100644
--- a/sys-boot/palo/Manifest
+++ b/sys-boot/palo/Manifest
@@ -4,9 +4,11 @@ MD5 215a7af50439001abaae3f11694675bc palo-1.2_pre20030630.ebuild 933
MD5 bdf378eec83dab3345d0bb28756985c1 palo-1.3_pre20040303.ebuild 934
MD5 88ad675808b43e5bd5c8f0325adba7bd palo-1.5_pre20040515.ebuild 1011
MD5 4cf4bd85a4506b544c6c66fea39d2a98 palo-1.8_pre20050523.ebuild 1011
+MD5 caa8270cb3361def5ea376b744021423 palo-1.10_pre20051012.ebuild 1152
MD5 7ee737710bef1fd5dd94d975eaf30721 files/digest-palo-1.2_pre20030630 71
MD5 976dc147179cc0e2e54c219e32084c2c files/digest-palo-1.3_pre20040303 71
MD5 552150e078605c297602afb8d8d4c9fe files/digest-palo-1.5_pre20040515 72
MD5 e54ad3d44d639d402e7bacda8826dd58 files/palo-remove-HOME-TERM.patch 3605
MD5 0df188cd6b8a1188ebd0fc4440753187 files/palo.conf 207
MD5 250c702ef4ccd048d09ad0a611350295 files/digest-palo-1.8_pre20050523 72
+MD5 ac935ddd89e26083054622394617a13a files/digest-palo-1.10_pre20051012 72
diff --git a/sys-boot/palo/files/digest-palo-1.10_pre20051012 b/sys-boot/palo/files/digest-palo-1.10_pre20051012
new file mode 100644
index 000000000000..24660c1c14f2
--- /dev/null
+++ b/sys-boot/palo/files/digest-palo-1.10_pre20051012
@@ -0,0 +1 @@
+MD5 effb3d446823b5eb7faf912760bcdc04 palo-1.10-CVS20051012.tar.gz 88740
diff --git a/sys-boot/palo/palo-1.10_pre20051012.ebuild b/sys-boot/palo/palo-1.10_pre20051012.ebuild
new file mode 100644
index 000000000000..309a35cf8d6c
--- /dev/null
+++ b/sys-boot/palo/palo-1.10_pre20051012.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/palo/palo-1.10_pre20051012.ebuild,v 1.1 2005/11/26 15:14:10 gmsoft Exp $
+
+inherit eutils
+
+MY_V=${PV/_pre/-CVS}
+DESCRIPTION="PALO : PArisc Linux Loader"
+HOMEPAGE="http://parisc-linux.org/"
+SRC_URI="http://ftp.parisc-linux.org/cvs/palo-${MY_V}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~hppa"
+IUSE=""
+
+DEPEND="virtual/libc"
+PROVIDE="virtual/bootloader"
+
+S=${WORKDIR}/palo
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/${PN}-remove-HOME-TERM.patch
+}
+
+src_compile() {
+ emake -C palo CFLAGS="${CFLAGS} -I../include -I../lib -D__KERNEL_STRICT_NAMES" || die "make palo failed."
+ emake -C ipl CFLAGS="${CFLAGS} -I. -I../lib -I../include -fwritable-strings -mdisable-fpregs -Wall -D__kernel_timer_t=int -D__kernel_clockid_t=int" || die "make ipl failed."
+ emake MACHINE=parisc iplboot || die "make iplboot failed."
+}
+
+src_install() {
+ dosbin palo/palo || die
+ doman palo.8
+ dohtml README.html
+ dodoc README palo.conf
+
+ insinto /etc
+ doins ${FILESDIR}/palo.conf
+
+ insinto /usr/share/palo
+ doins iplboot
+}