summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2005-07-24 13:43:10 +0000
committerMartin Schlemmer <azarah@gentoo.org>2005-07-24 13:43:10 +0000
commit992b523f3d772add0be37f64a12a7c3a1d392549 (patch)
tree5adcb790f944663993814556a4d7cc1fef66405a /sys-boot/grub
parentVersion bump. Older versions marked stable on x86. (diff)
downloadgentoo-2-992b523f3d772add0be37f64a12a7c3a1d392549.tar.gz
gentoo-2-992b523f3d772add0be37f64a12a7c3a1d392549.tar.bz2
gentoo-2-992b523f3d772add0be37f64a12a7c3a1d392549.zip
Fix building with gcc2.
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'sys-boot/grub')
-rw-r--r--sys-boot/grub/ChangeLog6
-rw-r--r--sys-boot/grub/files/grub-0.96-gcc2.patch19
-rw-r--r--sys-boot/grub/grub-0.96-r2.ebuild5
3 files changed, 28 insertions, 2 deletions
diff --git a/sys-boot/grub/ChangeLog b/sys-boot/grub/ChangeLog
index e5235148b6b1..e65cb6f1dede 100644
--- a/sys-boot/grub/ChangeLog
+++ b/sys-boot/grub/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-boot/grub
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/ChangeLog,v 1.44 2005/07/04 11:35:49 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/ChangeLog,v 1.45 2005/07/24 13:43:10 azarah Exp $
+
+ 24 Jul 2005; Martin Schlemmer <azarah@gentoo.org>
+ +files/grub-0.96-gcc2.patch, grub-0.96-r2.ebuild:
+ Fix building with gcc2.
04 Jul 2005; Sven Wegener <swegener@gentoo.org> grub-0.95.20040823.ebuild,
grub-0.96.ebuild, grub-0.96-r1.ebuild, grub-0.96-r2.ebuild:
diff --git a/sys-boot/grub/files/grub-0.96-gcc2.patch b/sys-boot/grub/files/grub-0.96-gcc2.patch
new file mode 100644
index 000000000000..5600fb62b46d
--- /dev/null
+++ b/sys-boot/grub/files/grub-0.96-gcc2.patch
@@ -0,0 +1,19 @@
+--- grub-0.96/stage2/builtins.c 2005-07-24 15:46:56 +0200
++++ grub-0.96.az/stage2/builtins.c 2005-07-24 15:47:40 +0200
+@@ -2012,14 +2012,14 @@
+ int is_open = 0;
+ /* If LBA is forced? */
+ int is_force_lba = 0;
+-
+- *stage2_first_buffer = old_sect + SECTOR_SIZE;
+ #ifdef GRUB_UTIL
+ /* If the Stage 2 is in a partition mounted by an OS, this will store
+ the filename under the OS. */
+ char *stage2_os_file = 0;
+ #endif /* GRUB_UTIL */
+
++ *stage2_first_buffer = old_sect + SECTOR_SIZE;
++
+ /* First, check the GNU-style long option. */
+ while (1)
+ {
diff --git a/sys-boot/grub/grub-0.96-r2.ebuild b/sys-boot/grub/grub-0.96-r2.ebuild
index 648bdf3fdafd..39523f3f45bb 100644
--- a/sys-boot/grub/grub-0.96-r2.ebuild
+++ b/sys-boot/grub/grub-0.96-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-0.96-r2.ebuild,v 1.4 2005/07/04 11:35:49 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-0.96-r2.ebuild,v 1.5 2005/07/24 13:43:10 azarah Exp $
inherit mount-boot eutils flag-o-matic toolchain-funcs
@@ -67,6 +67,9 @@ src_unpack() {
# fix PIC issues in netboot code #85566
epatch "${FILESDIR}"/${P}-netboot-pic.patch
+ # fix building with gcc2
+ epatch "${FILESDIR}"/${P}-gcc2.patch
+
# a bunch of patches apply to raw autotool files
autoconf || die "autoconf failed"
aclocal || die "aclocal failed"