summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2008-02-25 02:08:22 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2008-02-25 02:08:22 +0000
commit3f3e22d1b0b2b486bbb6ab06b3a1089d6b0abd1d (patch)
tree378ba3730f09eed24a46d5d071b3b40fa7663c3a /sys-boot/grub/grub-0.96-r1.ebuild
parentVersion bump (diff)
downloadgentoo-2-3f3e22d1b0b2b486bbb6ab06b3a1089d6b0abd1d.tar.gz
gentoo-2-3f3e22d1b0b2b486bbb6ab06b3a1089d6b0abd1d.tar.bz2
gentoo-2-3f3e22d1b0b2b486bbb6ab06b3a1089d6b0abd1d.zip
Fix up all quoting to make repoman happy.
(Portage version: 2.1.4.4)
Diffstat (limited to 'sys-boot/grub/grub-0.96-r1.ebuild')
-rw-r--r--sys-boot/grub/grub-0.96-r1.ebuild16
1 files changed, 8 insertions, 8 deletions
diff --git a/sys-boot/grub/grub-0.96-r1.ebuild b/sys-boot/grub/grub-0.96-r1.ebuild
index 2d483090d9e3..583f0e6ca42c 100644
--- a/sys-boot/grub/grub-0.96-r1.ebuild
+++ b/sys-boot/grub/grub-0.96-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-0.96-r1.ebuild,v 1.15 2005/08/21 02:24:04 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-0.96-r1.ebuild,v 1.16 2008/02/25 02:08:22 robbat2 Exp $
inherit mount-boot eutils flag-o-matic toolchain-funcs
@@ -46,7 +46,7 @@ src_unpack() {
unpack ${A} ; cd "${S}"
EPATCH_SUFFIX="patch"
- epatch ${PATCHDIR}
+ epatch "${PATCHDIR}"
# a bunch of patches apply to raw autotool files
autoconf || die "autoconf failed"
@@ -117,18 +117,18 @@ src_install() {
use netboot && doexe nbgrub pxegrub stage2/stage2.netboot
insinto /boot/grub
- doins ${DISTDIR}/splash.xpm.gz
+ doins "${DISTDIR}"/splash.xpm.gz
newins docs/menu.lst grub.conf.sample
- dodoc AUTHORS BUGS COPYING ChangeLog NEWS README THANKS TODO
+ dodoc AUTHORS BUGS ChangeLog NEWS README THANKS TODO
newdoc docs/menu.lst grub.conf.sample
docinto gentoo
- dodoc ${PATCHDIR}/README.Gentoo.patches
+ dodoc "${PATCHDIR}"/README.Gentoo.patches
}
pkg_postinst() {
- [[ ${ROOT} != "/" ]] && return 0
+ [[ "${ROOT}" != "/" ]] && return 0
# change menu.lst to grub.conf
if [[ ! -e /boot/grub/grub.conf && -e /boot/grub/menu.lst ]] ; then
@@ -144,7 +144,7 @@ pkg_postinst() {
einfo "Copying files from /lib/grub and /usr/lib/grub to /boot"
for x in /lib/grub/*/* /usr/lib/grub/*/* ; do
- [[ -f ${x} ]] && cp -p ${x} /boot/grub
+ [[ -f "${x}" ]] && cp -p "${x}" /boot/grub
done
# hardened voodoo