summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2005-07-28 14:29:56 +0000
committerSeemant Kulleen <seemant@gentoo.org>2005-07-28 14:29:56 +0000
commit3055a844e3b53fe565e648f6781cd1c742b46019 (patch)
tree2609d518346248f589415d7a201c5fe0719bd4bf /sys-boot/grub/grub-0.94-r1.ebuild
parentFix qt dep per bug #100235 (diff)
downloadgentoo-2-3055a844e3b53fe565e648f6781cd1c742b46019.tar.gz
gentoo-2-3055a844e3b53fe565e648f6781cd1c742b46019.tar.bz2
gentoo-2-3055a844e3b53fe565e648f6781cd1c742b46019.zip
remove cruft ebuilds
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'sys-boot/grub/grub-0.94-r1.ebuild')
-rw-r--r--sys-boot/grub/grub-0.94-r1.ebuild133
1 files changed, 0 insertions, 133 deletions
diff --git a/sys-boot/grub/grub-0.94-r1.ebuild b/sys-boot/grub/grub-0.94-r1.ebuild
deleted file mode 100644
index 990c80347ec7..000000000000
--- a/sys-boot/grub/grub-0.94-r1.ebuild
+++ /dev/null
@@ -1,133 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-0.94-r1.ebuild,v 1.19 2005/05/30 19:58:21 swegener Exp $
-
-inherit mount-boot eutils flag-o-matic toolchain-funcs
-
-DESCRIPTION="GNU GRUB boot loader"
-HOMEPAGE="http://www.gnu.org/software/grub/"
-SRC_URI="ftp://alpha.gnu.org/gnu/grub/${P}.tar.gz
- mirror://gentoo/${P}-splash.patch.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="-* x86 amd64"
-IUSE="static"
-
-RDEPEND=">=sys-libs/ncurses-5.2-r5"
-DEPEND="${RDEPEND}
- >=sys-devel/automake-1.7
- >=sys-devel/autoconf-2.5"
-PROVIDE="virtual/bootloader"
-
-pkg_setup() {
- if use amd64; then
- has_m32 || die "your compiler seems to be unable to compile 32bit code. if you are on amd64, make sure you compile gcc with USE=multilib FEATURES=-sandbox"
-
- ABI_ALLOW="x86"
- ABI="x86"
- fi
-}
-
-src_unpack() {
- unpack ${A}
- cd ${S}
-
- epatch ${WORKDIR}/${P}-splash.patch
- epatch ${FILESDIR}/${P}-gcc3.4.patch
-
- # This patchset is from SuSE -- hopefully fixes the acl symlink issue
- # And should add some boot prettification
-# epatch ${WORKDIR}/${PF}-gentoo.diff
-# epatch ${FILESDIR}/${P}-test.patch
-}
-
-src_compile() {
- unset BLOCK_SIZE #73499
-
- ### i686-specific code in the boot loader is a bad idea; disabling to ensure
- ### at least some compatibility if the hard drive is moved to an older or
- ### incompatible system.
- unset CFLAGS
-
- filter-ldflags -pie
- append-flags -DNDEBUG
- [ `gcc-major-version` -eq 3 ] && append-flags -minline-all-stringops
- use static && append-ldflags -static
-
- has_pie && CC="${CC} `test_flag -fno-pic` `test_flag -nopie`"
- has_ssp && CC="${CC} `test_flag -fno-stack-protector`"
-
- autoconf || die
- aclocal || die
- WANT_AUTOMAKE=1.7 automake || die
-
- # build the net-bootable grub first
- CFLAGS="" \
- econf \
- --libdir=/lib \
- --datadir=/usr/lib/grub \
- --exec-prefix=/ \
- --disable-auto-linux-mem-opt \
- --enable-diskless \
- --enable-{3c{5{03,07,09,29,95},90x},cs89x0,davicom,depca,eepro{,100}} \
- --enable-{epic100,exos205,ni5210,lance,ne2100,ni{50,65}10,natsemi} \
- --enable-{ne,ns8390,wd,otulip,rtl8139,sis900,sk-g16,smc9000,tiara} \
- --enable-{tulip,via-rhine,w89c840} || die
-
- emake w89c840_o_CFLAGS="-O" || die "making netboot stuff"
-
- mv stage2/{nbgrub,pxegrub} ${S}
- mv stage2/stage2 stage2/stage2.netboot
-
- make clean || die
-
- # now build the regular grub
- CFLAGS="${CFLAGS}" \
- econf \
- --libdir=/lib \
- --datadir=/usr/lib/grub \
- --exec-prefix=/ \
- --disable-auto-linux-mem-opt || die
- emake || die "making regular stuff"
-}
-
-src_install() {
- make DESTDIR=${D} install || die
- exeinto /usr/lib/grub
- doexe nbgrub pxegrub stage2/stage2 stage2/stage2.netboot
-
- insinto /boot/grub
- doins ${FILESDIR}/splash.xpm.gz
- newins docs/menu.lst grub.conf.sample
-
- dodoc AUTHORS BUGS COPYING ChangeLog NEWS README THANKS TODO
- newdoc docs/menu.lst grub.conf.sample
-}
-
-pkg_postinst() {
- [ "$ROOT" != "/" ] && return 0
-
- # change menu.lst to grub.conf
- if [ ! -e /boot/grub/grub.conf -a -e /boot/grub/menu.lst ]
- then
- mv /boot/grub/menu.lst /boot/grub/grub.conf
- ewarn
- ewarn "*** IMPORTANT NOTE: menu.lst has been renamed to grub.conf"
- ewarn
- fi
- einfo "Linking from new grub.conf name to menu.lst"
- ln -s grub.conf /boot/grub/menu.lst
-
- [ -e /boot/grub/stage2 ] && mv /boot/grub/stage2{,.old}
-
- einfo "Copying files from /usr/lib/grub to /boot"
- cp -p /usr/lib/grub/* /boot/grub
- cp -p /usr/lib/grub/grub/*/* /boot/grub
-
- [ -e /boot/grub/grub.conf ] \
- && /usr/sbin/grub \
- --batch \
- --device-map=/boot/grub/device.map \
- < /boot/grub/grub.conf > /dev/null 2>&1
-}