summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStuart Longland <redhatter@gentoo.org>2005-06-04 07:29:44 +0000
committerStuart Longland <redhatter@gentoo.org>2005-06-04 07:29:44 +0000
commit858027d36fe466cec5e579346797bd2b80c13589 (patch)
treec2d6405ccc06ebe432df7562463499b36b2794b1 /sys-boot/colo
parentCorrect list of needed libraries. (diff)
downloadgentoo-2-858027d36fe466cec5e579346797bd2b80c13589.tar.gz
gentoo-2-858027d36fe466cec5e579346797bd2b80c13589.tar.bz2
gentoo-2-858027d36fe466cec5e579346797bd2b80c13589.zip
Added ebuild for sys-boot/colo-1.19 as per bug #72161.
(Portage version: 2.0.51.19)
Diffstat (limited to 'sys-boot/colo')
-rw-r--r--sys-boot/colo/ChangeLog6
-rw-r--r--sys-boot/colo/Manifest9
-rw-r--r--sys-boot/colo/colo-1.19.ebuild115
-rw-r--r--sys-boot/colo/files/digest-colo-1.191
4 files changed, 127 insertions, 4 deletions
diff --git a/sys-boot/colo/ChangeLog b/sys-boot/colo/ChangeLog
index 4dabb3ad3187..9011a01402bc 100644
--- a/sys-boot/colo/ChangeLog
+++ b/sys-boot/colo/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-boot/colo
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/colo/ChangeLog,v 1.12 2005/03/21 03:00:33 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/colo/ChangeLog,v 1.13 2005/06/04 07:29:44 redhatter Exp $
+
+*colo-1.19 (04 Jun 2005)
+ 04 Jun 2005; Stuart Longland <redhatter@gentoo.org> +colo-1.19.ebuild:
+ Version bump of unstable to v1.19 as per bug #72161
*colo-1.16 (20 Mar 2005)
diff --git a/sys-boot/colo/Manifest b/sys-boot/colo/Manifest
index 1858fbadf36a..74ad63aedef8 100644
--- a/sys-boot/colo/Manifest
+++ b/sys-boot/colo/Manifest
@@ -1,9 +1,12 @@
MD5 70130438ff36ae8f2fec9d46083cfc74 ChangeLog 2196
-MD5 026831567291f246c369c29fb65e8d41 colo-1.16.ebuild 4457
-MD5 b4b40f8fa2c83fedc1252c16ce931d9b colo-1.13.ebuild 3754
MD5 821bbe104fd36eab5f08495277bc5adb metadata.xml 364
-MD5 90a0baf918f815c9b6d3daafcc77c960 files/digest-colo-1.16 61
+MD5 b4b40f8fa2c83fedc1252c16ce931d9b colo-1.13.ebuild 3754
+MD5 026831567291f246c369c29fb65e8d41 colo-1.16.ebuild 4457
+MD5 06c55b857c25526f5a563c8d5196343c .colo-1.19.ebuild.swp 16384
+MD5 718b2dacf0fe990e0704bd3af2844378 colo-1.19.ebuild 3773
MD5 bcfba587298a2f1a3dd4c186dbc1ce0d files/colo-linker-overlap-fix.patch 1489
MD5 887b7cc9e154a546edceffc8ecedc9fd files/default.colo 840
MD5 3a2004f193ec415c0087691d913c92db files/digest-colo-1.13 61
MD5 216fc6b6d9c407532a57bf484d8fe7d3 files/menu-linux.colo 286
+MD5 90a0baf918f815c9b6d3daafcc77c960 files/digest-colo-1.16 61
+MD5 b2c42788147b311d818a159f61096aff files/digest-colo-1.19 61
diff --git a/sys-boot/colo/colo-1.19.ebuild b/sys-boot/colo/colo-1.19.ebuild
new file mode 100644
index 000000000000..10e9a77f8af0
--- /dev/null
+++ b/sys-boot/colo/colo-1.19.ebuild
@@ -0,0 +1,115 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/colo/colo-1.19.ebuild,v 1.1 2005/06/04 07:29:44 redhatter Exp $
+
+inherit eutils
+
+DESCRIPTION="CObalt LOader - Modern bootloader for Cobalt MIPS machines"
+HOMEPAGE="http://www.colonel-panic.org/cobalt-mips/"
+SRC_URI="http://www.colonel-panic.org/cobalt-mips/colo/colo-${PV}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~mips"
+IUSE=""
+DEPEND=""
+RESTRICT="nostrip"
+
+
+pkg_setup() {
+ # See if we're on a cobalt system (must use the cobalt-mips profile)
+ if [ "${PROFILE_ARCH}" != "cobalt" ]; then
+ echo -e ""
+ eerror "This package is only intended for the Cobalt Microserver MIPS-based"
+ eerror "systems. It will not function on any other MIPS-based system or any"
+ eerror "other architecture"
+ echo -e ""
+ die
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+
+ # cp the bootscripts to WORKDIR
+ cp ${FILESDIR}/menu-linux.colo ${WORKDIR}
+
+ # sed the primary boot script and stick the current colo version in there
+ sed "s:@COLOVER@:${PV}:g" ${FILESDIR}/default.colo > ${WORKDIR}/default.colo
+}
+
+src_compile() {
+ echo -e ""
+ einfo ">>> Building the CoLo Bootloader ..."
+ cd ${S}
+ make clean || die # emake breaks the build
+ make || die
+}
+
+src_install() {
+ # bins
+ cd ${S}
+ dodir /usr/lib/colo
+ cp binaries/colo-chain.elf ${D}/usr/lib/colo
+ cp binaries/colo-rom-image.bin ${D}/usr/lib/colo
+
+ # docs
+ dodoc CHANGES COPYING INSTALL README README.{restore,shell,netcon} tools/README.tools TODO
+
+ # all tools except lcdtools (see below)
+ local tool
+ for tool in flash-tool colo-perm copy-rom elf2rfx; do
+
+ einfo "Installing ${tool} binary to ${D}/usr/sbin"
+ dosbin tools/${tool}/${tool}
+ if [ -f tools/${tool}/${tool}.8 ]; then
+ einfo "Installing ${tool} manpage to ${D}/usr/share/man"
+ doman tools/flash-tool/flash-tool.8
+ fi
+
+ done
+
+ # lcdtools
+ for tool in paneld putlcd e2fsck-lcd; do
+ einfo "Installing ${tool} binary and manpage to ${D}/usr/sbin"
+ dosbin tools/lcdtools/${tool}/${tool}
+ doman tools/lcdtools/${tool}/${tool}.8
+ done
+ dolib.a tools/lcdtools/liblcd/liblcd.a
+
+ # bootscripts
+ dodir /usr/lib/colo/scripts
+ cp ${WORKDIR}/default.colo ${WORKDIR}/menu-linux.colo ${D}/usr/lib/colo/scripts
+}
+
+pkg_postinst() {
+ echo -e ""
+ einfo "Install locations:"
+ einfo " Binaries:\t/usr/lib/${PN}"
+ einfo " Docs:\t/usr/share/doc/${PF}"
+ einfo " Tools:\t/usr/sbin/{flash-tool,colo-perm,copy-rom,"
+ einfo " \tputlcd,paneld,e2fsck-lcd,elf2rfx}"
+ einfo " Scripts:\t/usr/lib/${PN}/scripts"
+ echo -e ""
+ einfo "Please read the docs to fully understand the behavior of this bootloader, and"
+ einfo "edit the boot scripts to suit your needs."
+ echo -e ""
+ ewarn "Users installing ${PN} for the first time need to be aware that newer"
+ ewarn "versions of ${PN} disable the serial port by default. If the serial port"
+ ewarn "is needed, select it from the boot menu. Users using the example boot"
+ ewarn "scripts provided will have the serial port automatically enabled."
+ echo -e ""
+ ewarn "Note: It is HIGHLY recommended that you use the chain"
+ ewarn "bootloader (colo-chain.elf) first before attempting to"
+ ewarn "write the bootloader to the flash chip to verify that"
+ ewarn "it will work for you. It is also recommended that"
+ ewarn "you read the documentation in /usr/share/doc/${PF}"
+ ewarn "as it explains how to properly use this package."
+ echo -e ""
+ eerror "Warning: Make sure that IF you plan on flashing the"
+ eerror "bootloader into the flash chip that you are using a"
+ eerror "modern 2.4 Linux kernel (i.e., >2.4.18), otherwise"
+ eerror "you run a risk of destroying the contents of the"
+ eerror "flash chip and rendering the machine unusable."
+ echo -e ""
+ echo -e ""
+}
diff --git a/sys-boot/colo/files/digest-colo-1.19 b/sys-boot/colo/files/digest-colo-1.19
new file mode 100644
index 000000000000..69a1b91cf9e8
--- /dev/null
+++ b/sys-boot/colo/files/digest-colo-1.19
@@ -0,0 +1 @@
+MD5 c4eec43ab581c803f52812f13a5b55bf colo-1.19.tar.gz 253487