summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2010-12-13 10:30:37 +0000
committerMike Frysinger <vapier@gentoo.org>2010-12-13 10:30:37 +0000
commite1c70d63d8c43a605574f38deadb44a43d1005d4 (patch)
tree579f2c005b9220d29d3cc68820d44f062b6edc33 /sys-block
parentold (diff)
downloadgentoo-2-e1c70d63d8c43a605574f38deadb44a43d1005d4.tar.gz
gentoo-2-e1c70d63d8c43a605574f38deadb44a43d1005d4.tar.bz2
gentoo-2-e1c70d63d8c43a605574f38deadb44a43d1005d4.zip
Version bump #338467 by Michaelian Ennis. Respect env build settings #336022 by Diego Elio Pettenò.
(Portage version: 2.2.0_alpha5/cvs/Linux x86_64)
Diffstat (limited to 'sys-block')
-rw-r--r--sys-block/aoetools/ChangeLog9
-rw-r--r--sys-block/aoetools/aoetools-32.ebuild26
-rw-r--r--sys-block/aoetools/files/aoetools-32-build.patch32
3 files changed, 66 insertions, 1 deletions
diff --git a/sys-block/aoetools/ChangeLog b/sys-block/aoetools/ChangeLog
index c5ef25e013ea..6594b0da1e3b 100644
--- a/sys-block/aoetools/ChangeLog
+++ b/sys-block/aoetools/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-block/aoetools
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-block/aoetools/ChangeLog,v 1.37 2010/06/02 07:04:59 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-block/aoetools/ChangeLog,v 1.38 2010/12/13 10:30:37 vapier Exp $
+
+*aoetools-32 (13 Dec 2010)
+
+ 13 Dec 2010; Mike Frysinger <vapier@gentoo.org> +aoetools-32.ebuild,
+ +files/aoetools-32-build.patch:
+ Version bump #338467 by Michaelian Ennis. Respect env build settings
+ #336022 by Diego Elio Pettenò.
02 Jun 2010; Torsten Veller <tove@gentoo.org> metadata.xml:
Remove caleb from metadata.xml (#317071)
diff --git a/sys-block/aoetools/aoetools-32.ebuild b/sys-block/aoetools/aoetools-32.ebuild
new file mode 100644
index 000000000000..a22a24ad9600
--- /dev/null
+++ b/sys-block/aoetools/aoetools-32.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-block/aoetools/aoetools-32.ebuild,v 1.1 2010/12/13 10:30:37 vapier Exp $
+
+EAPI="2"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="tools for ATA over Ethernet (AoE) network storage protocol"
+HOMEPAGE="http://aoetools.sourceforge.net/"
+SRC_URI="mirror://sourceforge/aoetools/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-32-build.patch
+ tc-export CC
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+ dodoc NEWS README
+}
diff --git a/sys-block/aoetools/files/aoetools-32-build.patch b/sys-block/aoetools/files/aoetools-32-build.patch
new file mode 100644
index 000000000000..abd2cce3d847
--- /dev/null
+++ b/sys-block/aoetools/files/aoetools-32-build.patch
@@ -0,0 +1,32 @@
+--- Makefile
++++ Makefile
+@@ -40,7 +40,7 @@
+ CONF_SCRIPTS = aoe-discover aoe-interfaces aoe-mkshelf aoe-revalidate aoe-flush aoe-stat
+ PROGS = aoeping aoecfg aoe-sancheck
+ COMMANDS := ${CONF_SCRIPTS} aoe-mkdevs aoe-version coraid-update ${PROGS}
+-CFLAGS = -Wall -O -g
++CFLAGS += $(CPPFLAGS)
+ SANCHECKLIBS = -lpthread
+
+ AOE_PING_OBJ = aoeping.o linux.o
+@@ -68,17 +68,17 @@
+ rm -f ${CONF_SCRIPTS} ${AOE_PING_OBJ} ${AOE_CFG_OBJ} ${SANCHECK_OBJ} ${PROGS}
+
+ aoeping : ${AOE_PING_OBJ}
+- ${CC} ${CFLAGS} -o $@ ${AOE_PING_OBJ}
++ ${CC} ${CFLAGS} ${LDFLAGS} -o $@ ${AOE_PING_OBJ}
+ aoeping.o : aoeping.c dat.h fns.h
+ ${CC} ${CFLAGS} -o $@ -c $<
+ linux.o : linux.c config.h
+ ${CC} ${CFLAGS} -o $@ -c $<
+ aoecfg: ${AOE_CFG_OBJ}
+- ${CC} ${CFLAGS} -o $@ ${AOE_CFG_OBJ}
++ ${CC} ${CFLAGS} ${LDFLAGS} -o $@ ${AOE_CFG_OBJ}
+ aoecfg.o : aoecfg.c dat.h fns.h
+ ${CC} ${CFLAGS} -o $@ -c $<
+ aoe-sancheck : ${SANCHECK_OBJ}
+- -$(CC) $(CFLAGS) -o $@ ${SANCHECK_OBJ} $(SANCHECKLIBS)
++ -$(CC) $(CFLAGS) ${LDFLAGS} -o $@ ${SANCHECK_OBJ} $(SANCHECKLIBS)
+ aoe-sancheck.o : aoe-sancheck.c
+ -$(CC) $(CFLAGS) -o $@ -c $<
+