summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2011-09-15 08:05:36 +0000
committerTim Harder <radhermit@gentoo.org>2011-09-15 08:05:36 +0000
commit8f084ee7976aa1f3af7451cf8cb19d08883ee736 (patch)
tree4db9d6fa442f1ffc13aaaf6773000aaeec3f17de /sys-block
parentRemoved deprecated --oknodo option (bug #377769). Replaced deprecated opts va... (diff)
downloadgentoo-2-8f084ee7976aa1f3af7451cf8cb19d08883ee736.tar.gz
gentoo-2-8f084ee7976aa1f3af7451cf8cb19d08883ee736.tar.bz2
gentoo-2-8f084ee7976aa1f3af7451cf8cb19d08883ee736.zip
Remove old.
(Portage version: 2.2.0_alpha55/cvs/Linux x86_64)
Diffstat (limited to 'sys-block')
-rw-r--r--sys-block/vblade/ChangeLog7
-rw-r--r--sys-block/vblade/files/init.d-vblade.vblade0-14114
-rw-r--r--sys-block/vblade/files/init.d-vblade.vblade0-14-r1114
-rw-r--r--sys-block/vblade/vblade-14-r1.ebuild43
-rw-r--r--sys-block/vblade/vblade-14.ebuild43
-rw-r--r--sys-block/vblade/vblade-18.ebuild38
6 files changed, 6 insertions, 353 deletions
diff --git a/sys-block/vblade/ChangeLog b/sys-block/vblade/ChangeLog
index ec72c3cce5ca..a7a979f196f8 100644
--- a/sys-block/vblade/ChangeLog
+++ b/sys-block/vblade/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-block/vblade
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-block/vblade/ChangeLog,v 1.28 2011/09/15 07:56:37 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-block/vblade/ChangeLog,v 1.29 2011/09/15 08:05:36 radhermit Exp $
+
+ 15 Sep 2011; Tim Harder <radhermit@gentoo.org>
+ -files/init.d-vblade.vblade0-14, -vblade-14.ebuild,
+ -files/init.d-vblade.vblade0-14-r1, -vblade-14-r1.ebuild, -vblade-18.ebuild:
+ Remove old.
*vblade-20 (15 Sep 2011)
diff --git a/sys-block/vblade/files/init.d-vblade.vblade0-14 b/sys-block/vblade/files/init.d-vblade.vblade0-14
deleted file mode 100644
index dc22c9f17463..000000000000
--- a/sys-block/vblade/files/init.d-vblade.vblade0-14
+++ /dev/null
@@ -1,114 +0,0 @@
-#!/sbin/runscript
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/sys-block/vblade/files/init.d-vblade.vblade0-14,v 1.1 2007/03/07 19:49:54 robbat2 Exp $
-
-opts="${opts} checkconfig"
-
-depend() {
- need net
-}
-
-conf="$(add_suffix /etc/conf.d/vblade)"
-[[ -e "${conf}" ]] && source "${conf}"
-vblade_name="${myservice#*.}"
-vblade_conf_variable="config_${vblade_name}"
-vblade_conf="${!vblade_conf_variable}"
-pidfile="/var/run/vblade-${vblade_name}.pid"
-srvname="vblade.${vblade_name}"
-
-getconfig() {
- tmp="${vblade_conf}"
- shelf="${tmp/ *}"
- tmp="${tmp#* }"
- slot="${tmp/ *}"
- tmp="${tmp#* }"
- netif="${tmp/ *}"
- tmp="${tmp#* }"
- src="${tmp}"
- export shelf slot netif src
-}
-
-
-checkconfig() {
- if [ -z "${vblade_conf}" ]; then
- eerror "vblade configuration not specified for ${vblade_name}"
- return 1
- fi
- getconfig
-
- is_valid_numeric "${shelf}" 0
- if [[ $? -ne 0 ]]; then
- eerror "Shelf '${shelf}' is non-numeric or less than zero."
- return 1
- fi
- is_valid_numeric "${slot}" 0 15
- if [[ $? -ne 0 ]]; then
- eerror "Slot '${slot}' is outside the valid range [0..15]."
- return 1
- fi
-
- sysfs_base="/sys/class/net/"
- procfs_base="/proc/sys/net/ipv4/conf/"
- if test ! \( -e "${sysfs_base}${netif}" -o -e "${procfs_base}${netif}" \); then
- eerror "Network interface '${netif}' does not exist"
- return 1
- fi
-
- if test ! \( -f "${src}" -o -b "${src}" \) ; then
- eerror "Source '${src}' must be a file or block device"
- return 1
- fi
-
- if test ! \( -e "${src}" -a -r "${src}" \) ; then
- eerror "Source '${src}' is not readable."
- return 1
- fi
-
- return 0
-}
-
-is_valid_numeric() {
- num="${1}"
- min="${2}"
- max="${3}"
- # non-numeric
- test "$num" -ge "0" 2>/dev/null
- rc=$?
- test "$rc" -eq 2 && return 2
- # check for min
- test -z "$min" && return 0
- test "$num" -lt "$min" && return 1
- # check for max
- test -z "$max" && return 0
- test "$num" -gt "$max" && return 1
- # done
- return 0
-}
-
-start() {
- checkconfig || return 1
- getconfig
- ebegin "Starting ${srvname}: e${shelf}.${slot} on ${netif} using '${src}'"
- export LOGTAG="${srvname}"
- start-stop-daemon --start --quiet \
- --pidfile ${pidfile} --background \
- --make-pidfile --exec /usr/sbin/vbladed -- \
- ${shelf} ${slot} ${netif} "${src}"
- eend $?
-
- #${shelf} ${slot} ${netif} "${src}" 2>&1 | logger -t ${srvname} &
-}
-
-stop() {
- ebegin "Stopping ${srvname}"
- #start-stop-daemon --stop --quiet --pidfile ${pidfile}
- getconfig
- ps -Ao pid,args | egrep "^[[:space:]]*[[:digit:]]+ /usr/sbin/vblade ${shelf} ${slot} ${netif} ${src}" | awk '{print $1}' | xargs kill
- eend $?
-
- #start-stop-daemon --stop --quiet --exec /usr/sbin/vblade
-}
-
-# vim: ft=gentoo-init-d syntax=gentoo-init-d :
-# vim: ai sw=4 sts=4 ts=4 :
diff --git a/sys-block/vblade/files/init.d-vblade.vblade0-14-r1 b/sys-block/vblade/files/init.d-vblade.vblade0-14-r1
deleted file mode 100644
index 93d0a92b251a..000000000000
--- a/sys-block/vblade/files/init.d-vblade.vblade0-14-r1
+++ /dev/null
@@ -1,114 +0,0 @@
-#!/sbin/runscript
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/sys-block/vblade/files/init.d-vblade.vblade0-14-r1,v 1.1 2008/07/05 09:53:39 robbat2 Exp $
-
-opts="${opts} checkconfig"
-
-depend() {
- need net
-}
-
-conf="$(add_suffix /etc/conf.d/vblade)"
-[[ -e "${conf}" ]] && source "${conf}"
-vblade_name="${myservice#*.}"
-vblade_conf_variable="config_${vblade_name}"
-vblade_conf="${!vblade_conf_variable}"
-pidfile="/var/run/vblade-${vblade_name}.pid"
-srvname="vblade.${vblade_name}"
-
-getconfig() {
- tmp="${vblade_conf}"
- shelf="${tmp/ *}"
- tmp="${tmp#* }"
- slot="${tmp/ *}"
- tmp="${tmp#* }"
- netif="${tmp/ *}"
- tmp="${tmp#* }"
- src="${tmp}"
- export shelf slot netif src
-}
-
-
-checkconfig() {
- if [ -z "${vblade_conf}" ]; then
- eerror "vblade configuration not specified for ${vblade_name}"
- return 1
- fi
- getconfig
-
- is_valid_numeric "${shelf}" 0
- if [[ $? -ne 0 ]]; then
- eerror "Shelf '${shelf}' is non-numeric or less than zero."
- return 1
- fi
- is_valid_numeric "${slot}" 0 15
- if [[ $? -ne 0 ]]; then
- eerror "Slot '${slot}' is outside the valid range [0..15]."
- return 1
- fi
-
- sysfs_base="/sys/class/net/"
- procfs_base="/proc/sys/net/ipv4/conf/"
- if test ! \( -e "${sysfs_base}${netif}" -o -e "${procfs_base}${netif}" \); then
- eerror "Network interface '${netif}' does not exist"
- return 1
- fi
-
- if test ! \( -f "${src}" -o -b "${src}" \) ; then
- eerror "Source '${src}' must be a file or block device"
- return 1
- fi
-
- if test ! \( -e "${src}" -a -r "${src}" \) ; then
- eerror "Source '${src}' is not readable."
- return 1
- fi
-
- return 0
-}
-
-is_valid_numeric() {
- num="${1}"
- min="${2}"
- max="${3}"
- # non-numeric
- test "$num" -ge "0" 2>/dev/null
- rc=$?
- test "$rc" -eq 2 && return 2
- # check for min
- test -z "$min" && return 0
- test "$num" -lt "$min" && return 1
- # check for max
- test -z "$max" && return 0
- test "$num" -gt "$max" && return 1
- # done
- return 0
-}
-
-start() {
- checkconfig || return 1
- getconfig
- ebegin "Starting ${srvname}: e${shelf}.${slot} on ${netif} using '${src}'"
- export LOGTAG="${srvname}"
- start-stop-daemon --start --quiet \
- --pidfile ${pidfile} --background \
- --make-pidfile --exec /usr/sbin/vbladed -- \
- ${shelf} ${slot} ${netif} "${src}"
- eend $?
-
- #${shelf} ${slot} ${netif} "${src}" 2>&1 | logger -t ${srvname} &
-}
-
-stop() {
- ebegin "Stopping ${srvname}"
- #start-stop-daemon --stop --quiet --pidfile ${pidfile}
- getconfig
- ps -Ao pid,args | egrep "^[[:space:]]*[[:digit:]]+ /usr/sbin/vbladed? ${shelf} ${slot}" | awk '{print $1}' | xargs kill
- eend $?
-
- #start-stop-daemon --stop --quiet --exec /usr/sbin/vblade
-}
-
-# vim: ft=gentoo-init-d syntax=gentoo-init-d :
-# vim: ai sw=4 sts=4 ts=4 :
diff --git a/sys-block/vblade/vblade-14-r1.ebuild b/sys-block/vblade/vblade-14-r1.ebuild
deleted file mode 100644
index a983b7239a5f..000000000000
--- a/sys-block/vblade/vblade-14-r1.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-block/vblade/vblade-14-r1.ebuild,v 1.2 2009/09/23 20:33:58 patrick Exp $
-
-inherit eutils
-
-DESCRIPTION="vblade exports a block device using AoE"
-HOMEPAGE="http://sf.net/projects/aoetools/"
-#SRC_URI="mirror://sourceforge/aoetools/${P}.tar.gz"
-SRC_URI="mirror://sourceforge/aoetools/${P}.tgz"
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
-IUSE=""
-DEPEND=""
-RDEPEND="${DEPEND}
- sys-apps/util-linux"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- # messy tarball
- make clean || die "Failed to clean up source"
- sed -i 's,^CFLAGS.*,CFLAGS += -Wall,' makefile || die "Failed to clean up makefile"
-}
-src_compile() {
- emake || die "emake failed"
-}
-
-src_install() {
- into /usr
- doman vblade.8
- dodoc HACKING NEWS README
- dosbin vblade
- dosbin "${FILESDIR}"/vbladed
- newconfd "${FILESDIR}"/conf.d-vblade vblade
- newinitd "${FILESDIR}"/init.d-vblade.vblade0-14-r1 vblade.vblade0
-}
-
-pkg_postinst() {
- einfo "We do now include an init.d script, please look in your init.d and"
- einfo "conf.d directories for it."
-}
diff --git a/sys-block/vblade/vblade-14.ebuild b/sys-block/vblade/vblade-14.ebuild
deleted file mode 100644
index 1cc5989a5a04..000000000000
--- a/sys-block/vblade/vblade-14.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-block/vblade/vblade-14.ebuild,v 1.7 2009/09/23 20:33:58 patrick Exp $
-
-inherit eutils
-
-DESCRIPTION="vblade exports a block device using AoE"
-HOMEPAGE="http://sf.net/projects/aoetools/"
-#SRC_URI="mirror://sourceforge/aoetools/${P}.tar.gz"
-SRC_URI="mirror://sourceforge/aoetools/${P}.tgz"
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ppc ppc64 x86"
-IUSE=""
-DEPEND=""
-RDEPEND="${DEPEND}
- sys-apps/util-linux"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- # messy tarball
- make clean || die "Failed to clean up source"
- sed -i 's,^CFLAGS.*,CFLAGS += -Wall,' makefile || die "Failed to clean up makefile"
-}
-src_compile() {
- emake || die "emake failed"
-}
-
-src_install() {
- into /usr
- doman vblade.8
- dodoc HACKING NEWS README
- dosbin vblade
- dosbin "${FILESDIR}"/vbladed
- newconfd "${FILESDIR}"/conf.d-vblade vblade
- newinitd "${FILESDIR}"/init.d-vblade.vblade0-14 vblade.vblade0
-}
-
-pkg_postinst() {
- einfo "We do now include an init.d script, please look in your init.d and"
- einfo "conf.d directories for it."
-}
diff --git a/sys-block/vblade/vblade-18.ebuild b/sys-block/vblade/vblade-18.ebuild
deleted file mode 100644
index d8f68320c05d..000000000000
--- a/sys-block/vblade/vblade-18.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-block/vblade/vblade-18.ebuild,v 1.2 2009/09/23 20:33:58 patrick Exp $
-
-inherit eutils
-
-DESCRIPTION="vblade exports a block device using AoE"
-HOMEPAGE="http://sf.net/projects/aoetools/"
-#SRC_URI="mirror://sourceforge/aoetools/${P}.tar.gz"
-SRC_URI="mirror://sourceforge/aoetools/${P}.tgz"
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
-IUSE=""
-DEPEND=""
-RDEPEND="${DEPEND}
- sys-apps/util-linux"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- # messy tarball
- make clean || die "Failed to clean up source"
- sed -i 's,^CFLAGS.*,CFLAGS += -Wall,' makefile || die "Failed to clean up makefile"
-}
-src_compile() {
- emake || die "emake failed"
-}
-
-src_install() {
- into /usr
- doman vblade.8
- dodoc HACKING NEWS README
- dosbin vblade
- dosbin "${FILESDIR}"/vbladed
- newconfd "${FILESDIR}"/conf.d-vblade vblade
- newinitd "${FILESDIR}"/init.d-vblade.vblade0 vblade.vblade0
-}