summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Alexander <wired@gentoo.org>2009-08-04 11:14:00 +0000
committerAlex Alexander <wired@gentoo.org>2009-08-04 11:14:00 +0000
commitfa311db7483ec9339b4534179b05ff9bf429268b (patch)
tree4ce2267e6a673a5352fe1349e5874cbdffda1c2b /sys-auth
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-fa311db7483ec9339b4534179b05ff9bf429268b.tar.gz
gentoo-2-fa311db7483ec9339b4534179b05ff9bf429268b.tar.bz2
gentoo-2-fa311db7483ec9339b4534179b05ff9bf429268b.zip
new ebuild for policykit-qt
(Portage version: 2.2_rc35/cvs/Linux x86_64)
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/policykit-qt/ChangeLog10
-rw-r--r--sys-auth/policykit-qt/metadata.xml5
-rw-r--r--sys-auth/policykit-qt/policykit-qt-0.9.2.ebuild35
3 files changed, 50 insertions, 0 deletions
diff --git a/sys-auth/policykit-qt/ChangeLog b/sys-auth/policykit-qt/ChangeLog
new file mode 100644
index 000000000000..0ffd09ea82ea
--- /dev/null
+++ b/sys-auth/policykit-qt/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sys-auth/policykit-qt
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/policykit-qt/ChangeLog,v 1.1 2009/08/04 11:14:00 wired Exp $
+
+*policykit-qt-0.9.2 (04 Aug 2009)
+
+ 04 Aug 2009; Alex Alexander <wired@gentoo.org> +policykit-qt-0.9.2.ebuild,
+ +metadata.xml:
+ new ebuild for policykit-qt (from kde-testing overlay)
+
diff --git a/sys-auth/policykit-qt/metadata.xml b/sys-auth/policykit-qt/metadata.xml
new file mode 100644
index 000000000000..8d1e86a9cefb
--- /dev/null
+++ b/sys-auth/policykit-qt/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>kde</herd>
+</pkgmetadata>
diff --git a/sys-auth/policykit-qt/policykit-qt-0.9.2.ebuild b/sys-auth/policykit-qt/policykit-qt-0.9.2.ebuild
new file mode 100644
index 000000000000..878ad80b92cb
--- /dev/null
+++ b/sys-auth/policykit-qt/policykit-qt-0.9.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/policykit-qt/policykit-qt-0.9.2.ebuild,v 1.1 2009/08/04 11:14:00 wired Exp $
+
+EAPI="2"
+
+inherit cmake-utils
+
+MY_P="polkit-qt-${PV}"
+
+DESCRIPTION="PolicyKit Qt4 API wrapper library."
+HOMEPAGE="http://kde.org/"
+SRC_URI="mirror://kde/stable/apps/KDE4.x/admin/${MY_P}.tar.bz2"
+
+LICENSE="LGPL-2"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="debug examples"
+
+RDEPEND="
+ >=sys-auth/policykit-0.8
+ >=x11-libs/qt-gui-4.4:4[dbus]
+"
+DEPEND="${RDEPEND}
+ kde-base/automoc
+"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_build examples)"
+
+ cmake-utils_src_configure
+}