summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2011-10-06 14:35:03 +0000
committerHanno Böck <hanno@gentoo.org>2011-10-06 14:35:03 +0000
commit67e19b1c069f1ed8ff43378a083a2a132cec9f35 (patch)
tree231dc60562a56e249755d921c99a7c9b6f7ead9b /sys-auth
parentVersion bump. (diff)
downloadgentoo-2-67e19b1c069f1ed8ff43378a083a2a132cec9f35.tar.gz
gentoo-2-67e19b1c069f1ed8ff43378a083a2a132cec9f35.tar.bz2
gentoo-2-67e19b1c069f1ed8ff43378a083a2a132cec9f35.zip
pam_mount bump
(Portage version: 2.1.10.21/cvs/Linux x86_64)
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/pam_mount/ChangeLog7
-rw-r--r--sys-auth/pam_mount/pam_mount-2.12.ebuild41
2 files changed, 47 insertions, 1 deletions
diff --git a/sys-auth/pam_mount/ChangeLog b/sys-auth/pam_mount/ChangeLog
index 873413dac2d3..735b1c0ef0a3 100644
--- a/sys-auth/pam_mount/ChangeLog
+++ b/sys-auth/pam_mount/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-auth/pam_mount
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_mount/ChangeLog,v 1.60 2011/09/04 13:50:03 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_mount/ChangeLog,v 1.61 2011/10/06 14:35:03 hanno Exp $
+
+*pam_mount-2.12 (06 Oct 2011)
+
+ 06 Oct 2011; Hanno Boeck <hanno@gentoo.org> +pam_mount-2.12.ebuild:
+ Version bump.
04 Sep 2011; Markus Meier <maekke@gentoo.org> pam_mount-2.11.ebuild:
x86 stable, bug #380783
diff --git a/sys-auth/pam_mount/pam_mount-2.12.ebuild b/sys-auth/pam_mount/pam_mount-2.12.ebuild
new file mode 100644
index 000000000000..0e95d8f6cc4c
--- /dev/null
+++ b/sys-auth/pam_mount/pam_mount-2.12.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_mount/pam_mount-2.12.ebuild,v 1.1 2011/10/06 14:35:03 hanno Exp $
+
+EAPI=4
+
+inherit multilib
+
+DESCRIPTION="A PAM module that can mount volumes for a user session"
+HOMEPAGE="http://pam-mount.sourceforge.net"
+SRC_URI="mirror://sourceforge/pam-mount/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+IUSE="crypt ssl selinux"
+
+COMMON_DEPEND=">=sys-libs/pam-0.99
+ >=sys-libs/libhx-3.11
+ >=dev-libs/libxml2-2.6
+ crypt? ( >=sys-fs/cryptsetup-1.1.0 )
+ ssl? ( >=dev-libs/openssl-0.9.8 )
+ selinux? ( sys-libs/libselinux )"
+DEPEND="${COMMON_DEPEND}
+ dev-util/pkgconfig
+ app-arch/xz-utils"
+RDEPEND="${COMMON_DEPEND}"
+
+src_configure() {
+ econf --with-slibdir="/$(get_libdir)" \
+ $(use_with crypt cryptsetup) \
+ $(use_with ssl crypto) \
+ $(use_with selinux)
+}
+
+src_install() {
+ default
+ use selinux || rm -r "${D}"/etc/selinux
+ dodoc doc/*.txt
+}