summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-02-27 10:59:24 +0000
committerMike Frysinger <vapier@gentoo.org>2008-02-27 10:59:24 +0000
commit7eee4dce4ef3205b404704d79bdaf14b7c1e0d28 (patch)
treeea8e7dcc5d7813344dacc13056cb64c54c7e3528 /sys-auth/tfm-fingerprint
parentx11-drivers/xf86-video-i810: bump to 2.2.1 (diff)
downloadgentoo-2-7eee4dce4ef3205b404704d79bdaf14b7c1e0d28.tar.gz
gentoo-2-7eee4dce4ef3205b404704d79bdaf14b7c1e0d28.tar.bz2
gentoo-2-7eee4dce4ef3205b404704d79bdaf14b7c1e0d28.zip
fix old bug: uninstalling with mod_install takes filename, not full path
(Portage version: 2.2_pre2)
Diffstat (limited to 'sys-auth/tfm-fingerprint')
-rw-r--r--sys-auth/tfm-fingerprint/tfm-fingerprint-1.0.ebuild9
1 files changed, 6 insertions, 3 deletions
diff --git a/sys-auth/tfm-fingerprint/tfm-fingerprint-1.0.ebuild b/sys-auth/tfm-fingerprint/tfm-fingerprint-1.0.ebuild
index fc49bd04c1d3..60b33579426b 100644
--- a/sys-auth/tfm-fingerprint/tfm-fingerprint-1.0.ebuild
+++ b/sys-auth/tfm-fingerprint/tfm-fingerprint-1.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/tfm-fingerprint/tfm-fingerprint-1.0.ebuild,v 1.2 2008/02/27 10:40:13 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/tfm-fingerprint/tfm-fingerprint-1.0.ebuild,v 1.3 2008/02/27 10:59:24 vapier Exp $
inherit multilib
@@ -35,6 +35,9 @@ pkg_postinst() {
elog "Note: You have to be in the group usb to access the fingerprint device."
}
-pkg_prerm() {
- doit_with_ewarn mod_install -fu /usr/$(get_libdir)/libtfmessbsp.so
+pkg_postrm() {
+ # only do this if uninstalling
+ if ! has_version ${CATEGORY}/${PN} ; then
+ doit_with_ewarn mod_install -fu libtfmessbsp.so
+ fi
}