summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2011-01-26 19:47:46 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2011-01-26 19:47:46 +0000
commitfb5cd5941539919d18fde9fe52573eeb1e2374e2 (patch)
tree83685444d3f660f2bf0e5a0b4e8947c0106e2976 /sys-auth/polkit-qt
parentAdd Prefix keywords (diff)
downloadgentoo-2-fb5cd5941539919d18fde9fe52573eeb1e2374e2.tar.gz
gentoo-2-fb5cd5941539919d18fde9fe52573eeb1e2374e2.tar.bz2
gentoo-2-fb5cd5941539919d18fde9fe52573eeb1e2374e2.zip
[sys-auth/polkit-qt] Version bump for kde sc 4.6.0
(Portage version: 2.2.0_alpha19_p2/cvs/Linux x86_64)
Diffstat (limited to 'sys-auth/polkit-qt')
-rw-r--r--sys-auth/polkit-qt/ChangeLog9
-rw-r--r--sys-auth/polkit-qt/polkit-qt-0.99.0.ebuild42
2 files changed, 49 insertions, 2 deletions
diff --git a/sys-auth/polkit-qt/ChangeLog b/sys-auth/polkit-qt/ChangeLog
index 6f8d7bf47f2c..6e6db52bee45 100644
--- a/sys-auth/polkit-qt/ChangeLog
+++ b/sys-auth/polkit-qt/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-auth/polkit-qt
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/polkit-qt/ChangeLog,v 1.12 2010/09/12 16:36:50 phajdan.jr Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/polkit-qt/ChangeLog,v 1.13 2011/01/26 19:47:46 alexxy Exp $
+
+*polkit-qt-0.99.0 (26 Jan 2011)
+
+ 26 Jan 2011; Alexey Shvetsov <alexxy@gentoo.org> +polkit-qt-0.99.0.ebuild:
+ Version bump for kde sc 4.6.0
12 Sep 2010; Pawel Hajdan jr <phajdan.jr@gentoo.org>
polkit-qt-0.96.1.ebuild:
diff --git a/sys-auth/polkit-qt/polkit-qt-0.99.0.ebuild b/sys-auth/polkit-qt/polkit-qt-0.99.0.ebuild
new file mode 100644
index 000000000000..46f7b4c3fd0c
--- /dev/null
+++ b/sys-auth/polkit-qt/polkit-qt-0.99.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/polkit-qt/polkit-qt-0.99.0.ebuild,v 1.1 2011/01/26 19:47:46 alexxy Exp $
+
+EAPI="3"
+
+MY_P="${P/qt/qt-1}"
+
+inherit cmake-utils
+
+DESCRIPTION="PolicyKit Qt4 API wrapper library."
+HOMEPAGE="http://kde.org/"
+SRC_URI="mirror://kde/stable/apps/KDE4.x/admin/${MY_P}.tar.bz2"
+
+LICENSE="LGPL-2"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="debug examples"
+
+COMMON_DEPEND="
+ dev-libs/glib:2
+ >=sys-auth/polkit-0.99
+ x11-libs/qt-core
+ x11-libs/qt-gui[dbus]
+"
+DEPEND="${COMMON_DEPEND}
+ dev-util/automoc
+"
+RDEPEND="${COMMON_DEPEND}
+ examples? ( !sys-auth/policykit-qt[examples] )
+"
+
+DOCS=(AUTHORS README README.porting TODO)
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_build examples)
+ )
+ cmake-utils_src_configure
+}