summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-03-08 19:49:11 +0000
committerMike Frysinger <vapier@gentoo.org>2009-03-08 19:49:11 +0000
commitf04db63b04a097a69707775fe302e066b7399df0 (patch)
tree6960bdff8242260d4b8421c99ea7145eb1cef6eb /sys-auth/bioapi
parentDrop KDE 4.2.0 (diff)
downloadgentoo-2-f04db63b04a097a69707775fe302e066b7399df0.tar.gz
gentoo-2-f04db63b04a097a69707775fe302e066b7399df0.tar.bz2
gentoo-2-f04db63b04a097a69707775fe302e066b7399df0.zip
Do not let mod_install delete symlinks as that is the job of portage.
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'sys-auth/bioapi')
-rw-r--r--sys-auth/bioapi/ChangeLog10
-rw-r--r--sys-auth/bioapi/bioapi-1.2.3-r2.ebuild84
-rw-r--r--sys-auth/bioapi/files/bioapi-1.2.3-no-delete.patch15
3 files changed, 107 insertions, 2 deletions
diff --git a/sys-auth/bioapi/ChangeLog b/sys-auth/bioapi/ChangeLog
index 479c70ee1db0..86dd30922810 100644
--- a/sys-auth/bioapi/ChangeLog
+++ b/sys-auth/bioapi/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-auth/bioapi
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/bioapi/ChangeLog,v 1.9 2008/10/26 19:13:05 maekke Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/bioapi/ChangeLog,v 1.10 2009/03/08 19:49:11 vapier Exp $
+
+*bioapi-1.2.3-r2 (08 Mar 2009)
+
+ 08 Mar 2009; Mike Frysinger <vapier@gentoo.org>
+ +files/bioapi-1.2.3-no-delete.patch, +bioapi-1.2.3-r2.ebuild:
+ Do not let mod_install delete symlinks as that is the job of portage.
26 Oct 2008; Markus Meier <maekke@gentoo.org> bioapi-1.2.3-r1.ebuild:
amd64/x86 stable, bug #244447
diff --git a/sys-auth/bioapi/bioapi-1.2.3-r2.ebuild b/sys-auth/bioapi/bioapi-1.2.3-r2.ebuild
new file mode 100644
index 000000000000..919439f07c29
--- /dev/null
+++ b/sys-auth/bioapi/bioapi-1.2.3-r2.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/bioapi/bioapi-1.2.3-r2.ebuild,v 1.1 2009/03/08 19:49:11 vapier Exp $
+
+inherit eutils multilib
+
+DESCRIPTION="Framework for biometric-based authentication"
+HOMEPAGE="http://code.google.com/p/bioapi-linux/"
+SRC_URI="http://bioapi-linux.googlecode.com/files/${PN}_${PV}.tar.gz"
+
+LICENSE="bioapi"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="qt3"
+
+DEPEND="qt3? ( =x11-libs/qt-3* )"
+
+S=${WORKDIR}/bioapi-linux
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-enroll-ret.patch #236654
+ epatch "${FILESDIR}"/${P}-no-delete.patch
+}
+
+src_compile() {
+ econf $(use_with qt3 Qt-dir /usr/qt/3) || die "./configure failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake SKIPCONFIG=true DESTDIR="${D}" install || die "install failed"
+ dodoc README
+ dohtml *.htm
+
+ # rename generic binaries
+ mv "${D}"/usr/bin/{,BioAPI}Sample || die
+ if use qt3 ; then
+ mv "${D}"/usr/bin/{,BioAPI}QSample || die
+ fi
+}
+
+pkg_config() {
+ mds_install -s /usr/$(get_libdir)
+ mod_install -fi /usr/$(get_libdir)/libbioapi100.so
+ mod_install -fi /usr/$(get_libdir)/libbioapi_dummy100.so
+ mod_install -fi /usr/$(get_libdir)/libpwbsp.so
+ use qt3 && mod_install -fi /usr/$(get_libdir)/libqtpwbsp.so
+}
+
+pkg_preinst() {
+ if [[ -e ${ROOT}/var/bioapi ]] && [[ ! -e ${ROOT}/var/lib/bioapi ]] ; then
+ einfo "Moving /var/bioapi to /var/lib/bioapi"
+ dodir /var/lib
+ mv "${ROOT}"/var/bioapi "${ROOT}"/var/lib/bioapi
+ fi
+}
+
+pkg_postinst() {
+ einfo "Some generic-named programs have been renamed:"
+ einfo " Sample -> BioAPISample"
+ einfo " QSample -> BioAPIQSample"
+
+ if [[ ${ROOT} == "/" ]] ; then
+ pkg_config
+ else
+ ewarn "You will need to run 'emerge --config bioapi' before"
+ ewarn " you can use bioapi properly."
+ fi
+
+ # XXX: this can't be correct ...
+ enewgroup bioapi
+ chgrp bioapi "${ROOT}"/var/lib/bioapi -R
+ chmod g+w,o= "${ROOT}"/var/lib/bioapi -R
+ einfo "Note: users using bioapi must be in group bioapi."
+}
+
+pkg_prerm() {
+ mod_install -fu libbioapi100.so
+ mod_install -fu libbioapi_dummy100.so
+ mod_install -fu libpwbsp.so
+ use qt3 && mod_install -fu libqtpwbsp.so
+}
diff --git a/sys-auth/bioapi/files/bioapi-1.2.3-no-delete.patch b/sys-auth/bioapi/files/bioapi-1.2.3-no-delete.patch
new file mode 100644
index 000000000000..b5664d11ec3a
--- /dev/null
+++ b/sys-auth/bioapi/files/bioapi-1.2.3-no-delete.patch
@@ -0,0 +1,15 @@
+do not delete the installed symlink -- let the package manager handle that
+
+--- bioapi-linux/apps/mod_install/install.c
++++ bioapi-linux/apps/mod_install/install.c
+@@ -496,10 +496,6 @@
+ }
+ else if ( Action == INSTALL_ACTION_UNINSTALL )
+ {
+-/* Linux-Port: Added the Linux branch */
+-#if defined (LINUX) || defined (SOLARIS)
+- DeleteFile(szDstPath);
+-#endif
+ printf( "Module uninstalled successfully.\n" );
+ }
+ else if ( Action == INSTALL_ACTION_REFRESH )