summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2010-11-26 05:19:37 +0000
committerMike Frysinger <vapier@gentoo.org>2010-11-26 05:19:37 +0000
commitd20a9be4d48b8b07536d3123e6245c8517a2e44d (patch)
treea6333f9c0a5141fc4e5b58b84db6aba7f74dc213 /sys-auth/bioapi
parentBump to 0.9.22. Lots of bug fixes. Remove SRC_URI munging till a newer releas... (diff)
downloadgentoo-2-d20a9be4d48b8b07536d3123e6245c8517a2e44d.tar.gz
gentoo-2-d20a9be4d48b8b07536d3123e6245c8517a2e44d.tar.bz2
gentoo-2-d20a9be4d48b8b07536d3123e6245c8517a2e44d.zip
Respect build settings #336107 by Diego Elio Pettenò and make config.guess/config.sub into plain files #337805 by Ben Kero.
(Portage version: 2.2.0_alpha4/cvs/Linux x86_64)
Diffstat (limited to 'sys-auth/bioapi')
-rw-r--r--sys-auth/bioapi/ChangeLog7
-rw-r--r--sys-auth/bioapi/bioapi-1.2.3-r2.ebuild11
-rw-r--r--sys-auth/bioapi/files/bioapi-1.2.3-build.patch42
3 files changed, 55 insertions, 5 deletions
diff --git a/sys-auth/bioapi/ChangeLog b/sys-auth/bioapi/ChangeLog
index 478e65cf21cf..a90b53e62699 100644
--- a/sys-auth/bioapi/ChangeLog
+++ b/sys-auth/bioapi/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-auth/bioapi
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/bioapi/ChangeLog,v 1.13 2010/02/16 20:15:02 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/bioapi/ChangeLog,v 1.14 2010/11/26 05:19:37 vapier Exp $
+
+ 26 Nov 2010; Mike Frysinger <vapier@gentoo.org> bioapi-1.2.3-r2.ebuild,
+ +files/bioapi-1.2.3-build.patch:
+ Respect build settings #336107 by Diego Elio Pettenò and make
+ config.guess/config.sub into plain files #337805 by Ben Kero.
16 Feb 2010; Samuli Suominen <ssuominen@gentoo.org>
bioapi-1.2.3-r2.ebuild:
diff --git a/sys-auth/bioapi/bioapi-1.2.3-r2.ebuild b/sys-auth/bioapi/bioapi-1.2.3-r2.ebuild
index 7fe294724946..c113a348e810 100644
--- a/sys-auth/bioapi/bioapi-1.2.3-r2.ebuild
+++ b/sys-auth/bioapi/bioapi-1.2.3-r2.ebuild
@@ -1,8 +1,9 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/bioapi/bioapi-1.2.3-r2.ebuild,v 1.4 2010/02/16 20:15:02 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/bioapi/bioapi-1.2.3-r2.ebuild,v 1.5 2010/11/26 05:19:37 vapier Exp $
+
+EAPI="2"
-EAPI=2
inherit eutils multilib
DESCRIPTION="Framework for biometric-based authentication"
@@ -20,11 +21,13 @@ src_prepare() {
epatch "${FILESDIR}"/${P}-enroll-ret.patch #236654
epatch "${FILESDIR}"/${P}-no-delete.patch
epatch "${FILESDIR}"/${P}-gcc44.patch
+ epatch "${FILESDIR}"/${P}-build.patch #336107
+ rm -f config.{guess,sub} #337805
+ touch config.{guess,sub}
}
src_configure() {
- econf \
- --without-Qt-dir
+ econf --without-Qt-dir
}
src_install() {
diff --git a/sys-auth/bioapi/files/bioapi-1.2.3-build.patch b/sys-auth/bioapi/files/bioapi-1.2.3-build.patch
new file mode 100644
index 000000000000..9d679fe8c892
--- /dev/null
+++ b/sys-auth/bioapi/files/bioapi-1.2.3-build.patch
@@ -0,0 +1,42 @@
+http://code.google.com/p/bioapi-linux/issues/detail?id=4
+
+--- a/addins/pwbsp/Makefile.in
++++ b/addins/pwbsp/Makefile.in
+@@ -87,7 +87,7 @@ CC = @CC@
+ CCDEPMODE = @CCDEPMODE@
+ CFLAGS = @CFLAGS@
+ CPP = @CPP@
+-CPPFLAGS = -I${top_srcdir}/include/ \
++AM_CPPFLAGS = -I${top_srcdir}/include/ \
+ -I${top_srcdir}/imports/cdsa/v2_0/inc/
+
+ CXX = @CXX@
+@@ -111,7 +111,7 @@ INSTALL_DATA = @INSTALL_DATA@
+ INSTALL_PROGRAM = @INSTALL_PROGRAM@
+ INSTALL_SCRIPT = @INSTALL_SCRIPT@
+ INSTALL_STRIP_PROGRAM = @INSTALL_STRIP_PROGRAM@
+-LDFLAGS = -Wl,--version-script=${srcdir}/libpwbsp.ver
++AM_LDFLAGS = -Wl,--version-script=${srcdir}/libpwbsp.ver
+ LEX = @LEX@
+ LEXLIB = @LEXLIB@
+ LEX_OUTPUT_ROOT = @LEX_OUTPUT_ROOT@
+--- a/addins/qtpwbsp/Makefile.in
++++ b/addins/qtpwbsp/Makefile.in
+@@ -96,7 +96,7 @@ CC = @CC@
+ CCDEPMODE = @CCDEPMODE@
+ CFLAGS = @CFLAGS@
+ CPP = @CPP@
+-CPPFLAGS = -I${top_srcdir}/include \
++AM_CPPFLAGS = -I${top_srcdir}/include \
+ -I${top_srcdir}/imports/cdsa/v2_0/inc \
+ ${QT_CXXFLAGS}
+
+@@ -121,7 +121,7 @@ INSTALL_DATA = @INSTALL_DATA@
+ INSTALL_PROGRAM = @INSTALL_PROGRAM@
+ INSTALL_SCRIPT = @INSTALL_SCRIPT@
+ INSTALL_STRIP_PROGRAM = @INSTALL_STRIP_PROGRAM@
+-LDFLAGS = -Wl,--version-script=${srcdir}/libqtpwbsp.ver \
++AM_LDFLAGS = -Wl,--version-script=${srcdir}/libqtpwbsp.ver \
+ ${QT_LIBS}
+
+ LEX = @LEX@