summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2012-12-04 16:55:12 +0000
committerMichał Górny <mgorny@gentoo.org>2012-12-04 16:55:12 +0000
commitef50f0a98240e9d3918897d1634416054b92dd4f (patch)
treeb5ff62e84028de7cfd432eb3ff5aaaee8e415446 /sys-apps
parentbump, patches add dealing with building external packages, sed statements rep... (diff)
downloadgentoo-2-ef50f0a98240e9d3918897d1634416054b92dd4f.tar.gz
gentoo-2-ef50f0a98240e9d3918897d1634416054b92dd4f.tar.bz2
gentoo-2-ef50f0a98240e9d3918897d1634416054b92dd4f.zip
Do not require libgcrypt macros when gcrypt is disabled, bug #445920.
(Portage version: 2.2.0_alpha144/cvs/Linux x86_64, signed Manifest commit with key 42B9401D)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/systemd/ChangeLog7
-rw-r--r--sys-apps/systemd/files/196-0002-Don-t-fail-with-missing-gcrypt-macros.patch31
-rw-r--r--sys-apps/systemd/systemd-196.ebuild3
3 files changed, 39 insertions, 2 deletions
diff --git a/sys-apps/systemd/ChangeLog b/sys-apps/systemd/ChangeLog
index a1f1918e136e..75f8400a39a6 100644
--- a/sys-apps/systemd/ChangeLog
+++ b/sys-apps/systemd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/systemd
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/systemd/ChangeLog,v 1.61 2012/12/02 10:58:37 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/systemd/ChangeLog,v 1.62 2012/12/04 16:55:11 mgorny Exp $
+
+ 04 Dec 2012; Michał Górny <mgorny@gentoo.org>
+ +files/196-0002-Don-t-fail-with-missing-gcrypt-macros.patch,
+ systemd-196.ebuild:
+ Do not require libgcrypt macros when gcrypt is disabled, bug #445920.
*systemd-196 (02 Dec 2012)
diff --git a/sys-apps/systemd/files/196-0002-Don-t-fail-with-missing-gcrypt-macros.patch b/sys-apps/systemd/files/196-0002-Don-t-fail-with-missing-gcrypt-macros.patch
new file mode 100644
index 000000000000..694d3ef01138
--- /dev/null
+++ b/sys-apps/systemd/files/196-0002-Don-t-fail-with-missing-gcrypt-macros.patch
@@ -0,0 +1,31 @@
+From 94949efc89245ad8234d704ebb453e2f77605fd3 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
+Date: Tue, 4 Dec 2012 17:35:55 +0100
+Subject: [PATCH 2/2] Don't fail with missing gcrypt macros.
+
+---
+ configure.ac | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/configure.ac b/configure.ac
+index d0003bb..e804fdc 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -412,12 +412,14 @@ AC_ARG_ENABLE([gcrypt],
+ [have_gcrypt=auto])
+
+ if test "x${have_gcrypt}" != xno ; then
++m4_ifdef([AM_PATH_LIBGCRYPT], [
+ AM_PATH_LIBGCRYPT(
+ [1.4.5],
+ [have_gcrypt=yes],
+ [if test "x$have_gcrypt" = xyes ; then
+ AC_MSG_ERROR([*** GCRYPT headers not found.])
+ fi])
++])
+
+ if test "x$have_gcrypt" = xyes ; then
+ GCRYPT_LIBS="$LIBGCRYPT_LIBS"
+--
+1.8.0
+
diff --git a/sys-apps/systemd/systemd-196.ebuild b/sys-apps/systemd/systemd-196.ebuild
index a3e965ba3716..71ee768fbcc4 100644
--- a/sys-apps/systemd/systemd-196.ebuild
+++ b/sys-apps/systemd/systemd-196.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/systemd/systemd-196.ebuild,v 1.1 2012/12/02 10:58:37 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/systemd/systemd-196.ebuild,v 1.2 2012/12/04 16:55:11 mgorny Exp $
EAPI=4
@@ -75,6 +75,7 @@ src_prepare() {
local PATCHES=(
"${FILESDIR}"/196-0001-Disable-udev-targets.patch
+ "${FILESDIR}"/196-0002-Don-t-fail-with-missing-gcrypt-macros.patch
)
autotools-utils_src_prepare