summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2012-02-05 15:28:51 +0000
committerZac Medico <zmedico@gentoo.org>2012-02-05 15:28:51 +0000
commit97e3efc4bccecb5d36ca675418d33726f1240a7a (patch)
tree43fb6bc6e9a049c629e969cf43f1db64efc2f5fd /sys-apps
parentDrop sparc keywords (diff)
downloadgentoo-2-97e3efc4bccecb5d36ca675418d33726f1240a7a.tar.gz
gentoo-2-97e3efc4bccecb5d36ca675418d33726f1240a7a.tar.bz2
gentoo-2-97e3efc4bccecb5d36ca675418d33726f1240a7a.zip
Add preinst ewarn message for USE=xattr if pyxattr is not installed.
(Portage version: 2.2.0_alpha85/cvs/Linux i686)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/portage/ChangeLog6
-rw-r--r--sys-apps/portage/portage-2.1.10.45.ebuild13
-rw-r--r--sys-apps/portage/portage-2.2.0_alpha85.ebuild13
-rw-r--r--sys-apps/portage/portage-9999.ebuild15
4 files changed, 42 insertions, 5 deletions
diff --git a/sys-apps/portage/ChangeLog b/sys-apps/portage/ChangeLog
index 797a7c169420..991aa407e9a2 100644
--- a/sys-apps/portage/ChangeLog
+++ b/sys-apps/portage/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-apps/portage
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/ChangeLog,v 1.956 2012/02/04 23:48:51 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/ChangeLog,v 1.957 2012/02/05 15:28:51 zmedico Exp $
+
+ 05 Feb 2012; Zac Medico <zmedico@gentoo.org> portage-2.1.10.45.ebuild,
+ portage-2.2.0_alpha85.ebuild, portage-9999.ebuild:
+ Add preinst ewarn message for USE=xattr if pyxattr is not installed.
04 Feb 2012; Zac Medico <zmedico@gentoo.org> -portage-2.1.10.11.ebuild,
-portage-2.2.0_alpha81.ebuild:
diff --git a/sys-apps/portage/portage-2.1.10.45.ebuild b/sys-apps/portage/portage-2.1.10.45.ebuild
index f12c81276eee..beeed48420b1 100644
--- a/sys-apps/portage/portage-2.1.10.45.ebuild
+++ b/sys-apps/portage/portage-2.1.10.45.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/portage-2.1.10.45.ebuild,v 1.1 2012/02/04 23:07:41 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/portage-2.1.10.45.ebuild,v 1.2 2012/02/05 15:28:51 zmedico Exp $
# Require EAPI 2 since we now require at least python-2.6 (for python 3
# syntax support) which also requires EAPI 2.
@@ -86,6 +86,10 @@ compatible_python_is_selected() {
[[ $(/usr/bin/python -c 'import sys ; sys.stdout.write(sys.hexversion >= 0x2060000 and "good" or "bad")') = good ]]
}
+current_python_has_xattr() {
+ [[ $(/usr/bin/python -c 'import sys ; sys.stdout.write(sys.hexversion >= 0x3030000 and "yes" or "no")') = yes ]]
+}
+
pkg_setup() {
# Bug #359731 - Die early if get_libdir fails.
[[ -z $(get_libdir) ]] && \
@@ -317,6 +321,13 @@ pkg_preinst() {
fi
fi
+ if use xattr && ! current_python_has_xattr && \
+ ! has_version dev-python/pyxattr ; then
+ ewarn "For optimal performance in xattr handling, install"
+ ewarn "dev-python/pyxattr, or install >=dev-lang/python-3.3 and"
+ ewarn "enable USE=python3 for $CATEGORY/$PN."
+ fi
+
if ! use build && ! has_version dev-python/pycrypto && \
! has_version '>=dev-lang/python-2.6[ssl]' ; then
ewarn "If you are an ebuild developer and you plan to commit ebuilds"
diff --git a/sys-apps/portage/portage-2.2.0_alpha85.ebuild b/sys-apps/portage/portage-2.2.0_alpha85.ebuild
index a287ec235cb6..46f70cc4cbea 100644
--- a/sys-apps/portage/portage-2.2.0_alpha85.ebuild
+++ b/sys-apps/portage/portage-2.2.0_alpha85.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/portage-2.2.0_alpha85.ebuild,v 1.1 2012/02/04 23:09:38 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/portage-2.2.0_alpha85.ebuild,v 1.2 2012/02/05 15:28:51 zmedico Exp $
# Require EAPI 2 since we now require at least python-2.6 (for python 3
# syntax support) which also requires EAPI 2.
@@ -86,6 +86,10 @@ compatible_python_is_selected() {
[[ $(/usr/bin/python -c 'import sys ; sys.stdout.write(sys.hexversion >= 0x2060000 and "good" or "bad")') = good ]]
}
+current_python_has_xattr() {
+ [[ $(/usr/bin/python -c 'import sys ; sys.stdout.write(sys.hexversion >= 0x3030000 and "yes" or "no")') = yes ]]
+}
+
pkg_setup() {
# Bug #359731 - Die early if get_libdir fails.
[[ -z $(get_libdir) ]] && \
@@ -352,6 +356,13 @@ pkg_preinst() {
fi
fi
+ if use xattr && ! current_python_has_xattr && \
+ ! has_version dev-python/pyxattr ; then
+ ewarn "For optimal performance in xattr handling, install"
+ ewarn "dev-python/pyxattr, or install >=dev-lang/python-3.3 and"
+ ewarn "enable USE=python3 for $CATEGORY/$PN."
+ fi
+
if ! use build && ! has_version dev-python/pycrypto && \
! has_version '>=dev-lang/python-2.6[ssl]' ; then
ewarn "If you are an ebuild developer and you plan to commit ebuilds"
diff --git a/sys-apps/portage/portage-9999.ebuild b/sys-apps/portage/portage-9999.ebuild
index 5be1ce8c8829..a7d3ef084e31 100644
--- a/sys-apps/portage/portage-9999.ebuild
+++ b/sys-apps/portage/portage-9999.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/portage-9999.ebuild,v 1.40 2011/12/22 04:46:55 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/portage-9999.ebuild,v 1.41 2012/02/05 15:28:51 zmedico Exp $
EAPI=3
inherit git-2 eutils multilib python
@@ -69,6 +69,10 @@ compatible_python_is_selected() {
[[ $(/usr/bin/python -c 'import sys ; sys.stdout.write(sys.hexversion >= 0x2060000 and "good" or "bad")') = good ]]
}
+current_python_has_xattr() {
+ [[ $(/usr/bin/python -c 'import sys ; sys.stdout.write(sys.hexversion >= 0x3030000 and "yes" or "no")') = yes ]]
+}
+
pkg_setup() {
# Bug #359731 - Die early if get_libdir fails.
[[ -z $(get_libdir) ]] && \
@@ -325,6 +329,13 @@ pkg_preinst() {
fi
fi
+ if use xattr && ! current_python_has_xattr && \
+ ! has_version dev-python/pyxattr ; then
+ ewarn "For optimal performance in xattr handling, install"
+ ewarn "dev-python/pyxattr, or install >=dev-lang/python-3.3 and"
+ ewarn "enable USE=python3 for $CATEGORY/$PN."
+ fi
+
if ! use build && ! has_version dev-python/pycrypto && \
! has_version '>=dev-lang/python-2.6[ssl]' ; then
ewarn "If you are an ebuild developer and you plan to commit ebuilds"