summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2014-07-19 14:09:13 +0000
committerPacho Ramos <pacho@gentoo.org>2014-07-19 14:09:13 +0000
commit687198cdb2e3e557cf86f23dee9d8cd811612bf3 (patch)
treeb36ef36dd360b0ef0edba8e7afac462097539f18 /sys-apps
parentx86 stable wrt bug #515540 (diff)
downloadgentoo-2-687198cdb2e3e557cf86f23dee9d8cd811612bf3.tar.gz
gentoo-2-687198cdb2e3e557cf86f23dee9d8cd811612bf3.tar.bz2
gentoo-2-687198cdb2e3e557cf86f23dee9d8cd811612bf3.zip
Add unit file (#517348 by Jose Romildo Malaquias)
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/qingy/ChangeLog8
-rw-r--r--sys-apps/qingy/files/qingy_at.service21
-rw-r--r--sys-apps/qingy/qingy-1.0.0-r2.ebuild134
3 files changed, 162 insertions, 1 deletions
diff --git a/sys-apps/qingy/ChangeLog b/sys-apps/qingy/ChangeLog
index 311e93a8cf09..46c183e755e6 100644
--- a/sys-apps/qingy/ChangeLog
+++ b/sys-apps/qingy/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/qingy
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/qingy/ChangeLog,v 1.73 2014/03/01 22:37:55 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/qingy/ChangeLog,v 1.74 2014/07/19 14:09:13 pacho Exp $
+
+*qingy-1.0.0-r2 (19 Jul 2014)
+
+ 19 Jul 2014; Pacho Ramos <pacho@gentoo.org> +files/qingy_at.service,
+ +qingy-1.0.0-r2.ebuild:
+ Add unit file (#517348 by Jose Romildo Malaquias)
01 Mar 2014; Michał Górny <mgorny@gentoo.org> qingy-1.0.0-r1.ebuild,
qingy-1.0.0.ebuild:
diff --git a/sys-apps/qingy/files/qingy_at.service b/sys-apps/qingy/files/qingy_at.service
new file mode 100644
index 000000000000..b321d224a152
--- /dev/null
+++ b/sys-apps/qingy/files/qingy_at.service
@@ -0,0 +1,21 @@
+[Unit]
+Description=Qingy on %I
+Documentation=info:qingy
+After=systemd-user-sessions.service plymouth-quit-wait.service
+
+[Service]
+Environment=TERM=linux
+ExecStart=/sbin/qingy %I -n
+Type=idle
+Restart=always
+RestartSec=0
+UtmpIdentifier=%I
+TTYPath=/dev/%I
+TTYReset=yes
+TTYVHangup=yes
+TTYVTDisallocate=yes
+KillMode=process
+IgnoreSIGPIPE=no
+
+[Install]
+Alias=getty.target.wants/qingy@tty1.service
diff --git a/sys-apps/qingy/qingy-1.0.0-r2.ebuild b/sys-apps/qingy/qingy-1.0.0-r2.ebuild
new file mode 100644
index 000000000000..4336ed716442
--- /dev/null
+++ b/sys-apps/qingy/qingy-1.0.0-r2.ebuild
@@ -0,0 +1,134 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/qingy/qingy-1.0.0-r2.ebuild,v 1.1 2014/07/19 14:09:13 pacho Exp $
+
+EAPI=5
+inherit autotools elisp-common eutils pam systemd
+
+GENTOO_THEME_VERSION=2.1
+
+DESCRIPTION="a DirectFB getty replacement"
+HOMEPAGE="http://qingy.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2
+ mirror://gentoo/${PN}-gentoo-theme-${GENTOO_THEME_VERSION}.tar.bz2
+ http://dev.gentoo.org/~gienah/2big4tree/sys-apps/qingy/${P}-screensavers.patch.gz
+ http://dev.gentoo.org/~gienah/2big4tree/sys-apps/qingy/${P}-consolekit-pam.patch.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="consolekit crypt directfb emacs gpm opensslcrypt pam static X"
+
+RDEPEND=">=sys-libs/ncurses-5.7-r7:=
+ opensslcrypt? ( dev-libs/openssl:0= )
+ crypt? ( >=dev-libs/libgcrypt-1.2.1:0= )
+ directfb? ( >=dev-libs/DirectFB-1.4.2[fbcon,jpeg,png,truetype] )
+ emacs? ( virtual/emacs )
+ pam? ( >=sys-libs/pam-0.75-r11 )
+ X? (
+ x11-libs/libX11:=
+ x11-libs/libXScrnSaver:=
+ x11-proto/scrnsaverproto
+ )"
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4.1.4-r1
+ virtual/pkgconfig"
+RDEPEND="${RDEPEND}
+ consolekit? (
+ sys-auth/consolekit
+ sys-apps/dbus )
+ pam? ( sys-auth/pambase )"
+
+SITEFILE=50${PN}-gentoo.el
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-tinfo.patch
+ # bug #359637 and bug #462634 - fixes from upstream
+ epatch "${DISTDIR}"/${P}-screensavers.patch.gz
+ # bug #372675 - fix from upstream
+ epatch "${DISTDIR}"/${P}-consolekit-pam.patch.gz
+ eautoreconf
+}
+
+src_configure() {
+ local crypto_support="--disable-crypto"
+ local emacs_support="--disable-emacs --without-lispdir"
+
+ if use crypt && use opensslcrypt; then
+ echo
+ ewarn "You can have openssl or libgcrypt as a crypto library, not both."
+ ewarn "Using libgcrypt now..."
+ echo
+ fi
+
+ use emacs && emacs_support="--enable-emacs --with-lispdir=${SITELISP}/${PN}"
+ use opensslcrypt && crypto_support="--enable-crypto=openssl"
+ use crypt && crypto_support="--enable-crypto=libgcrypt"
+ econf \
+ --sbindir=/sbin \
+ --disable-optimizations \
+ $(use_enable consolekit) \
+ $(use_enable pam) \
+ $(use_enable static static-build) \
+ $(use_enable gpm gpm-lock) \
+ $(use_enable X x-support) \
+ $(use_enable directfb DirectFB-support ) \
+ ${crypto_support} \
+ ${emacs_support}
+}
+
+src_install() {
+ # Copy documentation manually as make install only installs info files
+ # INSTALL is left because it contains also configuration informations
+ dodoc AUTHORS ChangeLog INSTALL NEWS README THANKS TODO
+
+ # Install the program
+ emake DESTDIR="${D}" install
+
+ # Set the settings file umask to 600, in case somebody
+ # wants to make use of the autologin feature
+ /bin/chmod 600 "${D}"/etc/qingy/settings
+
+ # Install Gentoo theme
+ dodir /usr/share/${PN}/themes/gentoo
+ cp "${WORKDIR}"/gentoo/* "${D}"/usr/share/${PN}/themes/gentoo || die
+
+ # Alter config file so that it uses our theme
+ sed -i 's/theme = "default"/theme = "gentoo"/' "${D}"/etc/${PN}/settings
+
+ # Install log rotation policy
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}"/${PN}-logrotate ${PN}
+
+ use emacs && elisp-site-file-install "${FILESDIR}"/${SITEFILE}
+
+ rm "${D}"/etc/pam.d/qingy
+ pamd_mimic system-local-login qingy auth account password session
+
+ systemd_newunit "${FILESDIR}/${PN}_at.service" "${PN}@.service"
+}
+
+pkg_postinst() {
+ einfo "In order to use qingy you must first edit your /etc/inittab"
+ einfo "Check the documentation at ${HOMEPAGE}"
+ einfo "for instructions on how to do that."
+ echo
+ einfo "Also, make sure to adjust qingy settings file (/etc/qingy/settings)"
+ einfo "to your preferences/machine configuration..."
+
+ if use crypt; then
+ echo
+ einfo "You will have to create a key pair using 'qingy-keygen'"
+ echo
+ ewarn "Note that sometimes a generated key-pair may pass the internal tests"
+ ewarn "but fail to work properly. You will get a 'regenerate your keys'"
+ ewarn "message. If this is your case, please remove /etc/qingy/public_key"
+ ewarn "and /etc/qingy/private_key and run qingy-keygen again..."
+ fi
+
+ use emacs && echo && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}