summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2013-11-03 19:44:51 +0000
committerPacho Ramos <pacho@gentoo.org>2013-11-03 19:44:51 +0000
commitb2da2a3d38d42dce4fdfdf4ed5db622db4ea8076 (patch)
tree6a13c949a5dda4716ba6d84d81e9778b15594b5c /sys-apps/xinetd
parentsys-fs/aufs3: Bump to latest aufs release (diff)
downloadgentoo-2-b2da2a3d38d42dce4fdfdf4ed5db622db4ea8076.tar.gz
gentoo-2-b2da2a3d38d42dce4fdfdf4ed5db622db4ea8076.tar.bz2
gentoo-2-b2da2a3d38d42dce4fdfdf4ed5db622db4ea8076.zip
Add unit file
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'sys-apps/xinetd')
-rw-r--r--sys-apps/xinetd/ChangeLog8
-rw-r--r--sys-apps/xinetd/files/xinetd.service10
-rw-r--r--sys-apps/xinetd/xinetd-2.3.15-r1.ebuild54
3 files changed, 71 insertions, 1 deletions
diff --git a/sys-apps/xinetd/ChangeLog b/sys-apps/xinetd/ChangeLog
index ab9d246c22c3..ff6656393ac9 100644
--- a/sys-apps/xinetd/ChangeLog
+++ b/sys-apps/xinetd/ChangeLog
@@ -1,5 +1,11 @@
# ChangeLog for sys-apps/xinetd
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/xinetd/ChangeLog,v 1.69 2012/09/20 12:05:15 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/xinetd/ChangeLog,v 1.70 2013/11/03 19:44:51 pacho Exp $
+
+*xinetd-2.3.15-r1 (03 Nov 2013)
+
+ 03 Nov 2013; Pacho Ramos <pacho@gentoo.org> +files/xinetd.service,
+ +xinetd-2.3.15-r1.ebuild:
+ Add unit file
20 Sep 2012; Kacper Kowalik <xarthisius@gentoo.org> xinetd-2.3.15.ebuild:
ppc64 stable wrt #420927
diff --git a/sys-apps/xinetd/files/xinetd.service b/sys-apps/xinetd/files/xinetd.service
new file mode 100644
index 000000000000..c6f6271fd97b
--- /dev/null
+++ b/sys-apps/xinetd/files/xinetd.service
@@ -0,0 +1,10 @@
+[Unit]
+Description=A secure replacement for inetd
+After=network.target
+
+[Service]
+ExecStart=/usr/sbin/xinetd -dontfork
+ExecReload=/bin/kill -HUP $MAINPID
+
+[Install]
+WantedBy=multi-user.target
diff --git a/sys-apps/xinetd/xinetd-2.3.15-r1.ebuild b/sys-apps/xinetd/xinetd-2.3.15-r1.ebuild
new file mode 100644
index 000000000000..d07d6b1a3e2b
--- /dev/null
+++ b/sys-apps/xinetd/xinetd-2.3.15-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/xinetd/xinetd-2.3.15-r1.ebuild,v 1.1 2013/11/03 19:44:51 pacho Exp $
+
+EAPI="4"
+
+inherit eutils flag-o-matic systemd toolchain-funcs
+
+DESCRIPTION="powerful replacement for inetd"
+HOMEPAGE="http://www.xinetd.org/"
+SRC_URI="http://www.xinetd.org/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
+IUSE="perl rpc tcpd"
+
+DEPEND="tcpd? ( >=sys-apps/tcp-wrappers-7.6-r2 )
+ rpc? ( net-libs/libtirpc )"
+RDEPEND="${DEPEND}
+ perl? ( dev-lang/perl )"
+DEPEND="${DEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-2.3.14-DESTDIR.patch
+ epatch "${FILESDIR}"/${PN}-2.3.14-install-contrib.patch
+ epatch "${FILESDIR}"/${PN}-2.3.14-config.patch
+ find -name Makefile.in -exec sed -i 's:\<ar\>:$(AR):' {} +
+}
+
+src_configure() {
+ if ! use rpc ; then
+ append-cppflags -DNO_RPC
+ export ac_cv_header_{rpc_{rpc,rpcent,pmap_clnt},netdb}_h=no
+ fi
+ tc-export AR PKG_CONFIG
+ LIBS=$(${PKG_CONFIG} --libs libtirpc) \
+ econf \
+ $(use_with tcpd libwrap) \
+ --with-loadavg
+}
+
+src_install() {
+ emake DESTDIR="${ED}" install install-contrib
+ use perl || rm -f "${ED}"/usr/sbin/xconv.pl
+
+ newinitd "${FILESDIR}"/xinetd.rc6 xinetd
+ newconfd "${FILESDIR}"/xinetd.confd xinetd
+ systemd_dounit "${FILESDIR}/${PN}.service"
+
+ newdoc contrib/xinetd.conf xinetd.conf.dist.sample
+ dodoc AUDIT INSTALL README TODO CHANGELOG
+}