summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-06-15 11:59:22 +0000
committerJustin Lecher <jlec@gentoo.org>2012-06-15 11:59:22 +0000
commit536c6df7d79a9ed74addb4a878ce38a297905493 (patch)
tree25cc4c9dc00ec2ec213b5a72557a4510a5f21fe4 /sys-apps/x86info
parentSame for amd64 by emul-linux (diff)
downloadgentoo-2-536c6df7d79a9ed74addb4a878ce38a297905493.tar.gz
gentoo-2-536c6df7d79a9ed74addb4a878ce38a297905493.tar.bz2
gentoo-2-536c6df7d79a9ed74addb4a878ce38a297905493.zip
sys-apps/x86info: Use linux-info.eclas instead of elog
(Portage version: 2.2.0_alpha110/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/x86info')
-rw-r--r--sys-apps/x86info/ChangeLog6
-rw-r--r--sys-apps/x86info/metadata.xml8
-rw-r--r--sys-apps/x86info/x86info-1.30.ebuild15
3 files changed, 14 insertions, 15 deletions
diff --git a/sys-apps/x86info/ChangeLog b/sys-apps/x86info/ChangeLog
index ab9876e2fa46..d42f5373ff80 100644
--- a/sys-apps/x86info/ChangeLog
+++ b/sys-apps/x86info/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-apps/x86info
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/x86info/ChangeLog,v 1.35 2012/03/30 13:20:39 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/x86info/ChangeLog,v 1.36 2012/06/15 11:59:22 jlec Exp $
+
+ 15 Jun 2012; Justin Lecher <jlec@gentoo.org> x86info-1.30.ebuild,
+ metadata.xml:
+ Use linux-info.eclas instead of elog
30 Mar 2012; Samuli Suominen <ssuominen@gentoo.org> -x86info-1.21.ebuild,
-x86info-1.24-r1.ebuild, -x86info-1.24-r2.ebuild, -x86info-1.25.ebuild,
diff --git a/sys-apps/x86info/metadata.xml b/sys-apps/x86info/metadata.xml
index 035bc6b0e2cd..e2a0d741c0f6 100644
--- a/sys-apps/x86info/metadata.xml
+++ b/sys-apps/x86info/metadata.xml
@@ -1,8 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>base-system</herd>
-<maintainer>
- <email>robbat2@gentoo.org</email>
-</maintainer>
+ <herd>base-system</herd>
+ <maintainer>
+ <email>robbat2@gentoo.org</email>
+ </maintainer>
</pkgmetadata>
diff --git a/sys-apps/x86info/x86info-1.30.ebuild b/sys-apps/x86info/x86info-1.30.ebuild
index 09294192731a..bca78f4c1e62 100644
--- a/sys-apps/x86info/x86info-1.30.ebuild
+++ b/sys-apps/x86info/x86info-1.30.ebuild
@@ -1,9 +1,10 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/x86info/x86info-1.30.ebuild,v 1.3 2012/03/24 16:54:37 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/x86info/x86info-1.30.ebuild,v 1.4 2012/06/15 11:59:22 jlec Exp $
EAPI=2
-inherit eutils toolchain-funcs flag-o-matic
+
+inherit eutils flag-o-matic linux-info toolchain-funcs
DESCRIPTION="Dave Jones' handy, informative x86 CPU diagnostic utility"
HOMEPAGE="http://www.codemonkey.org.uk/projects/x86info/"
@@ -17,6 +18,8 @@ IUSE=""
RDEPEND="sys-apps/pciutils"
DEPEND="${RDEPEND}"
+CONFIG_CHECK="~MTRR ~X86_CPUID"
+
src_prepare() {
epatch "${FILESDIR}"/1.21-pic.patch
epatch "${FILESDIR}"/${PN}-1.24-pic.patch #270388
@@ -57,11 +60,3 @@ pkg_preinst() {
mv "${ROOT}"/etc/modprobe.d/x86info{,.conf}
fi
}
-
-pkg_postinst() {
- ewarn "Your kernel must be built with the following options"
- ewarn "set to Y or M"
- ewarn " Processor type and features ->"
- ewarn " [*] /dev/cpu/*/msr - Model-specific register support"
- ewarn " [*] /dev/cpu/*/cpuid - CPU information support"
-}