summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephen Becker <geoman@gentoo.org>2006-04-21 16:02:12 +0000
committerStephen Becker <geoman@gentoo.org>2006-04-21 16:02:12 +0000
commit7ee0cbe4cf3258e120c329c36495ce5f90b68c3a (patch)
treeca4018e23458982c7850877270904a05f7c23596 /sys-apps/util-linux
parentDon't depend on expect. Thanks to Emil Beinroth in bug #98864. (diff)
downloadgentoo-2-7ee0cbe4cf3258e120c329c36495ce5f90b68c3a.tar.gz
gentoo-2-7ee0cbe4cf3258e120c329c36495ce5f90b68c3a.tar.bz2
gentoo-2-7ee0cbe4cf3258e120c329c36495ce5f90b68c3a.zip
use lseek instead of llseek for mips, and mark -r3 stable on mips
(Portage version: 2.1_pre7-r5)
Diffstat (limited to 'sys-apps/util-linux')
-rw-r--r--sys-apps/util-linux/ChangeLog7
-rw-r--r--sys-apps/util-linux/files/util-linux-2.12-mips-lseek.patch24
-rw-r--r--sys-apps/util-linux/util-linux-2.12r-r3.ebuild7
-rw-r--r--sys-apps/util-linux/util-linux-2.12r-r4.ebuild5
4 files changed, 39 insertions, 4 deletions
diff --git a/sys-apps/util-linux/ChangeLog b/sys-apps/util-linux/ChangeLog
index 8ee420169e56..1d2d15cc04c0 100644
--- a/sys-apps/util-linux/ChangeLog
+++ b/sys-apps/util-linux/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/util-linux
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/ChangeLog,v 1.157 2006/04/17 20:35:12 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/ChangeLog,v 1.158 2006/04/21 16:02:12 geoman Exp $
+
+ 21 Apr 2006; Stephen P. Becker <geoman@gentoo.org>
+ +files/util-linux-2.12-mips-lseek.patch, util-linux-2.12r-r3.ebuild,
+ util-linux-2.12r-r4.ebuild:
+ use lseek instead of llseek for mips, and mark -r3 stable on mips
17 Apr 2006; Markus Rothe <corsair@gentoo.org> util-linux-2.12r-r3.ebuild:
Stable on ppc64; bug #129540
diff --git a/sys-apps/util-linux/files/util-linux-2.12-mips-lseek.patch b/sys-apps/util-linux/files/util-linux-2.12-mips-lseek.patch
new file mode 100644
index 000000000000..3fcd5b554a31
--- /dev/null
+++ b/sys-apps/util-linux/files/util-linux-2.12-mips-lseek.patch
@@ -0,0 +1,24 @@
+Because there is no llseek defined for mips n32, we will use lseek instead.
+
+--- util-linux-2.12r/fdisk/sfdisk.c.orig
++++ util-linux-2.12r/fdisk/sfdisk.c
+@@ -172,7 +172,7 @@
+ * Note: we use 512-byte sectors here, irrespective of the hardware ss.
+ */
+ #undef use_lseek
+-#if defined (__alpha__) || defined (__ia64__) || defined (__x86_64__) || defined (__s390x__)
++#if defined (__alpha__) || defined (__ia64__) || defined (__x86_64__) || defined (__s390x__) || defined (__mips__)
+ #define use_lseek
+ #endif
+
+--- util-linux-2.12r/partx/partx.c.orig
++++ util-linux-2.12r/partx/partx.c
+@@ -333,7 +333,7 @@
+ /*
+ * sseek: seek to specified sector
+ */
+-#if !defined (__alpha__) && !defined (__ia64__) && !defined (__s390x__) && !defined(__x86_64__)
++#if !defined (__alpha__) && !defined (__ia64__) && !defined (__s390x__) && !defined(__x86_64__) && !defined(__mips__)
+ #define NEED__llseek
+ #endif
+
diff --git a/sys-apps/util-linux/util-linux-2.12r-r3.ebuild b/sys-apps/util-linux/util-linux-2.12r-r3.ebuild
index f63a311dc9fc..dd13538352b5 100644
--- a/sys-apps/util-linux/util-linux-2.12r-r3.ebuild
+++ b/sys-apps/util-linux/util-linux-2.12r-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/util-linux-2.12r-r3.ebuild,v 1.10 2006/04/17 20:35:12 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/util-linux-2.12r-r3.ebuild,v 1.11 2006/04/21 16:02:12 geoman Exp $
inherit eutils flag-o-matic toolchain-funcs
@@ -17,7 +17,7 @@ SRC_URI="mirror://kernel/linux/utils/${PN}/${P}.tar.bz2
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86"
+KEYWORDS="alpha amd64 arm hppa ia64 m68k mips ppc ppc64 s390 sh sparc x86"
IUSE="crypt old-crypt nls static selinux perl"
RDEPEND=">=sys-libs/ncurses-5.2-r2
@@ -111,6 +111,9 @@ src_unpack() {
# Patches from Fedora
epatch "${FILESDIR}"/${PN}-2.12r-umount-nosysfs.patch
+ # fix mips n32 (no llseek syscall)
+ epatch "${FILESDIR}"/${PN}-2.12-mips-lseek.patch
+
# Enable random features
local mconfigs="MCONFIG"
use old-crypt && mconfigs="${mconfigs} ${OLD_CRYPT_P}/MCONFIG"
diff --git a/sys-apps/util-linux/util-linux-2.12r-r4.ebuild b/sys-apps/util-linux/util-linux-2.12r-r4.ebuild
index 0f0dd93cb775..2005169da57b 100644
--- a/sys-apps/util-linux/util-linux-2.12r-r4.ebuild
+++ b/sys-apps/util-linux/util-linux-2.12r-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/util-linux-2.12r-r4.ebuild,v 1.1 2006/04/11 00:36:34 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/util-linux-2.12r-r4.ebuild,v 1.2 2006/04/21 16:02:12 geoman Exp $
inherit eutils flag-o-matic toolchain-funcs
@@ -114,6 +114,9 @@ src_unpack() {
# Patches from Fedora
epatch "${FILESDIR}"/${PN}-2.12r-umount-nosysfs.patch
+ # fix mips n32 (no llseek syscall)
+ epatch "${FILESDIR}"/${PN}-2.12-mips-lseek.patch
+
# Enable random features
local mconfigs="MCONFIG"
use old-crypt && mconfigs="${mconfigs} ${OLD_CRYPT_P}/MCONFIG"