summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2004-06-16 02:03:32 +0000
committerDaniel Black <dragonheart@gentoo.org>2004-06-16 02:03:32 +0000
commit426951c7cf0d9909752a19d7973443a706313f64 (patch)
treeb46e52cea5e3fc46f46379815fd614c2c43ee917 /sys-apps/util-linux
parentBump version. (Manifest recommit) (diff)
downloadgentoo-2-426951c7cf0d9909752a19d7973443a706313f64.tar.gz
gentoo-2-426951c7cf0d9909752a19d7973443a706313f64.tar.bz2
gentoo-2-426951c7cf0d9909752a19d7973443a706313f64.zip
uclibc fixes
Diffstat (limited to 'sys-apps/util-linux')
-rw-r--r--sys-apps/util-linux/ChangeLog6
-rw-r--r--sys-apps/util-linux/util-linux-2.12-r4.ebuild5
-rw-r--r--sys-apps/util-linux/util-linux-2.12-r5.ebuild6
3 files changed, 12 insertions, 5 deletions
diff --git a/sys-apps/util-linux/ChangeLog b/sys-apps/util-linux/ChangeLog
index c8bdb51d3a58..506443accdcd 100644
--- a/sys-apps/util-linux/ChangeLog
+++ b/sys-apps/util-linux/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-apps/util-linux
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/ChangeLog,v 1.79 2004/06/02 04:39:28 lv Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/ChangeLog,v 1.80 2004/06/16 02:03:32 dragonheart Exp $
+
+ 16 Jun 2004; Daniel Black <dragonheart@gentoo.org>
+ util-linux-2.12-r4.ebuild, util-linux-2.12-r5.ebuild:
+ uclibc fixes thanks to Peter S. Mazinger <ps.m@gmx.net>
02 Jun 2004; Travis Tilley <lv@gentoo.org> util-linux-2.12-r5.ebuild:
stable on amd64
diff --git a/sys-apps/util-linux/util-linux-2.12-r4.ebuild b/sys-apps/util-linux/util-linux-2.12-r4.ebuild
index d05049ae717c..2c8a885c736c 100644
--- a/sys-apps/util-linux/util-linux-2.12-r4.ebuild
+++ b/sys-apps/util-linux/util-linux-2.12-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/util-linux-2.12-r4.ebuild,v 1.12 2004/05/09 01:45:29 solar Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/util-linux-2.12-r4.ebuild,v 1.13 2004/06/16 02:03:32 dragonheart Exp $
inherit eutils flag-o-matic
@@ -15,7 +15,7 @@ SRC_URI="mirror://kernel/linux/utils/${PN}/${P}.tar.gz
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86 ~ppc sparc mips alpha arm hppa amd64 ia64 ~ppc64 s390"
-IUSE="crypt nls static pam selinux"
+IUSE="crypt nls static pam selinux uclibc"
DEPEND="virtual/glibc
>=sys-apps/sed-4.0.5
@@ -112,6 +112,7 @@ src_unpack() {
# /bin/kill is provided by procps ONLY
epatch ${FILESDIR}/${PN}-no-kill.patch
+ use uclibc && sed -e 's/sys_siglist\[sig\]/strsignal(sig)/' -i ${S}/mount/fstab.c
}
src_compile() {
diff --git a/sys-apps/util-linux/util-linux-2.12-r5.ebuild b/sys-apps/util-linux/util-linux-2.12-r5.ebuild
index 5e82d6acae52..b7e43bf4113b 100644
--- a/sys-apps/util-linux/util-linux-2.12-r5.ebuild
+++ b/sys-apps/util-linux/util-linux-2.12-r5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/util-linux-2.12-r5.ebuild,v 1.9 2004/06/02 04:39:28 lv Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/util-linux-2.12-r5.ebuild,v 1.10 2004/06/16 02:03:32 dragonheart Exp $
inherit eutils flag-o-matic
@@ -15,7 +15,7 @@ SRC_URI="mirror://kernel/linux/utils/${PN}/${P}.tar.gz
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86 ~ppc ~sparc mips ~alpha arm ~hppa amd64 ~ia64 ~ppc64"
-IUSE="crypt nls static pam selinux"
+IUSE="crypt nls static pam selinux uclibc"
DEPEND="virtual/glibc
>=sys-apps/sed-4.0.5
@@ -116,6 +116,8 @@ src_unpack() {
# Install rdev on amd64 platform
epatch ${FILESDIR}/${P}-amd64_rdev_installation.patch
+
+ use uclibc && sed -e 's/sys_siglist\[sig\]/strsignal(sig)/' -i ${S}/mount/fstab.c
}
src_compile() {