summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2014-04-21 08:18:36 +0000
committerPatrick Lauer <patrick@gentoo.org>2014-04-21 08:18:36 +0000
commit4f32c9e957c7e728f8a29cc120fa38bc4fc0d186 (patch)
tree01e3f8eb411a62e4072ec01d9a099b436ba01bbf /sys-apps/toybox
parentamd64 stable wrt bug #455548 (diff)
downloadgentoo-2-4f32c9e957c7e728f8a29cc120fa38bc4fc0d186.tar.gz
gentoo-2-4f32c9e957c7e728f8a29cc120fa38bc4fc0d186.tar.bz2
gentoo-2-4f32c9e957c7e728f8a29cc120fa38bc4fc0d186.zip
Bump
(Portage version: 2.2.10/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'sys-apps/toybox')
-rw-r--r--sys-apps/toybox/ChangeLog7
-rw-r--r--sys-apps/toybox/toybox-0.4.8.ebuild37
2 files changed, 43 insertions, 1 deletions
diff --git a/sys-apps/toybox/ChangeLog b/sys-apps/toybox/ChangeLog
index df63e681f6e8..6723582cd54f 100644
--- a/sys-apps/toybox/ChangeLog
+++ b/sys-apps/toybox/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/toybox
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/toybox/ChangeLog,v 1.1 2014/04/01 04:09:36 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/toybox/ChangeLog,v 1.2 2014/04/21 08:18:36 patrick Exp $
+
+*toybox-0.4.8 (21 Apr 2014)
+
+ 21 Apr 2014; Patrick Lauer <patrick@gentoo.org> +toybox-0.4.8.ebuild:
+ Bump
*toybox-9999 (01 Apr 2014)
*toybox-0.4.7 (01 Apr 2014)
diff --git a/sys-apps/toybox/toybox-0.4.8.ebuild b/sys-apps/toybox/toybox-0.4.8.ebuild
new file mode 100644
index 000000000000..3d65b6d6beb7
--- /dev/null
+++ b/sys-apps/toybox/toybox-0.4.8.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/toybox/toybox-0.4.8.ebuild,v 1.1 2014/04/21 08:18:36 patrick Exp $
+
+EAPI=5
+
+inherit eutils
+
+# makefile is stupid
+RESTRICT="test"
+
+DESCRIPTION="Common linux commands in a multicall binary"
+HOMEPAGE="http://landley.net/code/toybox/"
+SRC_URI="http://landley.net/code/toybox/downloads/${P}.tar.bz2"
+
+# The source code does not explicitly say that it's BSD, but the author has repeatedly said it
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+src_configure() {
+ make defconfig
+}
+
+src_compile() {
+ emake
+}
+
+src_test() {
+ emake test
+}
+
+src_install() {
+ mkdir -p "${D}/usr/bin"
+ cp toybox "${D}/usr/bin" || die
+}