summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2002-07-05 08:49:12 +0000
committerDoug Goldstein <cardoe@gentoo.org>2002-07-05 08:49:12 +0000
commitbc887856756eff84a4cd88530065292181d32da2 (patch)
treebd999cae45e6f1a39b7864274aba6728c1ef9c84 /sys-apps/pcmcia-cs
parentUpdated to 3.1.34-r5 (diff)
downloadgentoo-2-bc887856756eff84a4cd88530065292181d32da2.tar.gz
gentoo-2-bc887856756eff84a4cd88530065292181d32da2.tar.bz2
gentoo-2-bc887856756eff84a4cd88530065292181d32da2.zip
Updated to 3.1.34-r5
Corrected with lintool Updated to orinoco 0.12a Removed attempt to patch with gentoo-3.1.34.patch since it didn't exist
Diffstat (limited to 'sys-apps/pcmcia-cs')
-rw-r--r--sys-apps/pcmcia-cs/files/digest-pcmcia-cs-3.1.34-r52
-rw-r--r--sys-apps/pcmcia-cs/pcmcia-cs-3.1.34-r5.ebuild127
2 files changed, 129 insertions, 0 deletions
diff --git a/sys-apps/pcmcia-cs/files/digest-pcmcia-cs-3.1.34-r5 b/sys-apps/pcmcia-cs/files/digest-pcmcia-cs-3.1.34-r5
new file mode 100644
index 000000000000..deed8723d64a
--- /dev/null
+++ b/sys-apps/pcmcia-cs/files/digest-pcmcia-cs-3.1.34-r5
@@ -0,0 +1,2 @@
+MD5 c31d1bbd2117cc90f4bf1cac31f97d1d pcmcia-cs-3.1.34.tar.gz 1247038
+MD5 63882c41d70905879a73b37608e3d7e7 orinoco-0.12a.tar.gz 62864
diff --git a/sys-apps/pcmcia-cs/pcmcia-cs-3.1.34-r5.ebuild b/sys-apps/pcmcia-cs/pcmcia-cs-3.1.34-r5.ebuild
new file mode 100644
index 000000000000..80e492110015
--- /dev/null
+++ b/sys-apps/pcmcia-cs/pcmcia-cs-3.1.34-r5.ebuild
@@ -0,0 +1,127 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pcmcia-cs/pcmcia-cs-3.1.34-r5.ebuild,v 1.1 2002/07/05 08:49:12 cardoe Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="PCMCIA tools for Linux"
+SRC_URI="mirror://sourceforge/pcmcia-cs/${P}.tar.gz
+ http://ozlabs.org/people/dgibson/dldwd/orinoco-0.12a.tar.gz"
+
+HOMEPAGE="http://pcmcia-cs.sourceforge.net"
+DEPEND="sys-kernel/linux-headers"
+RDEPEND=""
+SLOT="0"
+LICENSE="GPL"
+
+# check arch for configure
+if [ ${ARCH} = "x86" ] ; then
+ MY_ARCH="i386"
+else
+ MY_ARCH="ppc"
+fi
+
+# Note: To use this ebuild, you should have the usr/src/linux symlink to
+# the kernel directory that pcmcia-cs should use for configuration.
+
+src_unpack() {
+ unpack ${P}.tar.gz
+# patch -p0 < ${FILESDIR}/gentoo-${P}.patch
+
+ unpack orinoco-0.12a.tar.gz
+ cd ${S}
+ mv ../orinoco-0.12a/hermes*.{c,h} \
+ ../orinoco-0.12a/orinoco*.{c,h} \
+ ../orinoco-0.12a/ieee802_11.h wireless/
+ cp Configure Configure.orig
+ sed -e 's:usr/man:usr/share/man:g' Configure.orig > Configure
+ #man pages will now install into /usr/share/man
+}
+
+src_compile() {
+ local myconf
+ if [ -n "`use trusted`" ] ; then
+ myconf="--trust"
+ else
+ myconf="--notrust"
+ fi
+
+ if [ -n "`use apm`" ] ; then
+ myconf="$myconf --apm"
+ else
+ myconf="$myconf --noapm"
+ fi
+
+ if [ -n "`use pnp`" ] ; then
+ myconf="$myconf --pnp"
+ else
+ myconf="$myconf --nopnp"
+ fi
+
+ if [ -n "`use nocardbus`" ] ; then
+ myconf="$myconf --nocardbus"
+ else
+ myconf="$myconf --cardbus"
+ fi
+
+ #use $CFLAGS for user tools, but standard kernel optimizations for the kernel modules (for compatibility)
+ ./Configure -n \
+ --target=${D} \
+ --srctree \
+ --kernel=/usr/src/linux \
+ --arch="${MY_ARCH}" \
+ --uflags="$CFLAGS" \
+ --kflags="-Wall -Wstrict-prototypes -O2 -fomit-frame-pointer" \
+ $myconf || die "failed configuring"
+ # nopnp and noapm are important, because without them the pcmcia-cs
+ # tools will require a kernel with ISA PnP and/or APM support,
+ # which cannot be guaranteed. We need to make sure the tools
+ # work *all* the time, not just some of the time.
+
+ # The --srctree option tells pcmcia-cs to configure for the kernel in /usr/src/linux
+ # rather than the currently-running kernel. It's Gentoo Linux policy to configure for
+ # the kernel in /usr/src/linux
+ emake all || die "failed compiling"
+}
+
+src_install () {
+ make PREFIX=${D} install || die "failed installing"
+ cd ${D}
+ rm -rf etc/rc*.d
+ # remove X
+ # this is simply much easier than patching configure or the makefiles
+ # not to build them in the first place
+ rm -rf usr/X11R6
+ # todo: if they are nstalled, move them to /usr
+
+ insinto /etc/conf.d
+ newins ${FILESDIR}/pcmcia.conf pcmcia
+
+ exeinto /etc/pcmcia
+ doexe ${FILESDIR}/network
+
+ # install our own init script
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/pcmcia.rc6 pcmcia
+ if [ -z "`use build`" ]
+ then
+ cd ${S}
+ # install docs
+ dodoc BUGS CHANGES COPYING LICENSE MAINTAINERS README \
+ README-2.4 SUPPORTED.CARDS doc/*
+ else
+ rm -rf ${D}/usr/share/man
+ fi
+ rm -f ${D}/etc/modules.conf
+ rm -rf ${D}/var/lib/pcmcia
+
+ # if on ppc set the ppc revised config.opts
+ if [ ${ARCH} = "ppc" ] ; then
+ insinto /etc/pcmcia
+ newins ${FILESDIR}/ppc.config.opts config.opts
+ fi
+}
+
+src_postinst() {
+ einfo "To avail yourself of the pcmcia-cs drivers, you have to disable the PCMCIA support in the kernel."
+ einfo "(Otherwise, you might experience CardServices version mismatch errors)"
+}