summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2014-09-21 10:59:57 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2014-09-21 10:59:57 +0000
commit0a9f54700b0ad186d2961a8a1c17a69fd2676519 (patch)
treeb9656ebdd527c1d58f99afa6f95ff419424875c9 /sys-apps/kmod
parentold (diff)
downloadgentoo-2-0a9f54700b0ad186d2961a8a1c17a69fd2676519.tar.gz
gentoo-2-0a9f54700b0ad186d2961a8a1c17a69fd2676519.tar.bz2
gentoo-2-0a9f54700b0ad186d2961a8a1c17a69fd2676519.zip
old
(Portage version: 2.2.13/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'sys-apps/kmod')
-rw-r--r--sys-apps/kmod/ChangeLog6
-rw-r--r--sys-apps/kmod/files/kmod-static-nodes18
-rw-r--r--sys-apps/kmod/kmod-16.ebuild136
-rw-r--r--sys-apps/kmod/kmod-17.ebuild195
-rw-r--r--sys-apps/kmod/kmod-18.ebuild195
5 files changed, 5 insertions, 545 deletions
diff --git a/sys-apps/kmod/ChangeLog b/sys-apps/kmod/ChangeLog
index 186adce7b271..4b6a51ccd829 100644
--- a/sys-apps/kmod/ChangeLog
+++ b/sys-apps/kmod/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-apps/kmod
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/kmod/ChangeLog,v 1.169 2014/09/21 10:28:29 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/kmod/ChangeLog,v 1.170 2014/09/21 10:59:57 ssuominen Exp $
+
+ 21 Sep 2014; Samuli Suominen <ssuominen@gentoo.org> -files/kmod-static-nodes,
+ -kmod-16.ebuild, -kmod-17.ebuild, -kmod-18.ebuild:
+ old
21 Sep 2014; Agostino Sarubbo <ago@gentoo.org> kmod-18-r1.ebuild:
Stable for sparc, wrt bug #517106
diff --git a/sys-apps/kmod/files/kmod-static-nodes b/sys-apps/kmod/files/kmod-static-nodes
deleted file mode 100644
index 43d843111314..000000000000
--- a/sys-apps/kmod/files/kmod-static-nodes
+++ /dev/null
@@ -1,18 +0,0 @@
-#!/sbin/runscript
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/kmod/files/kmod-static-nodes,v 1.1 2013/08/09 19:08:18 ssuominen Exp $
-
-description="Create list of required static device nodes for the current kernel"
-
-depend() {
- after dev-mount
- before tmpfiles.dev dev
-}
-
-start() {
- ebegin "Creating list of required static device nodes for the current kernel"
- checkpath -q -d /run/tmpfiles.d
- kmod static-nodes --format=tmpfiles --output=/run/tmpfiles.d/kmod.conf
- eend $?
-}
diff --git a/sys-apps/kmod/kmod-16.ebuild b/sys-apps/kmod/kmod-16.ebuild
deleted file mode 100644
index 448ab377fc0b..000000000000
--- a/sys-apps/kmod/kmod-16.ebuild
+++ /dev/null
@@ -1,136 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/kmod/kmod-16.ebuild,v 1.17 2014/09/02 03:24:55 ryao Exp $
-
-EAPI=5
-inherit bash-completion-r1 eutils multilib
-
-if [[ ${PV} == 9999* ]]; then
- EGIT_REPO_URI="git://git.kernel.org/pub/scm/utils/kernel/${PN}/${PN}.git"
- inherit autotools git-2
-else
- SRC_URI="mirror://kernel/linux/utils/kernel/kmod/${P}.tar.xz"
- KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86"
- inherit libtool
-fi
-
-DESCRIPTION="library and tools for managing linux kernel modules"
-HOMEPAGE="http://git.kernel.org/?p=utils/kernel/kmod/kmod.git"
-
-LICENSE="LGPL-2"
-SLOT="0"
-IUSE="debug doc lzma static-libs +tools zlib"
-
-# Upstream does not support running the test suite with custom configure flags.
-# I was also told that the test suite is intended for kmod developers.
-# So we have to restrict it.
-# See bug #408915.
-RESTRICT="test"
-
-RDEPEND="!sys-apps/module-init-tools
- !sys-apps/modutils
- lzma? ( >=app-arch/xz-utils-5.0.4-r1 )
- !<sys-apps/openrc-0.12
- zlib? ( >=sys-libs/zlib-1.2.6 )" #427130
-DEPEND="${RDEPEND}
- dev-libs/libxslt
- doc? ( dev-util/gtk-doc )
- lzma? ( virtual/pkgconfig )
- zlib? ( virtual/pkgconfig )"
-
-src_prepare() {
- if [ ! -e configure ]; then
- if use doc; then
- gtkdocize --copy --docdir libkmod/docs || die
- else
- touch libkmod/docs/gtk-doc.make
- fi
- eautoreconf
- else
- epatch "${FILESDIR}"/${PN}-15-dynamic-kmod.patch #493630
- elibtoolize
- fi
-
- # Restore possibility of running --enable-static wrt #472608
- sed -i \
- -e '/--enable-static is not supported by kmod/s:as_fn_error:echo:' \
- configure || die
-}
-
-src_configure() {
- econf \
- --bindir="${EPREFIX}/bin" \
- --with-rootlibdir="${EPREFIX}/$(get_libdir)" \
- --enable-shared \
- $(use_enable static-libs static) \
- $(use_enable tools) \
- $(use_enable debug) \
- $(use_enable doc gtk-doc) \
- $(use_with lzma xz) \
- $(use_with zlib) \
- --with-bashcompletiondir="$(get_bashcompdir)"
-}
-
-src_compile() {
- if [[ ${PV} == 9999* ]]; then
- default
- else
- # Force -j1 because of -15-dynamic-kmod.patch, likely caused by lack of eautoreconf
- # wrt #494806
- emake -j1
- fi
-}
-
-src_install() {
- default
- prune_libtool_files
-
- if use tools; then
- local bincmd sbincmd
- for sbincmd in depmod insmod lsmod modinfo modprobe rmmod; do
- dosym /bin/kmod /sbin/${sbincmd}
- done
-
- # These are also usable as normal user
- for bincmd in lsmod modinfo; do
- dosym kmod /bin/${bincmd}
- done
- fi
-
- cat <<-EOF > "${T}"/usb-load-ehci-first.conf
- softdep uhci_hcd pre: ehci_hcd
- softdep ohci_hcd pre: ehci_hcd
- EOF
-
- insinto /lib/modprobe.d
- doins "${T}"/usb-load-ehci-first.conf #260139
-
- doinitd "${FILESDIR}"/kmod-static-nodes
-}
-
-pkg_postinst() {
- if [[ -L ${EROOT%/}/etc/runlevels/boot/static-nodes ]]; then
- ewarn "Removing old conflicting static-nodes init script from the boot runlevel"
- rm -f "${EROOT%/}"/etc/runlevels/boot/static-nodes
- fi
-
- # Add kmod to the runlevel automatically if this is the first install of this package.
- if [[ -z ${REPLACING_VERSIONS} ]]; then
- if [[ ! -d ${EROOT%/}/etc/runlevels/sysinit ]]; then
- mkdir -p "${EROOT%/}"/etc/runlevels/sysinit
- fi
- if [[ -x ${EROOT%/}/etc/init.d/kmod-static-nodes ]]; then
- ln -s /etc/init.d/kmod-static-nodes "${EROOT%/}"/etc/runlevels/sysinit/kmod-static-nodes
- fi
- fi
-
- if [[ -e ${EROOT%/}/etc/runlevels/sysinit ]]; then
- if [[ ! -e ${EROOT%/}/etc/runlevels/sysinit/kmod-static-nodes ]]; then
- ewarn
- ewarn "You need to add kmod-static-nodes to the sysinit runlevel for"
- ewarn "kernel modules to have required static nodes!"
- ewarn "Run this command:"
- ewarn "\trc-update add kmod-static-nodes sysinit"
- fi
- fi
-}
diff --git a/sys-apps/kmod/kmod-17.ebuild b/sys-apps/kmod/kmod-17.ebuild
deleted file mode 100644
index a8b2debf78d8..000000000000
--- a/sys-apps/kmod/kmod-17.ebuild
+++ /dev/null
@@ -1,195 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/kmod/kmod-17.ebuild,v 1.13 2014/09/02 03:24:55 ryao Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_7,3_2,3_3,3_4} )
-
-inherit bash-completion-r1 eutils multilib python-r1
-
-if [[ ${PV} == 9999* ]]; then
- EGIT_REPO_URI="git://git.kernel.org/pub/scm/utils/kernel/${PN}/${PN}.git"
- inherit autotools git-2
-else
- SRC_URI="mirror://kernel/linux/utils/kernel/kmod/${P}.tar.xz"
- KEYWORDS="~alpha amd64 arm arm64 hppa ia64 m68k ~mips ~ppc ~ppc64 s390 sh ~sparc x86"
- inherit libtool
-fi
-
-DESCRIPTION="library and tools for managing linux kernel modules"
-HOMEPAGE="http://git.kernel.org/?p=utils/kernel/kmod/kmod.git"
-
-LICENSE="LGPL-2"
-SLOT="0"
-IUSE="debug doc lzma python static-libs +tools zlib"
-
-# Upstream does not support running the test suite with custom configure flags.
-# I was also told that the test suite is intended for kmod developers.
-# So we have to restrict it.
-# See bug #408915.
-RESTRICT="test"
-
-RDEPEND="!sys-apps/module-init-tools
- !sys-apps/modutils
- !<sys-apps/openrc-0.12
- lzma? ( >=app-arch/xz-utils-5.0.4-r1 )
- python? ( ${PYTHON_DEPS} )
- zlib? ( >=sys-libs/zlib-1.2.6 )" #427130
-DEPEND="${RDEPEND}
- doc? ( dev-util/gtk-doc )
- lzma? ( virtual/pkgconfig )
- python? (
- dev-python/cython[${PYTHON_USEDEP}]
- virtual/pkgconfig
- )
- zlib? ( virtual/pkgconfig )"
-if [[ ${PV} == 9999* ]]; then
- DEPEND="${DEPEND}
- dev-libs/libxslt"
-fi
-
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-DOCS="NEWS README TODO"
-
-src_prepare() {
- if [ ! -e configure ]; then
- if use doc; then
- gtkdocize --copy --docdir libkmod/docs || die
- else
- touch libkmod/docs/gtk-doc.make
- fi
- eautoreconf
- else
- epatch "${FILESDIR}"/${PN}-15-dynamic-kmod.patch #493630
- elibtoolize
- fi
-
- # Restore possibility of running --enable-static wrt #472608
- sed -i \
- -e '/--enable-static is not supported by kmod/s:as_fn_error:echo:' \
- configure || die
-}
-
-src_configure() {
- local myeconfargs=(
- --bindir="${EPREFIX}/bin"
- --with-rootlibdir="${EPREFIX}/$(get_libdir)"
- --enable-shared
- $(use_enable static-libs static)
- $(use_enable tools)
- $(use_enable debug)
- $(use_enable doc gtk-doc)
- $(use_with lzma xz)
- $(use_with zlib)
- --with-bashcompletiondir="$(get_bashcompdir)"
- )
-
- local ECONF_SOURCE="${S}"
-
- kmod_configure() {
- mkdir -p "${BUILD_DIR}" || die
- run_in_build_dir econf "${myeconfargs[@]}" "$@"
- }
-
- BUILD_DIR="${WORKDIR}/build"
- kmod_configure --disable-python
-
- if use python; then
- python_parallel_foreach_impl kmod_configure --enable-python
- fi
-}
-
-src_compile() {
- if [[ ${PV} != 9999* ]]; then
- # Force -j1 because of -15-dynamic-kmod.patch, likely caused by lack of eautoreconf
- # wrt #494806
- local MAKEOPTS="${MAKEOPTS} -j1"
- fi
-
- emake -C "${BUILD_DIR}"
-
- if use python; then
- local native_builddir=${BUILD_DIR}
-
- python_compile() {
- emake -C "${BUILD_DIR}" -f Makefile -f - python \
- VPATH="${native_builddir}:${S}" \
- native_builddir="${native_builddir}" \
- libkmod_python_kmod_{kmod,list,module,_util}_la_LIBADD='$(PYTHON_LIBS) $(native_builddir)/libkmod/libkmod.la' \
- <<< 'python: $(pkgpyexec_LTLIBRARIES)'
- }
-
- python_foreach_impl python_compile
- fi
-}
-
-src_install() {
- emake -C "${BUILD_DIR}" DESTDIR="${D}" install
- einstalldocs
-
- if use python; then
- local native_builddir=${BUILD_DIR}
-
- python_install() {
- emake -C "${BUILD_DIR}" DESTDIR="${D}" \
- VPATH="${native_builddir}:${S}" \
- install-pkgpyexecLTLIBRARIES \
- install-dist_pkgpyexecPYTHON
- }
-
- python_foreach_impl python_install
- fi
-
- prune_libtool_files --modules
-
- if use tools; then
- local bincmd sbincmd
- for sbincmd in depmod insmod lsmod modinfo modprobe rmmod; do
- dosym /bin/kmod /sbin/${sbincmd}
- done
-
- # These are also usable as normal user
- for bincmd in lsmod modinfo; do
- dosym kmod /bin/${bincmd}
- done
- fi
-
- cat <<-EOF > "${T}"/usb-load-ehci-first.conf
- softdep uhci_hcd pre: ehci_hcd
- softdep ohci_hcd pre: ehci_hcd
- EOF
-
- insinto /lib/modprobe.d
- doins "${T}"/usb-load-ehci-first.conf #260139
-
- doinitd "${FILESDIR}"/kmod-static-nodes
-}
-
-pkg_postinst() {
- if [[ -L ${EROOT%/}/etc/runlevels/boot/static-nodes ]]; then
- ewarn "Removing old conflicting static-nodes init script from the boot runlevel"
- rm -f "${EROOT%/}"/etc/runlevels/boot/static-nodes
- fi
-
- # Add kmod to the runlevel automatically if this is the first install of this package.
- if [[ -z ${REPLACING_VERSIONS} ]]; then
- if [[ ! -d ${EROOT%/}/etc/runlevels/sysinit ]]; then
- mkdir -p "${EROOT%/}"/etc/runlevels/sysinit
- fi
- if [[ -x ${EROOT%/}/etc/init.d/kmod-static-nodes ]]; then
- ln -s /etc/init.d/kmod-static-nodes "${EROOT%/}"/etc/runlevels/sysinit/kmod-static-nodes
- fi
- fi
-
- if [[ -e ${EROOT%/}/etc/runlevels/sysinit ]]; then
- if [[ ! -e ${EROOT%/}/etc/runlevels/sysinit/kmod-static-nodes ]]; then
- ewarn
- ewarn "You need to add kmod-static-nodes to the sysinit runlevel for"
- ewarn "kernel modules to have required static nodes!"
- ewarn "Run this command:"
- ewarn "\trc-update add kmod-static-nodes sysinit"
- fi
- fi
-}
diff --git a/sys-apps/kmod/kmod-18.ebuild b/sys-apps/kmod/kmod-18.ebuild
deleted file mode 100644
index f698d6ec3030..000000000000
--- a/sys-apps/kmod/kmod-18.ebuild
+++ /dev/null
@@ -1,195 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/kmod/kmod-18.ebuild,v 1.3 2014/09/02 03:24:55 ryao Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_7,3_2,3_3,3_4} )
-
-inherit bash-completion-r1 eutils multilib python-r1
-
-if [[ ${PV} == 9999* ]]; then
- EGIT_REPO_URI="git://git.kernel.org/pub/scm/utils/kernel/${PN}/${PN}.git"
- inherit autotools git-2
-else
- SRC_URI="mirror://kernel/linux/utils/kernel/kmod/${P}.tar.xz"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
- inherit libtool
-fi
-
-DESCRIPTION="library and tools for managing linux kernel modules"
-HOMEPAGE="http://git.kernel.org/?p=utils/kernel/kmod/kmod.git"
-
-LICENSE="LGPL-2"
-SLOT="0"
-IUSE="debug doc lzma python static-libs +tools zlib"
-
-# Upstream does not support running the test suite with custom configure flags.
-# I was also told that the test suite is intended for kmod developers.
-# So we have to restrict it.
-# See bug #408915.
-RESTRICT="test"
-
-RDEPEND="!sys-apps/module-init-tools
- !sys-apps/modutils
- !<sys-apps/openrc-0.12
- lzma? ( >=app-arch/xz-utils-5.0.4-r1 )
- python? ( ${PYTHON_DEPS} )
- zlib? ( >=sys-libs/zlib-1.2.6 )" #427130
-DEPEND="${RDEPEND}
- doc? ( dev-util/gtk-doc )
- lzma? ( virtual/pkgconfig )
- python? (
- dev-python/cython[${PYTHON_USEDEP}]
- virtual/pkgconfig
- )
- zlib? ( virtual/pkgconfig )"
-if [[ ${PV} == 9999* ]]; then
- DEPEND="${DEPEND}
- dev-libs/libxslt"
-fi
-
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-DOCS="NEWS README TODO"
-
-src_prepare() {
- if [ ! -e configure ]; then
- if use doc; then
- gtkdocize --copy --docdir libkmod/docs || die
- else
- touch libkmod/docs/gtk-doc.make
- fi
- eautoreconf
- else
- epatch "${FILESDIR}"/${PN}-15-dynamic-kmod.patch #493630
- elibtoolize
- fi
-
- # Restore possibility of running --enable-static wrt #472608
- sed -i \
- -e '/--enable-static is not supported by kmod/s:as_fn_error:echo:' \
- configure || die
-}
-
-src_configure() {
- local myeconfargs=(
- --bindir="${EPREFIX}/bin"
- --with-rootlibdir="${EPREFIX}/$(get_libdir)"
- --enable-shared
- $(use_enable static-libs static)
- $(use_enable tools)
- $(use_enable debug)
- $(use_enable doc gtk-doc)
- $(use_with lzma xz)
- $(use_with zlib)
- --with-bashcompletiondir="$(get_bashcompdir)"
- )
-
- local ECONF_SOURCE="${S}"
-
- kmod_configure() {
- mkdir -p "${BUILD_DIR}" || die
- run_in_build_dir econf "${myeconfargs[@]}" "$@"
- }
-
- BUILD_DIR="${WORKDIR}/build"
- kmod_configure --disable-python
-
- if use python; then
- python_parallel_foreach_impl kmod_configure --enable-python
- fi
-}
-
-src_compile() {
- if [[ ${PV} != 9999* ]]; then
- # Force -j1 because of -15-dynamic-kmod.patch, likely caused by lack of eautoreconf
- # wrt #494806
- local MAKEOPTS="${MAKEOPTS} -j1"
- fi
-
- emake -C "${BUILD_DIR}"
-
- if use python; then
- local native_builddir=${BUILD_DIR}
-
- python_compile() {
- emake -C "${BUILD_DIR}" -f Makefile -f - python \
- VPATH="${native_builddir}:${S}" \
- native_builddir="${native_builddir}" \
- libkmod_python_kmod_{kmod,list,module,_util}_la_LIBADD='$(PYTHON_LIBS) $(native_builddir)/libkmod/libkmod.la' \
- <<< 'python: $(pkgpyexec_LTLIBRARIES)'
- }
-
- python_foreach_impl python_compile
- fi
-}
-
-src_install() {
- emake -C "${BUILD_DIR}" DESTDIR="${D}" install
- einstalldocs
-
- if use python; then
- local native_builddir=${BUILD_DIR}
-
- python_install() {
- emake -C "${BUILD_DIR}" DESTDIR="${D}" \
- VPATH="${native_builddir}:${S}" \
- install-pkgpyexecLTLIBRARIES \
- install-dist_pkgpyexecPYTHON
- }
-
- python_foreach_impl python_install
- fi
-
- prune_libtool_files --modules
-
- if use tools; then
- local bincmd sbincmd
- for sbincmd in depmod insmod lsmod modinfo modprobe rmmod; do
- dosym /bin/kmod /sbin/${sbincmd}
- done
-
- # These are also usable as normal user
- for bincmd in lsmod modinfo; do
- dosym kmod /bin/${bincmd}
- done
- fi
-
- cat <<-EOF > "${T}"/usb-load-ehci-first.conf
- softdep uhci_hcd pre: ehci_hcd
- softdep ohci_hcd pre: ehci_hcd
- EOF
-
- insinto /lib/modprobe.d
- doins "${T}"/usb-load-ehci-first.conf #260139
-
- doinitd "${FILESDIR}"/kmod-static-nodes
-}
-
-pkg_postinst() {
- if [[ -L ${EROOT%/}/etc/runlevels/boot/static-nodes ]]; then
- ewarn "Removing old conflicting static-nodes init script from the boot runlevel"
- rm -f "${EROOT%/}"/etc/runlevels/boot/static-nodes
- fi
-
- # Add kmod to the runlevel automatically if this is the first install of this package.
- if [[ -z ${REPLACING_VERSIONS} ]]; then
- if [[ ! -d ${EROOT%/}/etc/runlevels/sysinit ]]; then
- mkdir -p "${EROOT%/}"/etc/runlevels/sysinit
- fi
- if [[ -x ${EROOT%/}/etc/init.d/kmod-static-nodes ]]; then
- ln -s /etc/init.d/kmod-static-nodes "${EROOT%/}"/etc/runlevels/sysinit/kmod-static-nodes
- fi
- fi
-
- if [[ -e ${EROOT%/}/etc/runlevels/sysinit ]]; then
- if [[ ! -e ${EROOT%/}/etc/runlevels/sysinit/kmod-static-nodes ]]; then
- ewarn
- ewarn "You need to add kmod-static-nodes to the sysinit runlevel for"
- ewarn "kernel modules to have required static nodes!"
- ewarn "Run this command:"
- ewarn "\trc-update add kmod-static-nodes sysinit"
- fi
- fi
-}