summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Yamin <plasmaroo@gentoo.org>2004-10-23 22:40:37 +0000
committerTim Yamin <plasmaroo@gentoo.org>2004-10-23 22:40:37 +0000
commita4ccec943c4e81aeb615a613b8b415d43f7c7907 (patch)
treedd24b65a32746e474d9de687a88b82bc9d787dbb /sys-apps/i2c
parentfix -py21 dependencie (Manifest recommit) (diff)
downloadgentoo-2-a4ccec943c4e81aeb615a613b8b415d43f7c7907.tar.gz
gentoo-2-a4ccec943c4e81aeb615a613b8b415d43f7c7907.tar.bz2
gentoo-2-a4ccec943c4e81aeb615a613b8b415d43f7c7907.zip
Version bump; bug #67587. Also made the 2.8.4 and 2.8.7 ebuilds install if we happen to be cross-compiling for another kernel tree.
Diffstat (limited to 'sys-apps/i2c')
-rw-r--r--sys-apps/i2c/ChangeLog7
-rw-r--r--sys-apps/i2c/files/digest-i2c-2.8.81
-rw-r--r--sys-apps/i2c/i2c-2.8.4.ebuild5
-rw-r--r--sys-apps/i2c/i2c-2.8.7.ebuild5
-rw-r--r--sys-apps/i2c/i2c-2.8.8.ebuild125
5 files changed, 138 insertions, 5 deletions
diff --git a/sys-apps/i2c/ChangeLog b/sys-apps/i2c/ChangeLog
index c1ea4cf17e90..5d6843c2c13d 100644
--- a/sys-apps/i2c/ChangeLog
+++ b/sys-apps/i2c/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/i2c
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/i2c/ChangeLog,v 1.24 2004/09/22 12:40:22 kugelfang Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/i2c/ChangeLog,v 1.25 2004/10/23 22:40:37 plasmaroo Exp $
+
+*i2c-2.8.8 (23 Oct 2004)
+
+ 23 Oct 2004; <plasmaroo@gentoo.org> +i2c-2.8.8.ebuild:
+ Version bump; bug #67587.
22 Sep 2004; Danny van Dyk <kugelfang@gentoo.org> i2c-2.8.7.ebuild:
Marked stable on amd64.
diff --git a/sys-apps/i2c/files/digest-i2c-2.8.8 b/sys-apps/i2c/files/digest-i2c-2.8.8
new file mode 100644
index 000000000000..6332dd3fe5e5
--- /dev/null
+++ b/sys-apps/i2c/files/digest-i2c-2.8.8
@@ -0,0 +1 @@
+MD5 f950162cbbfcec56e594981be2d8a9cf i2c-2.8.8.tar.gz 139995
diff --git a/sys-apps/i2c/i2c-2.8.4.ebuild b/sys-apps/i2c/i2c-2.8.4.ebuild
index 119afcc08fd4..7a955e629757 100644
--- a/sys-apps/i2c/i2c-2.8.4.ebuild
+++ b/sys-apps/i2c/i2c-2.8.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/i2c/i2c-2.8.4.ebuild,v 1.9 2004/09/06 00:42:53 ciaranm Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/i2c/i2c-2.8.4.ebuild,v 1.10 2004/10/23 22:40:37 plasmaroo Exp $
inherit eutils
@@ -94,7 +94,8 @@ src_compile () {
}
src_install() {
- if echo ${KV} | grep -q 2.4.; then
+ echo ${KV} | grep -q 2.4.
+ if [ "$?" -eq '0' -o "$LINUX" != '' ]; then
emake \
CC=${CC} \
LINUX=$LINUX \
diff --git a/sys-apps/i2c/i2c-2.8.7.ebuild b/sys-apps/i2c/i2c-2.8.7.ebuild
index 07d64de04173..049fa01327b2 100644
--- a/sys-apps/i2c/i2c-2.8.7.ebuild
+++ b/sys-apps/i2c/i2c-2.8.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/i2c/i2c-2.8.7.ebuild,v 1.7 2004/09/22 12:40:22 kugelfang Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/i2c/i2c-2.8.7.ebuild,v 1.8 2004/10/23 22:40:37 plasmaroo Exp $
inherit eutils
@@ -94,7 +94,8 @@ src_compile () {
}
src_install() {
- if echo ${KV} | grep -q 2.4.; then
+ echo ${KV} | grep -q 2.4.
+ if [ "$?" -eq '0' -o "$LINUX" != '' ]; then
emake \
CC=${CC} \
LINUX=$LINUX \
diff --git a/sys-apps/i2c/i2c-2.8.8.ebuild b/sys-apps/i2c/i2c-2.8.8.ebuild
new file mode 100644
index 000000000000..b6c4bfd5692f
--- /dev/null
+++ b/sys-apps/i2c/i2c-2.8.8.ebuild
@@ -0,0 +1,125 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/i2c/i2c-2.8.8.ebuild,v 1.1 2004/10/23 22:40:37 plasmaroo Exp $
+
+inherit eutils
+
+DESCRIPTION="I2C Bus support for 2.4.x kernels"
+HOMEPAGE="http://www2.lm-sensors.nu/~lm78/"
+SRC_URI="http://www2.lm-sensors.nu/~lm78/archive/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="${KV}"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND=""
+
+pkg_setup() {
+ echo
+ eerror "*****************************************************************"
+ eerror
+ eerror "WARNING: This i2c support is not recommended for things such as "
+ eerror "WARNING: BTTV"
+ eerror
+ eerror "*****************************************************************"
+ eerror
+ eerror "http://www2.lm-sensors.nu/~lm78/cvs/browse.cgi/lm_sensors2/README"
+ eerror
+ eerror "40 ADDITIONALLY, i2c-2.8.8 is not API compatible to earlier i2c"
+ eerror "41 releases due to struct changes; therefore you must NOT ENABLE"
+ eerror "42 any other i2c drivers (e.g. bttv) in the kernel."
+ eerror "43 Do NOT use lm-sensors 2.8.8 or i2c-2.8.8 if you require bttv."
+ eerror
+ eerror "Please try out http://khai.linux-fr.org/devel/i2c/ for a kernel"
+ eerror "patch which will fix this problem. Please note that nor the"
+ eerror "lm_sensors team nor the package maintainers will be able to"
+ eerror "support you if you encounter problems with I2C when using"
+ eerror "other modules with requirements on I2C..."
+ eerror
+ eerror "*****************************************************************"
+ echo
+}
+
+src_compile () {
+ if [ "$LINUX" != "" ]; then
+ einfo "Cross-compiling using:- $LINUX"
+ einfo "Using headers from:- `echo $LINUX/include/linux | sed 's/\/\//\//'`"
+ LINUX=`echo $LINUX | sed 's/build\//build/'`
+ else
+ einfo "You are running:- `uname -r`"
+ check_KV || die "Cannot find kernel in /usr/src/linux"
+ einfo "Using kernel in /usr/src/linux:- ${KV}"
+
+ echo ${KV} | grep -q 2.4.
+ if [ $? == 1 ]; then
+ echo
+ einfo "*****************************************************************"
+ einfo
+ einfo "For 2.5+ series kernels, use the support already in the kernel"
+ einfo "under 'Character devices' -> 'I2C support'."
+ einfo
+ einfo "To cross-compile, 'export LINUX=\"/lib/modules/<version>/build\"'"
+ einfo "or symlink /usr/src/linux to another kernel."
+ einfo
+ einfo "*****************************************************************"
+ echo
+ ewarn "Non-2.4 kernel detected; doing nothing..."
+ return
+ else
+ LINUX='/usr/src/linux'
+ fi
+
+ if [ "${KV}" != "`uname -r`" ]; then
+ ewarn "WARNING:- kernels do not match!"
+ fi
+ fi
+
+ cd kernel;
+ epatch ${FILESDIR}/i2c-2.8.0-alphaCompile.patch > /dev/null;
+ cd ..;
+
+ echo; einfo "You may safely ignore any errors from compilation"
+ einfo "that contain 'No such file' references."
+ echo '>>> Compiling...'
+
+ emake CC=${CC} LINUX=$LINUX clean all
+ if [ $? != 0 ]; then
+ eerror "I2C requires the source of a compatible kernel"
+ eerror "version installed in /usr/src/linux"
+ eerror "(or the environmental variable \$LINUX)"
+ eerror "and kernel I2C *disabled* or *enabled as a module*"
+ die "Error: compilation failed!"
+ fi
+}
+
+src_install() {
+ echo ${KV} | grep -q 2.4.
+ if [ "$?" -eq '0' -o "$LINUX" != '' ]; then
+ emake \
+ CC=${CC} \
+ LINUX=$LINUX \
+ LINUX_INCLUDE_DIR=/usr/include/linux \
+ DESTDIR=${D} \
+ PREFIX=/usr \
+ MANDIR=/usr/share/man \
+ install || die
+ epause 5 # Show important warnings from the Makefile
+ dodoc CHANGES INSTALL README
+ fi
+}
+
+pkg_postinst() {
+ if echo ${KV} | grep -q 2.4.; then
+ [ -x /usr/sbin/update-modules ] && /usr/sbin/update-modules
+
+ einfo
+ einfo "I2C modules installed ..."
+ einfo
+ ewarn "IMPORTANT ... if you are installing this package you need to"
+ ewarn "IMPORTANT ... *disable* kernel I2C support OR *modularize it*"
+ ewarn "IMPORTANT ... if your 2.4.x kernel is patched with such support"
+ einfo
+ echo
+ fi
+}