summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2011-08-31 15:53:45 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2011-08-31 15:53:45 +0000
commit32353b2c7831417031440ae1283d264e5a4f1894 (patch)
treefa3c8f750cf89e94421c695d86068e34856448cf /sys-apps/hwloc
parentVersion bump (diff)
downloadgentoo-2-32353b2c7831417031440ae1283d264e5a4f1894.tar.gz
gentoo-2-32353b2c7831417031440ae1283d264e5a4f1894.tar.bz2
gentoo-2-32353b2c7831417031440ae1283d264e5a4f1894.zip
[sys-apps/hwloc] Update deps
Commited with force option because jer dont permit modiffication of profiles/arch/hppa/package.use.mask (Portage version: 2.2.0_alpha51/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'sys-apps/hwloc')
-rw-r--r--sys-apps/hwloc/ChangeLog7
-rw-r--r--sys-apps/hwloc/hwloc-1.2-r1.ebuild41
-rw-r--r--sys-apps/hwloc/metadata.xml5
3 files changed, 51 insertions, 2 deletions
diff --git a/sys-apps/hwloc/ChangeLog b/sys-apps/hwloc/ChangeLog
index 744fb7d285de..d25c2a1bb8c7 100644
--- a/sys-apps/hwloc/ChangeLog
+++ b/sys-apps/hwloc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/hwloc
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwloc/ChangeLog,v 1.11 2011/08/02 11:37:34 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwloc/ChangeLog,v 1.12 2011/08/31 15:53:45 alexxy Exp $
+
+*hwloc-1.2-r1 (31 Aug 2011)
+
+ 31 Aug 2011; Alexey Shvetsov <alexxy@gentoo.org> +hwloc-1.2-r1.ebuild:
+ Update deps
02 Aug 2011; Kacper Kowalik <xarthisius@gentoo.org> hwloc-1.2.ebuild:
Fix sandbox violation wrt bug 377375 by Vasileios Lourdas
diff --git a/sys-apps/hwloc/hwloc-1.2-r1.ebuild b/sys-apps/hwloc/hwloc-1.2-r1.ebuild
new file mode 100644
index 000000000000..6febb9f1c49c
--- /dev/null
+++ b/sys-apps/hwloc/hwloc-1.2-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwloc/hwloc-1.2-r1.ebuild,v 1.1 2011/08/31 15:53:45 alexxy Exp $
+
+EAPI="4"
+
+inherit multilib versionator
+
+MY_PV=v$(get_version_component_range 1-2)
+
+DESCRIPTION="displays the hardware topology in convenient formats"
+HOMEPAGE="http://www.open-mpi.org/projects/hwloc/"
+SRC_URI="http://www.open-mpi.org/software/${PN}/${MY_PV}/downloads/${P}.tar.bz2"
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux"
+IUSE="cairo +numa svg static-libs xml X"
+SLOT="0"
+LICENSE="BSD"
+
+RDEPEND="sys-libs/ncurses
+ cairo? ( x11-libs/cairo[X?,svg?] )
+ xml? ( dev-libs/libxml2 )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ numa? ( sys-process/numactl )"
+
+src_configure() {
+ econf \
+ --docdir="${EPREFIX}/usr/share/doc/${P}" \
+ $(use_enable cairo) \
+ $(use_enable static-libs static) \
+ $(use_enable xml) \
+ $(use_with X x) \
+ --disable-silent-rules
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS NEWS README VERSION
+ use static-libs || rm "${D}"/usr/$(get_libdir)/lib${PN}.la
+}
diff --git a/sys-apps/hwloc/metadata.xml b/sys-apps/hwloc/metadata.xml
index 57f2fcfe3768..b8a6bd10f64b 100644
--- a/sys-apps/hwloc/metadata.xml
+++ b/sys-apps/hwloc/metadata.xml
@@ -13,5 +13,8 @@
It also gathers various system attributes such as cache and memory information.
It primarily aims at helping applications with gathering information about modern computing
hardware so as to exploit it accordingly and efficiently.
- </longdescription>
+ </longdescription>
+ <use>
+ <flag name='numa'>Add support for numa memory allocation</flag>
+ </use>
</pkgmetadata>