summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2002-01-01 22:35:51 +0000
committerMartin Schlemmer <azarah@gentoo.org>2002-01-01 22:35:51 +0000
commit6958fd94660a6f75a8de8b52b4f994965b22573c (patch)
tree1fc05a3b3717559d2787ef0c8284e2eb26a87775 /sys-apps/gzip
parentlots of cleanup. jpeg,zlib,libpng should now extract in the correct dirs (diff)
downloadgentoo-2-6958fd94660a6f75a8de8b52b4f994965b22573c.tar.gz
gentoo-2-6958fd94660a6f75a8de8b52b4f994965b22573c.tar.bz2
gentoo-2-6958fd94660a6f75a8de8b52b4f994965b22573c.zip
header, tab fixes
Diffstat (limited to 'sys-apps/gzip')
-rw-r--r--sys-apps/gzip/gzip-1.3.2.ebuild26
1 files changed, 15 insertions, 11 deletions
diff --git a/sys-apps/gzip/gzip-1.3.2.ebuild b/sys-apps/gzip/gzip-1.3.2.ebuild
index 216ed0cfc6e0..295aa8a1acb1 100644
--- a/sys-apps/gzip/gzip-1.3.2.ebuild
+++ b/sys-apps/gzip/gzip-1.3.2.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# Author Daniel Robbins <drobbins@gentoo.org>, Chad Huneycutt <chad.huneycutt@acm.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/gzip/gzip-1.3.2.ebuild,v 1.1 2001/12/17 17:25:01 azarah Exp $
+# Maintainer: Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/gzip/gzip-1.3.2.ebuild,v 1.2 2002/01/01 22:35:51 azarah Exp $
S=${WORKDIR}/${P}
DESCRIPTION="Standard GNU compressor"
@@ -19,19 +19,26 @@ src_unpack() {
src_compile() {
[ -z "`use nls`" ] && myconf="--disable-nls"
- ./configure --host=${CHOST} --prefix=/usr --exec-prefix=/ --mandir=/usr/share/man --infodir=/usr/share/info ${myconf} || die
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --exec-prefix=/ \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ ${myconf} || die
emake || die
}
src_install() {
dodir /usr/bin /usr/share/man/man1
- make prefix=${D}/usr exec_prefix=${D}/ mandir=${D}/usr/share/man infodir=${D}/usr/share/info install || die
+ make prefix=${D}/usr \
+ exec_prefix=${D}/ \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ install || die
cd ${D}/bin
for i in gzexe zforce zgrep zmore znew zcmp
do
- cp ${i} ${i}.orig
- sed -e "1d" -e "s:${D}::" ${i}.orig > ${i}
- rm ${i}.orig
+ dosed -e "1d" -e "s:${D}::" ${i}
chmod 755 ${i}
done
if [ -z "`use build`" ]
@@ -51,6 +58,3 @@ src_install() {
fi
}
-
-
-