summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-02-12 01:32:05 +0000
committerMike Frysinger <vapier@gentoo.org>2005-02-12 01:32:05 +0000
commit9997083c92a2332173fa6926f86d997738558d5d (patch)
tree821eba769bd04951613a81e0c6ef5bfc3596f0fc /sys-apps/gpart
parentInitial import. Stripped out of media-sound/xmms. (diff)
downloadgentoo-2-9997083c92a2332173fa6926f86d997738558d5d.tar.gz
gentoo-2-9997083c92a2332173fa6926f86d997738558d5d.tar.bz2
gentoo-2-9997083c92a2332173fa6926f86d997738558d5d.zip
respect CFLAGS and dont bomb when PIC is defined #43440
(Portage version: 2.0.51-r15)
Diffstat (limited to 'sys-apps/gpart')
-rw-r--r--sys-apps/gpart/ChangeLog12
-rw-r--r--sys-apps/gpart/files/gpart-0.1h-PIC.patch11
-rw-r--r--sys-apps/gpart/gpart-0.1h-r1.ebuild4
3 files changed, 20 insertions, 7 deletions
diff --git a/sys-apps/gpart/ChangeLog b/sys-apps/gpart/ChangeLog
index b117d5b897d2..1d41d0078ca7 100644
--- a/sys-apps/gpart/ChangeLog
+++ b/sys-apps/gpart/ChangeLog
@@ -1,15 +1,15 @@
# ChangeLog for sys-apps/gpart
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/gpart/ChangeLog,v 1.7 2005/02/12 01:23:51 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/gpart/ChangeLog,v 1.8 2005/02/12 01:32:05 vapier Exp $
*gpart-0.1h-r1 (11 Feb 2005)
11 Feb 2005; Mike Frysinger <vapier@gentoo.org>
- -files/gpart-0.1h-errno.diff, +files/gpart-0.1h-errno.patch,
- +files/gpart-0.1h-ntfs.patch, +files/gpart-0.1h-vfat.patch,
- +gpart-0.1h-r1.ebuild, -gpart-0.1h.ebuild:
- Add fix from reiserfs for #49732 by Brice Arnould. Grab patches from Debian
- to fix NTFS building #49878 by Hans-Christian Armingeon.
+ +files/gpart-0.1h-errno.patch, +files/gpart-0.1h-ntfs.patch,
+ +files/gpart-0.1h-vfat.patch, +files/gpart-0.1h-PIC.patch:
+ Add fix from reiserfs for #49732 by Brice Arnould. Grab patches from Debian
+ to fix NTFS building #49878 by Hans-Christian Armingeon. Fix building with
+ hardened (PIC) #43440 by John Davis.
*gpart-0.1h (09 Feb 2003)
diff --git a/sys-apps/gpart/files/gpart-0.1h-PIC.patch b/sys-apps/gpart/files/gpart-0.1h-PIC.patch
new file mode 100644
index 000000000000..6c57a9b1c66b
--- /dev/null
+++ b/sys-apps/gpart/files/gpart-0.1h-PIC.patch
@@ -0,0 +1,11 @@
+--- gpart-0.1h/src/l64seek.c.orig 2005-02-11 20:29:24.000000000 -0500
++++ gpart-0.1h/src/l64seek.c 2005-02-11 20:29:46.000000000 -0500
+@@ -26,7 +26,7 @@
+ } ostck[OSTACKLEN];
+ static int osptr = -1;
+
+-#if defined(__linux__) && defined(__i386__)
++#if defined(__linux__) && defined(__i386__) && ! defined(__PIC__)
+ _syscall5(int,_llseek,uint,fd,ulong,hi,ulong,lo,loff_t *,res,uint,wh)
+ #endif
+
diff --git a/sys-apps/gpart/gpart-0.1h-r1.ebuild b/sys-apps/gpart/gpart-0.1h-r1.ebuild
index 29792f39b0e7..33e29ceba0ed 100644
--- a/sys-apps/gpart/gpart-0.1h-r1.ebuild
+++ b/sys-apps/gpart/gpart-0.1h-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/gpart/gpart-0.1h-r1.ebuild,v 1.1 2005/02/12 01:23:51 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/gpart/gpart-0.1h-r1.ebuild,v 1.2 2005/02/12 01:32:05 vapier Exp $
inherit eutils
@@ -22,7 +22,9 @@ src_unpack() {
epatch "${FILESDIR}"/${P}-errno.patch
epatch "${FILESDIR}"/${P}-vfat.patch
epatch "${FILESDIR}"/${P}-ntfs.patch
+ epatch "${FILESDIR}"/${P}-PIC.patch
epatch "${WORKDIR}"/gpart-0.1h-reiserfs-3.6.patch
+ sed -i -e "/^CFLAGS/s: -O2 : ${CFLAGS} :" make.defs
}
src_install() {