summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2001-12-17 13:57:28 +0000
committerMartin Schlemmer <azarah@gentoo.org>2001-12-17 13:57:28 +0000
commite35d6876767e0baa525d0deac59c5c21c916c315 (patch)
tree8a634a2616bc853000288d73490f5406b2b6921f /sys-apps/fileutils
parentnew version (diff)
downloadgentoo-2-e35d6876767e0baa525d0deac59c5c21c916c315.tar.gz
gentoo-2-e35d6876767e0baa525d0deac59c5c21c916c315.tar.bz2
gentoo-2-e35d6876767e0baa525d0deac59c5c21c916c315.zip
new version
Diffstat (limited to 'sys-apps/fileutils')
-rw-r--r--sys-apps/fileutils/files/digest-fileutils-4.1.41
-rw-r--r--sys-apps/fileutils/fileutils-4.1.4.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/sys-apps/fileutils/files/digest-fileutils-4.1.4 b/sys-apps/fileutils/files/digest-fileutils-4.1.4
new file mode 100644
index 000000000000..af9b54d6deae
--- /dev/null
+++ b/sys-apps/fileutils/files/digest-fileutils-4.1.4
@@ -0,0 +1 @@
+MD5 f8df4aa3a4adf0c922802331511baaaa fileutils-4.1.4.tar.gz 2326528
diff --git a/sys-apps/fileutils/fileutils-4.1.4.ebuild b/sys-apps/fileutils/fileutils-4.1.4.ebuild
new file mode 100644
index 000000000000..9ec9da86ee99
--- /dev/null
+++ b/sys-apps/fileutils/fileutils-4.1.4.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Daniel Robbins <drobbins@gentoo.org>, Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/fileutils/fileutils-4.1.4.ebuild,v 1.1 2001/12/17 13:57:28 azarah Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Standard GNU file utilities (chmod, cp, dd, dir, ls, etc)"
+SRC_URI="ftp://alpha.gnu.org/gnu/fetish/${P}.tar.gz"
+HOMEPAGE="http://www.gnu.org/software/fileutils/fileutils.html"
+
+DEPEND="virtual/glibc nls? ( sys-devel/gettext )"
+RDEPEND="virtual/glibc"
+
+src_compile() {
+ local myconf
+ [ -z "`use nls`" ] && myconf="--disable-nls"
+ ./configure --prefix=/usr --mandir=/usr/share/man --infodir=/usr/share/info --bindir=/bin ${myconf} || die
+ emake || die
+}
+
+src_install() {
+ make prefix=${D}/usr mandir=${D}/usr/share/man infodir=${D}/usr/share/info bindir=${D}/bin install || die
+ cd ${D}
+ dodir /usr/bin
+ rm -rf usr/lib
+ cd usr/bin
+ ln -s ../../bin/* .
+ if [ -z "`use build`" ]
+ then
+ cd ${S}
+ dodoc COPYING NEWS README* THANKS TODO ChangeLog ChangeLog-1997 AUTHORS
+
+ #conflicts with textutils. seems that they install the same
+ #.info file between the two of them
+ rm -f ${D}/usr/share/info/coreutils.info
+ else
+ rm -rf ${D}/usr/share
+ fi
+}
+