summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2011-10-23 16:07:54 +0000
committerAnthony G. Basile <blueness@gentoo.org>2011-10-23 16:07:54 +0000
commit10fb762dc99e24da3d789ad156e3c1bf29cd4749 (patch)
tree9b330ca247f55f050fd6e7048272cd9b4e0a69db /sys-apps/elfix
parentsparc stable wrt #385205 (diff)
downloadgentoo-2-10fb762dc99e24da3d789ad156e3c1bf29cd4749.tar.gz
gentoo-2-10fb762dc99e24da3d789ad156e3c1bf29cd4749.tar.bz2
gentoo-2-10fb762dc99e24da3d789ad156e3c1bf29cd4749.zip
Version bump, adds XT_PAX support
(Portage version: 2.1.10.11/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/elfix')
-rw-r--r--sys-apps/elfix/ChangeLog5
-rw-r--r--sys-apps/elfix/elfix-0.3.0.ebuild29
2 files changed, 34 insertions, 0 deletions
diff --git a/sys-apps/elfix/ChangeLog b/sys-apps/elfix/ChangeLog
index 0fcf4a84c879..056ce35720d5 100644
--- a/sys-apps/elfix/ChangeLog
+++ b/sys-apps/elfix/ChangeLog
@@ -1,5 +1,10 @@
+*elfix-0.3.0 (23 Oct 2011)
+
+ 23 Oct 2011; Anthony G. Basile <blueness@gentoo.org> +elfix-0.3.0.ebuild:
+ Version bump, adds XT_PAX support
+
*elfix-0.2.5 (17 Oct 2011)
17 Oct 2011; Anthony G. Basile <blueness@gentoo.org> -elfix-0.2.3.ebuild,
diff --git a/sys-apps/elfix/elfix-0.3.0.ebuild b/sys-apps/elfix/elfix-0.3.0.ebuild
new file mode 100644
index 000000000000..492200571cc7
--- /dev/null
+++ b/sys-apps/elfix/elfix-0.3.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/elfix/elfix-0.3.0.ebuild,v 1.1 2011/10/23 16:07:54 blueness Exp $
+
+EAPI=4
+
+DESCRIPTION="Tools to fix ELF binaries to work on Hardened Gentoo"
+HOMEPAGE="http://dev.gentoo.org/~blueness/elfix/"
+SRC_URI="http://dev.gentoo.org/~blueness/elfix/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="dev-libs/elfutils
+ dev-python/pypax
+ test? ( dev-lang/yasm )"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ rm -f "${S}/scripts/setup.py"
+ econf $(use_enable test tests)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS ChangeLog INSTALL README THANKS TODO
+}