summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2012-11-10 01:52:23 +0000
committerMike Frysinger <vapier@gentoo.org>2012-11-10 01:52:23 +0000
commit22970b977097e80ee03935d44d4546c171eecc36 (patch)
tree16957affd2e3e5ad5e04634c0ef3fd125c2cab58 /sys-apps/dtc
parentVersion bump; a patch is needed for a test failure with USE=-dane. (diff)
downloadgentoo-2-22970b977097e80ee03935d44d4546c171eecc36.tar.gz
gentoo-2-22970b977097e80ee03935d44d4546c171eecc36.tar.bz2
gentoo-2-22970b977097e80ee03935d44d4546c171eecc36.zip
Backport fix from upstream for renaming ftdump to fdtdump #372895 by dacook.
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, signed Manifest commit with key FB7C4156)
Diffstat (limited to 'sys-apps/dtc')
-rw-r--r--sys-apps/dtc/ChangeLog9
-rw-r--r--sys-apps/dtc/dtc-1.3.0-r1.ebuild52
-rw-r--r--sys-apps/dtc/dtc-1.3.0.ebuild3
-rw-r--r--sys-apps/dtc/dtc-9999.ebuild5
-rw-r--r--sys-apps/dtc/files/dtc-1.3.0-fdtdump.patch118
5 files changed, 180 insertions, 7 deletions
diff --git a/sys-apps/dtc/ChangeLog b/sys-apps/dtc/ChangeLog
index 41ab21bfb6cf..f614c2deb9f2 100644
--- a/sys-apps/dtc/ChangeLog
+++ b/sys-apps/dtc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/dtc
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/dtc/ChangeLog,v 1.13 2012/11/03 19:24:19 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dtc/ChangeLog,v 1.14 2012/11/10 01:52:23 vapier Exp $
+
+*dtc-1.3.0-r1 (10 Nov 2012)
+
+ 10 Nov 2012; Mike Frysinger <vapier@gentoo.org> +dtc-1.3.0-r1.ebuild,
+ +files/dtc-1.3.0-fdtdump.patch, dtc-1.3.0.ebuild, dtc-9999.ebuild:
+ Backport fix from upstream for renaming ftdump to fdtdump #372895 by dacook.
03 Nov 2012; Samuli Suominen <ssuominen@gentoo.org> -dtc-1.0.0.ebuild,
-files/dtc-1.0.0-Makefile.patch, -dtc-1.2.0.ebuild:
@@ -53,4 +59,3 @@
07 Dec 2007; Luca Barbato <lu_zero@gentoo.org> +metadata.xml,
+dtc-1.0.0.ebuild:
First commit (imported from cell overlay)
-
diff --git a/sys-apps/dtc/dtc-1.3.0-r1.ebuild b/sys-apps/dtc/dtc-1.3.0-r1.ebuild
new file mode 100644
index 000000000000..67b33ab8f794
--- /dev/null
+++ b/sys-apps/dtc/dtc-1.3.0-r1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dtc/dtc-1.3.0-r1.ebuild,v 1.1 2012/11/10 01:52:23 vapier Exp $
+
+EAPI="4"
+MY_P="${PN}-v${PV}"
+
+inherit multilib toolchain-funcs eutils
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://git.jdl.com/software/dtc.git"
+ inherit git-2
+else
+ SRC_URI="http://www.jdl.com/software/${MY_P}.tgz"
+ KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+fi
+
+DESCRIPTION="Open Firmware device-trees compiler"
+HOMEPAGE="http://git.jdl.com/gitweb/?p=dtc.git"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="static-libs"
+
+RDEPEND=""
+DEPEND="sys-devel/flex
+ sys-devel/bison"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-fdtdump.patch #372895
+ sed -i \
+ -e '/^CFLAGS =/s:=:+=:' \
+ -e '/^CPPFLAGS =/s:=:+=:' \
+ -e 's:-Werror::' \
+ -e 's:-g -Os::' \
+ -e '/^PREFIX =/s:=.*:= /usr:' \
+ -e "/^LIBDIR =/s:=.*:= /usr/$(get_libdir):" \
+ Makefile || die
+ tc-export AR CC
+ export V=1
+}
+
+src_test() {
+ emake check
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ use static-libs || find "${ED}" -name '*.a' -delete
+ dodoc Documentation/manual.txt
+}
diff --git a/sys-apps/dtc/dtc-1.3.0.ebuild b/sys-apps/dtc/dtc-1.3.0.ebuild
index b47c69fe6c6a..9f477d0c9285 100644
--- a/sys-apps/dtc/dtc-1.3.0.ebuild
+++ b/sys-apps/dtc/dtc-1.3.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/dtc/dtc-1.3.0.ebuild,v 1.4 2012/11/03 19:24:19 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dtc/dtc-1.3.0.ebuild,v 1.5 2012/11/10 01:52:23 vapier Exp $
EAPI=4
inherit toolchain-funcs
@@ -42,6 +42,5 @@ src_test() {
src_install() {
emake DESTDIR="${D}" PREFIX="/usr" LIBDIR="/usr/$(get_libdir)" \
install
- [[ ${D}/usr/bin/ftdump ]] && mv "${D}"/usr/bin/ftdump{,.dtc} #372895
dodoc Documentation/manual.txt
}
diff --git a/sys-apps/dtc/dtc-9999.ebuild b/sys-apps/dtc/dtc-9999.ebuild
index 300eef8fc674..dc8e2c8d28e3 100644
--- a/sys-apps/dtc/dtc-9999.ebuild
+++ b/sys-apps/dtc/dtc-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/dtc/dtc-9999.ebuild,v 1.2 2012/11/03 19:20:21 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dtc/dtc-9999.ebuild,v 1.3 2012/11/10 01:52:23 vapier Exp $
EAPI="4"
MY_P="${PN}-v${PV}"
@@ -46,7 +46,6 @@ src_test() {
src_install() {
emake DESTDIR="${D}" install
- use static-libs || find "${D}" -name '*.a' -delete
- [[ ${D}/usr/bin/ftdump ]] && mv "${D}"/usr/bin/ftdump{,.dtc} #372895
+ use static-libs || find "${ED}" -name '*.a' -delete
dodoc Documentation/manual.txt
}
diff --git a/sys-apps/dtc/files/dtc-1.3.0-fdtdump.patch b/sys-apps/dtc/files/dtc-1.3.0-fdtdump.patch
new file mode 100644
index 000000000000..0bb1c8c88742
--- /dev/null
+++ b/sys-apps/dtc/files/dtc-1.3.0-fdtdump.patch
@@ -0,0 +1,118 @@
+https://bugs.gentoo.org/372895
+
+From 8f459c5d72673e1a3a119ac58a7eee56236fca73 Mon Sep 17 00:00:00 2001
+From: Mike Frysinger <vapier@gentoo.org>
+Date: Tue, 25 Oct 2011 17:29:24 -0400
+Subject: [PATCH] fdtdump: rename from ftdump
+
+The freetype package already installs a binary named "ftdump", so the dtc
+package conflicts with that. So rename the newer dtc tool to "fdtdump".
+This even makes a bit more sense:
+ ftdump: [F]lat device [T]ree [dump]
+ fdtdump: [F]lat [D]evice [T]ree [dump]
+
+Signed-off-by: Mike Frysinger <vapier@gentoo.org>
+Acked-by: David Gibson <david@gibson.dropbear.id.au>
+---
+ .gitignore | 2 +-
+ Documentation/manual.txt | 10 +++++-----
+ Makefile | 6 +++---
+ Makefile.utils | 6 +++---
+ ftdump.c => fdtdump.c | 2 +-
+ 5 files changed, 13 insertions(+), 13 deletions(-)
+ rename ftdump.c => fdtdump.c (97%)
+
+diff --git a/Documentation/manual.txt b/Documentation/manual.txt
+index f8a8a7b..14508f3 100644
+--- a/Documentation/manual.txt
++++ b/Documentation/manual.txt
+@@ -21,7 +21,7 @@ III - libfdt
+
+ IV - Utility Tools
+ 1) convert-dtsv0 -- Conversion to Version 1
+- 1) ftdump
++ 1) fdtdump
+
+
+ I - "dtc", the device tree compiler
+@@ -643,10 +643,10 @@ a new file with a "v1" appended the filename.
+ Comments, empty lines, etc. are preserved.
+
+
+-2) ftdump -- Flat Tree dumping utility
++2) fdtdump -- Flat Device Tree dumping utility
+
+-The ftdump program prints a readable version of a flat device tree file.
++The fdtdump program prints a readable version of a flat device tree file.
+
+-The syntax of the ftdump command line is:
++The syntax of the fdtdump command line is:
+
+- ftdump <DTB-file-name>
++ fdtdump <DTB-file-name>
+diff --git a/Makefile b/Makefile
+index b32409b..4582f5d 100644
+--- a/Makefile
++++ b/Makefile
+@@ -109,7 +109,7 @@ include Makefile.utils
+
+ BIN += convert-dtsv0
+ BIN += dtc
+-BIN += ftdump
++BIN += fdtdump
+
+ SCRIPTS = dtdiff
+
+@@ -119,7 +119,7 @@ all: $(BIN) libfdt
+ ifneq ($(DEPTARGETS),)
+ -include $(DTC_OBJS:%.o=%.d)
+ -include $(CONVERT_OBJS:%.o=%.d)
+--include $(FTDUMP_OBJS:%.o=%.d)
++-include $(FDTDUMP_OBJS:%.o=%.d)
+ endif
+
+
+@@ -178,7 +178,7 @@ convert-dtsv0: $(CONVERT_OBJS)
+ @$(VECHO) LD $@
+ $(LINK.c) -o $@ $^
+
+-ftdump: $(FTDUMP_OBJS)
++fdtdump: $(FDTDUMP_OBJS)
+
+
+ #
+diff --git a/Makefile.utils b/Makefile.utils
+index 0ed9297..fae5b00 100644
+--- a/Makefile.ftdump
++++ b/Makefile.ftdump
+@@ -4,8 +4,8 @@
+ # into other systems of Makefiles.
+ #
+
+-FTDUMP_SRCS = \
+- ftdump.c
++FDTDUMP_SRCS = \
++ fdtdump.c
+
+-FTDUMP_GEN_SRCS =
++FDTDUMP_GEN_SRCS =
+
+-FTDUMP_OBJS = $(FTDUMP_SRCS:%.c=%.o) $(FTDUMP_GEN_SRCS:%.c=%.o)
++FDTDUMP_OBJS = $(FDTDUMP_SRCS:%.c=%.o) $(FDTDUMP_GEN_SRCS:%.c=%.o)
+diff --git a/ftdump.c b/fdtdump.c
+similarity index 97%
+rename from ftdump.c
+rename to fdtdump.c
+index cc55fe2..207a46d 100644
+--- a/ftdump.c
++++ b/fdtdump.c
+@@ -1,5 +1,5 @@
+ /*
+- * ftdump.c - Contributed by Pantelis Antoniou <pantelis.antoniou AT gmail.com>
++ * fdtdump.c - Contributed by Pantelis Antoniou <pantelis.antoniou AT gmail.com>
+ */
+
+ #include <stdint.h>
+--
+1.7.12.4
+