summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2014-05-06 13:29:57 +0000
committerTony Vroon <chainsaw@gentoo.org>2014-05-06 13:29:57 +0000
commit16724f0597913791df6fa59c59207b8f0d4b50fd (patch)
treec24e4c37210deb95dec192a61e53666d1e5780b6 /sys-apps/dmidecode/dmidecode-2.12-r1.ebuild
parentVersion bump. Remove old. (diff)
downloadgentoo-2-16724f0597913791df6fa59c59207b8f0d4b50fd.tar.gz
gentoo-2-16724f0597913791df6fa59c59207b8f0d4b50fd.tar.bz2
gentoo-2-16724f0597913791df6fa59c59207b8f0d4b50fd.zip
Upstream left an outdated SMBIOS version check in place but have neglected to roll a new release so far. Backported fixes by J. Rosenboom close bug #504810.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xB5058F9A)
Diffstat (limited to 'sys-apps/dmidecode/dmidecode-2.12-r1.ebuild')
-rw-r--r--sys-apps/dmidecode/dmidecode-2.12-r1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/sys-apps/dmidecode/dmidecode-2.12-r1.ebuild b/sys-apps/dmidecode/dmidecode-2.12-r1.ebuild
new file mode 100644
index 000000000000..2cdb2803896e
--- /dev/null
+++ b/sys-apps/dmidecode/dmidecode-2.12-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dmidecode/dmidecode-2.12-r1.ebuild,v 1.1 2014/05/06 13:29:57 chainsaw Exp $
+
+EAPI="4"
+
+inherit flag-o-matic toolchain-funcs eutils
+
+DESCRIPTION="DMI (Desktop Management Interface) table related utilities"
+HOMEPAGE="http://www.nongnu.org/dmidecode/"
+SRC_URI="http://savannah.nongnu.org/download/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-solaris"
+IUSE="selinux"
+
+DEPEND="selinux? ( sec-policy/selinux-dmidecode )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PV}-supported-smbios-version.patch"
+ sed -i \
+ -e "/^prefix/s:/usr/local:${EPREFIX}/usr:" \
+ -e "/^docdir/s:dmidecode:${PF}:" \
+ -e '/^PROGRAMS !=/d' \
+ Makefile || die
+}
+
+src_compile() {
+ emake \
+ CFLAGS="${CFLAGS} ${CPPFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
+ CC="$(tc-getCC)"
+}
+
+pkg_postinst() {
+ if [[ ${CHOST} == *-solaris* ]] ; then
+ einfo "dmidecode needs root privileges to read /dev/xsvc"
+ einfo "To make dmidecode useful, either run as root, or chown and setuid the binary."
+ einfo "Note that /usr/sbin/ptrconf and /usr/sbin/ptrdiag give similar"
+ einfo "information without requiring root privileges."
+ fi
+}