summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-02-27 16:22:11 +0000
committerAchim Gottinger <achim@gentoo.org>2001-02-27 16:22:11 +0000
commit4a36e8087165c893946f8adeffec0e9ffa0dfc96 (patch)
tree0522c3d043989bfe1154a5283a7a570df57a4966 /sys-apps/debianutils
parentPatching Makefile now instead of using sed's changed hardlink to symlink on (diff)
downloadgentoo-2-4a36e8087165c893946f8adeffec0e9ffa0dfc96.tar.gz
gentoo-2-4a36e8087165c893946f8adeffec0e9ffa0dfc96.tar.bz2
gentoo-2-4a36e8087165c893946f8adeffec0e9ffa0dfc96.zip
Uses static and build now instead of build-static
Diffstat (limited to 'sys-apps/debianutils')
-rw-r--r--sys-apps/debianutils/debianutils-1.13.3-r3.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/sys-apps/debianutils/debianutils-1.13.3-r3.ebuild b/sys-apps/debianutils/debianutils-1.13.3-r3.ebuild
new file mode 100644
index 000000000000..8374affcccb4
--- /dev/null
+++ b/sys-apps/debianutils/debianutils-1.13.3-r3.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/debianutils/debianutils-1.13.3-r3.ebuild,v 1.1 2001/02/27 16:22:11 achim Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A selection of tools from Debian"
+SRC_URI="ftp://ftp.debian.org/debian/dists/potato/main/source/base/debianutils_${PV}.tar.gz"
+
+DEPEND="virtual/glibc"
+
+src_unpack() {
+
+ unpack ${A}
+ cd ${S}
+ patch -p0 < ${FILESDIR}/${P}-Makefile-gentoo.diff
+
+}
+
+src_compile() {
+
+ if [ -z "`use static`" ]
+ then
+ try pmake
+ else
+ try pmake LDFLAGS=-static
+ fi
+}
+
+
+src_install() {
+
+ into /
+ dobin readlink tempfile mktemp
+
+ if [ -z "`use build`" ]
+ then
+ dobin run-parts
+ insopts -m755
+ exeinto /usr/sbin
+ doexe savelog
+
+ doman mktemp.1 readlink.1 tempfile.1 run-parts.8 savelog.8
+
+ cd debian
+ dodoc changelog control copyright
+ fi
+
+}
+
+
+