summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-04-28 17:43:02 +0000
committerMichał Górny <mgorny@gentoo.org>2014-04-28 17:43:02 +0000
commit1a434ca9b62c4336082e62b9507c1c4105878644 (patch)
tree057bc0c300d1f2b89c349e40d6e1e0a10ec308fe /sys-apps/dbus
parentReplace multilib_build_binaries with multilib_is_native_abi, in order to put ... (diff)
downloadgentoo-2-1a434ca9b62c4336082e62b9507c1c4105878644.tar.gz
gentoo-2-1a434ca9b62c4336082e62b9507c1c4105878644.tar.bz2
gentoo-2-1a434ca9b62c4336082e62b9507c1c4105878644.zip
Replace multilib_build_binaries with multilib_is_native_abi, in order to put an end to the confusion introduced by having two functions, the proper one suggesting it is just for binaries.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'sys-apps/dbus')
-rw-r--r--sys-apps/dbus/ChangeLog8
-rw-r--r--sys-apps/dbus/dbus-1.6.18-r1.ebuild12
-rw-r--r--sys-apps/dbus/dbus-1.8.0.ebuild12
3 files changed, 19 insertions, 13 deletions
diff --git a/sys-apps/dbus/ChangeLog b/sys-apps/dbus/ChangeLog
index 2c048e491895..1cd8eb4ec106 100644
--- a/sys-apps/dbus/ChangeLog
+++ b/sys-apps/dbus/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/dbus
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/dbus/ChangeLog,v 1.414 2014/03/15 08:27:43 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dbus/ChangeLog,v 1.415 2014/04/28 17:43:02 mgorny Exp $
+
+ 28 Apr 2014; Michał Górny <mgorny@gentoo.org> dbus-1.6.18-r1.ebuild,
+ dbus-1.8.0.ebuild:
+ Replace multilib_build_binaries with multilib_is_native_abi, in order to put
+ an end to the confusion introduced by having two functions, the proper one
+ suggesting it is just for binaries.
15 Mar 2014; Samuli Suominen <ssuominen@gentoo.org> -dbus-1.6.12.ebuild,
-dbus-1.6.14.ebuild, -dbus-1.6.16.ebuild, -dbus-1.6.18.ebuild:
diff --git a/sys-apps/dbus/dbus-1.6.18-r1.ebuild b/sys-apps/dbus/dbus-1.6.18-r1.ebuild
index f1848ec93127..4eb3d1d7feab 100644
--- a/sys-apps/dbus/dbus-1.6.18-r1.ebuild
+++ b/sys-apps/dbus/dbus-1.6.18-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/dbus/dbus-1.6.18-r1.ebuild,v 1.13 2014/03/14 22:13:56 mattst88 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dbus/dbus-1.6.18-r1.ebuild,v 1.14 2014/04/28 17:43:02 mgorny Exp $
EAPI=5
PYTHON_COMPAT=( python2_7 )
@@ -111,7 +111,7 @@ multilib_src_configure() {
"$(systemd_with_unitdir)"
)
- if multilib_build_binaries; then
+ if multilib_is_native_abi; then
docconf=(
$(use_enable doc xml-docs) \
$(use_enable doc doxygen-docs)
@@ -137,7 +137,7 @@ multilib_src_configure() {
einfo "Running configure in ${BUILD_DIR}"
ECONF_SOURCE="${S}" econf "${myconf[@]}" "${docconf[@]}"
- if multilib_build_binaries && use test; then
+ if multilib_is_native_abi && use test; then
mkdir "${TBD}"
cd "${TBD}"
einfo "Running configure in ${TBD}"
@@ -150,7 +150,7 @@ multilib_src_configure() {
}
multilib_src_compile() {
- if multilib_build_binaries; then
+ if multilib_is_native_abi; then
# after the compile, it uses a selinuxfs interface to
# check if the SELinux policy has the right support
use selinux && addwrite /selinux/access
@@ -158,7 +158,7 @@ multilib_src_compile() {
einfo "Running make in ${BUILD_DIR}"
emake
- if multilib_build_binaries && use test; then
+ if multilib_is_native_abi && use test; then
cd "${TBD}"
einfo "Running make in ${TBD}"
emake
@@ -174,7 +174,7 @@ src_test() {
}
multilib_src_install() {
- if multilib_build_binaries; then
+ if multilib_is_native_abi; then
emake DESTDIR="${D}" install
else
emake DESTDIR="${D}" install-pkgconfigDATA
diff --git a/sys-apps/dbus/dbus-1.8.0.ebuild b/sys-apps/dbus/dbus-1.8.0.ebuild
index 2ce2d27a4a6f..e847122db83b 100644
--- a/sys-apps/dbus/dbus-1.8.0.ebuild
+++ b/sys-apps/dbus/dbus-1.8.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/dbus/dbus-1.8.0.ebuild,v 1.5 2014/02/26 19:21:07 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dbus/dbus-1.8.0.ebuild,v 1.6 2014/04/28 17:43:02 mgorny Exp $
EAPI=5
PYTHON_COMPAT=( python2_7 )
@@ -107,7 +107,7 @@ multilib_src_configure() {
"$(systemd_with_unitdir)"
)
- if multilib_build_binaries; then
+ if multilib_is_native_abi; then
docconf=(
--enable-xml-docs
$(use_enable doc doxygen-docs)
@@ -128,7 +128,7 @@ multilib_src_configure() {
einfo "Running configure in ${BUILD_DIR}"
ECONF_SOURCE="${S}" econf "${myconf[@]}" "${docconf[@]}"
- if multilib_build_binaries && use test; then
+ if multilib_is_native_abi && use test; then
mkdir "${TBD}"
cd "${TBD}"
einfo "Running configure in ${TBD}"
@@ -141,7 +141,7 @@ multilib_src_configure() {
}
multilib_src_compile() {
- if multilib_build_binaries; then
+ if multilib_is_native_abi; then
# after the compile, it uses a selinuxfs interface to
# check if the SELinux policy has the right support
use selinux && addwrite /selinux/access
@@ -149,7 +149,7 @@ multilib_src_compile() {
einfo "Running make in ${BUILD_DIR}"
emake
- if multilib_build_binaries && use test; then
+ if multilib_is_native_abi && use test; then
cd "${TBD}"
einfo "Running make in ${TBD}"
emake
@@ -165,7 +165,7 @@ src_test() {
}
multilib_src_install() {
- if multilib_build_binaries; then
+ if multilib_is_native_abi; then
emake DESTDIR="${D}" install
else
emake DESTDIR="${D}" install-pkgconfigDATA