summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Januszewski <spock@gentoo.org>2008-09-14 11:25:39 +0000
committerMichael Januszewski <spock@gentoo.org>2008-09-14 11:25:39 +0000
commit637c0a3e71b26ff9bd0a671722bce74854e796fe (patch)
tree8f7764e939b1853368087699971a2f67839a871d /sci-visualization/opendx
parentStable on sparc, bug #237335 (diff)
downloadgentoo-2-637c0a3e71b26ff9bd0a671722bce74854e796fe.tar.gz
gentoo-2-637c0a3e71b26ff9bd0a671722bce74854e796fe.tar.bz2
gentoo-2-637c0a3e71b26ff9bd0a671722bce74854e796fe.zip
Fix concurrent make (bug #230535).
(Portage version: 2.2_rc8/cvs/Linux 2.6.26 x86_64)
Diffstat (limited to 'sci-visualization/opendx')
-rw-r--r--sci-visualization/opendx/ChangeLog6
-rw-r--r--sci-visualization/opendx/files/opendx-4.4.4-concurrent-make-fix.patch33
-rw-r--r--sci-visualization/opendx/opendx-4.4.4.ebuild3
3 files changed, 40 insertions, 2 deletions
diff --git a/sci-visualization/opendx/ChangeLog b/sci-visualization/opendx/ChangeLog
index b80cc2d6a3ee..73ea1155005c 100644
--- a/sci-visualization/opendx/ChangeLog
+++ b/sci-visualization/opendx/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-visualization/opendx
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/opendx/ChangeLog,v 1.14 2008/08/06 18:55:22 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/opendx/ChangeLog,v 1.15 2008/09/14 11:25:38 spock Exp $
+
+ 14 Sep 2008; Michał Januszewski <spock@gentoo.org>
+ +files/opendx-4.4.4-concurrent-make-fix.patch, opendx-4.4.4.ebuild:
+ Fix concurrent make (bug #230535).
06 Aug 2008; Ulrich Mueller <ulm@gentoo.org> metadata.xml:
Add USE flag description to metadata wrt GLEP 56.
diff --git a/sci-visualization/opendx/files/opendx-4.4.4-concurrent-make-fix.patch b/sci-visualization/opendx/files/opendx-4.4.4-concurrent-make-fix.patch
new file mode 100644
index 000000000000..816b72c104a7
--- /dev/null
+++ b/sci-visualization/opendx/files/opendx-4.4.4-concurrent-make-fix.patch
@@ -0,0 +1,33 @@
+diff -Nuarp dx-4.4.4-orig/src/exec/dxmods/local.mk dx-4.4.4/src/exec/dxmods/local.mk
+--- dx-4.4.4-orig/src/exec/dxmods/local.mk 2008-09-11 22:31:38.000000000 +0200
++++ dx-4.4.4/src/exec/dxmods/local.mk 2008-09-11 22:33:44.000000000 +0200
+@@ -14,15 +14,15 @@ user.c: dx.mdf
+
+ dxcm.mdf: ${srcdir}/dxmdf.src
+ -rm -f dxcm.mdf
+- cp ${srcdir}/dxmdf.src tmp.c
+- $(CPP) $(INCLUDES) $(MDF) $(DEFS) tmp.c > dxcm.mdf
+- -rm -f tmp.c
++ cp ${srcdir}/dxmdf.src tmp-dxcm.c
++ $(CPP) $(INCLUDES) $(MDF) $(DEFS) tmp-dxcm.c > dxcm.mdf
++ -rm -f tmp-dxcm.c
+
+ dx.mdf: ${srcdir}/dxmdf.src
+ echo MYINC: $(MYINC)
+ -rm -f dx.mdf
+- cp ${srcdir}/dxmdf.src tmp.c
+- $(CPP) $(INCLUDES) $(MYINC) $(MDF) $(DEFS) -DCPLUSPLUS_UI -DEXECUTIVE_MODS tmp.c > dx.mdf
++ cp ${srcdir}/dxmdf.src tmp-dx.c
++ $(CPP) $(INCLUDES) $(MYINC) $(MDF) $(DEFS) -DCPLUSPLUS_UI -DEXECUTIVE_MODS tmp-dx.c > dx.mdf
+ @echo '/^ *$$/{' > stripl.sed
+ @echo 'N' >> stripl.sed
+ @echo '/^ *\\n *$$/D' >> stripl.sed
+@@ -30,7 +30,7 @@ dx.mdf: ${srcdir}/dxmdf.src
+ cat dx.mdf |sed '/^#/d' > tmp.mdf
+ cat tmp.mdf |sed -f stripl.sed > dx.mdf
+ @rm -f stripl.sed tmp.mdf
+- -rm -f tmp.c
++ -rm -f tmp-dx.c
+
+ .y.h:
+ $(YACC) $(YFLAGS) -d ${srcdir}/$*.y
diff --git a/sci-visualization/opendx/opendx-4.4.4.ebuild b/sci-visualization/opendx/opendx-4.4.4.ebuild
index 0f9b0406d22a..a8f192da9e32 100644
--- a/sci-visualization/opendx/opendx-4.4.4.ebuild
+++ b/sci-visualization/opendx/opendx-4.4.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/opendx/opendx-4.4.4.ebuild,v 1.6 2008/06/29 11:46:50 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/opendx/opendx-4.4.4.ebuild,v 1.7 2008/09/14 11:25:38 spock Exp $
# Set SMP="no" to force disable of SMP compilation.
# Set SMP="yes" to force enable of SMP compilation.
@@ -76,6 +76,7 @@ src_unpack() {
epatch "${FILESDIR}"/${PN}-compressed-man.patch
epatch "${FILESDIR}"/${PN}-4.4.4-gcc43.patch
epatch "${FILESDIR}"/${P}-libtool.patch
+ epatch "${FILESDIR}"/${P}-concurrent-make-fix.patch
eautoreconf || die "Failed running eautoreconf."
}