summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2013-10-30 17:16:28 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2013-10-30 17:16:28 +0000
commit8303791824fbd1e15022acae05625af4f5640866 (patch)
tree73f6ad13253a91168b6de3036fc09a095845b702 /sci-physics
parentStable for HPPA (bug #489854). (diff)
downloadgentoo-2-8303791824fbd1e15022acae05625af4f5640866.tar.gz
gentoo-2-8303791824fbd1e15022acae05625af4f5640866.tar.bz2
gentoo-2-8303791824fbd1e15022acae05625af4f5640866.zip
Version bump, switch to EAPI5 and python-r1, fixing bug #488698
(Portage version: 2.2.7-prefix/cvs/Linux x86_64, signed Manifest commit with key 0x13CB1360)
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/lhapdf/ChangeLog8
-rw-r--r--sci-physics/lhapdf/lhapdf-5.8.9.ebuild15
-rw-r--r--sci-physics/lhapdf/lhapdf-5.9.1.ebuild (renamed from sci-physics/lhapdf/lhapdf-5.8.8.ebuild)40
3 files changed, 42 insertions, 21 deletions
diff --git a/sci-physics/lhapdf/ChangeLog b/sci-physics/lhapdf/ChangeLog
index 379852e329ed..baa1debf2956 100644
--- a/sci-physics/lhapdf/ChangeLog
+++ b/sci-physics/lhapdf/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-physics/lhapdf
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/lhapdf/ChangeLog,v 1.21 2013/06/04 17:47:01 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/lhapdf/ChangeLog,v 1.22 2013/10/30 17:16:28 bicatali Exp $
+
+*lhapdf-5.9.1 (30 Oct 2013)
+
+ 30 Oct 2013; Sébastien Fabbro <bicatali@gentoo.org> +lhapdf-5.9.1.ebuild,
+ -lhapdf-5.8.8.ebuild, lhapdf-5.8.9.ebuild:
+ Version bump, switch to EAPI5 and python-r1, fixing bug #488698
*lhapdf-5.8.9 (04 Jun 2013)
diff --git a/sci-physics/lhapdf/lhapdf-5.8.9.ebuild b/sci-physics/lhapdf/lhapdf-5.8.9.ebuild
index 72a8259ae08f..f1f72a8d6469 100644
--- a/sci-physics/lhapdf/lhapdf-5.8.9.ebuild
+++ b/sci-physics/lhapdf/lhapdf-5.8.9.ebuild
@@ -1,11 +1,13 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/lhapdf/lhapdf-5.8.9.ebuild,v 1.1 2013/06/04 17:47:01 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/lhapdf/lhapdf-5.8.9.ebuild,v 1.2 2013/10/30 17:16:28 bicatali Exp $
EAPI=5
AUTOTOOLS_IN_SOURCE_BUILD=yes
-inherit versionator autotools-utils
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit versionator autotools-utils python-single-r1
MY_PV=$(get_version_component_range 1-3 ${PV})
MY_PF=${PN}-${MY_PV}
@@ -24,8 +26,11 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
IUSE="cxx doc examples octave python static-libs test"
-REQUIRED_USE="octave? ( cxx )"
-RDEPEND="octave? ( sci-mathematics/octave )"
+REQUIRED_USE="octave? ( cxx ) python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="
+ octave? ( sci-mathematics/octave )
+ python? ( ${PYTHON_DEPS} )"
DEPEND="${RDEPEND}
doc? ( app-doc/doxygen[latex] )
python? ( dev-lang/swig )"
@@ -70,5 +75,5 @@ src_install() {
pkg_postinst() {
elog "To install data files, you have to run as root:"
- elog "lhapdf-getdata --dest=${EROOT}usr/share/lhapdf/PDFsets --all"
+ elog "lhapdf-getdata --dest=${EROOT%/}/usr/share/lhapdf/PDFsets --all"
}
diff --git a/sci-physics/lhapdf/lhapdf-5.8.8.ebuild b/sci-physics/lhapdf/lhapdf-5.9.1.ebuild
index 1626b4777dc2..d6c78cabd5d2 100644
--- a/sci-physics/lhapdf/lhapdf-5.8.8.ebuild
+++ b/sci-physics/lhapdf/lhapdf-5.9.1.ebuild
@@ -1,10 +1,13 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/lhapdf/lhapdf-5.8.8.ebuild,v 1.1 2012/08/07 17:34:13 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/lhapdf/lhapdf-5.9.1.ebuild,v 1.1 2013/10/30 17:16:28 bicatali Exp $
-EAPI=4
+EAPI=5
-inherit versionator eutils
+AUTOTOOLS_IN_SOURCE_BUILD=yes
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit versionator autotools-utils python-single-r1
MY_PV=$(get_version_component_range 1-3 ${PV})
MY_PF=${PN}-${MY_PV}
@@ -23,8 +26,11 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
IUSE="cxx doc examples octave python static-libs test"
-REQUIRED_USE="octave? ( cxx )"
-RDEPEND="octave? ( sci-mathematics/octave )"
+REQUIRED_USE="octave? ( cxx ) python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="
+ octave? ( sci-mathematics/octave )
+ python? ( ${PYTHON_DEPS} )"
DEPEND="${RDEPEND}
doc? ( app-doc/doxygen[latex] )
python? ( dev-lang/swig )"
@@ -39,16 +45,18 @@ src_prepare() {
}
src_configure() {
- econf \
- $(use_enable cxx ccwrap) \
- $(use_enable cxx old-ccwrap ) \
- $(use_enable doc doxygen) \
- $(use_enable octave) \
- $(use_enable python pyext) \
- $(use_enable static-libs static)
+ local myeconfargs=(
+ $(use_enable cxx ccwrap)
+ $(use_enable cxx old-ccwrap)
+ $(use_enable doc doxygen)
+ $(use_enable octave)
+ $(use_enable python pyext)
+ )
+ autotools-utils_src_configure
}
src_test() {
+ cd "${BUILD_DIR}"
# need to make a bogus link for octave test
ln -s "${DISTDIR}" PDFsets
LHAPATH="${PWD}/PDFsets" \
@@ -57,7 +65,9 @@ src_test() {
}
src_install() {
- default
+ autotools-utils_src_install
+ use python \
+ && python_fix_shebang "${ED}"/usr/bin/lhapdf-{getdata,query}
use doc && use cxx && dohtml -r ccwrap/doxy/html/*
if use examples; then
insinto /usr/share/doc/${PF}/examples
@@ -67,5 +77,5 @@ src_install() {
pkg_postinst() {
elog "To install data files, you have to run as root:"
- elog "lhapdf-getdata --dest=${EROOT}usr/share/lhapdf/PDFsets --all"
+ elog "lhapdf-getdata --dest=${EROOT%/}/usr/share/lhapdf/PDFsets --all"
}