summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Bock <nicolasbock@gentoo.org>2014-02-19 20:12:04 +0000
committerNicolas Bock <nicolasbock@gentoo.org>2014-02-19 20:12:04 +0000
commit721e86fa5409dd0940e47539fcf2ba6337aee6f6 (patch)
treef77cb1cc1d57a1f0372ab0138cd9331d79810c6e /sci-physics/lammps
parentVersion Bump -> 1.8.8, Fix upstream source url for 1.8.7, Remove older ebuilds. (diff)
downloadgentoo-2-721e86fa5409dd0940e47539fcf2ba6337aee6f6.tar.gz
gentoo-2-721e86fa5409dd0940e47539fcf2ba6337aee6f6.tar.bz2
gentoo-2-721e86fa5409dd0940e47539fcf2ba6337aee6f6.zip
sci-physics/lammps-20140214: Revision bump...
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key AC91CA52)
Diffstat (limited to 'sci-physics/lammps')
-rw-r--r--sci-physics/lammps/ChangeLog8
-rw-r--r--sci-physics/lammps/lammps-20140214-r1.ebuild152
-rw-r--r--sci-physics/lammps/lammps-20140214.ebuild18
3 files changed, 165 insertions, 13 deletions
diff --git a/sci-physics/lammps/ChangeLog b/sci-physics/lammps/ChangeLog
index 7199d2f0acda..3344ec73ae94 100644
--- a/sci-physics/lammps/ChangeLog
+++ b/sci-physics/lammps/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-physics/lammps
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/lammps/ChangeLog,v 1.17 2014/02/19 19:05:49 nicolasbock Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/lammps/ChangeLog,v 1.18 2014/02/19 20:12:04 nicolasbock Exp $
+
+*lammps-20140214-r1 (19 Feb 2014)
+
+ 19 Feb 2014; Nicolas Bock <nicolasbock@gentoo.org> +lammps-20140214-r1.ebuild,
+ lammps-20140214.ebuild:
+ sci-physics/lammps-20140214: Revision bump...
19 Feb 2014; Nicolas Bock <nicolasbock@gentoo.org> lammps-20140214.ebuild:
sci-physics/lammps-20140214: Change location of examples.
diff --git a/sci-physics/lammps/lammps-20140214-r1.ebuild b/sci-physics/lammps/lammps-20140214-r1.ebuild
new file mode 100644
index 000000000000..1549844affbd
--- /dev/null
+++ b/sci-physics/lammps/lammps-20140214-r1.ebuild
@@ -0,0 +1,152 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/lammps/lammps-20140214-r1.ebuild,v 1.1 2014/02/19 20:12:04 nicolasbock Exp $
+
+EAPI=5
+
+inherit eutils fortran-2
+
+convert_month() {
+ case $1 in
+ 01) echo Jan
+ ;;
+ 02) echo Feb
+ ;;
+ 03) echo Mar
+ ;;
+ 04) echo Apr
+ ;;
+ 05) echo May
+ ;;
+ 06) echo Jun
+ ;;
+ 07) echo Jul
+ ;;
+ 08) echo Aug
+ ;;
+ 09) echo Sep
+ ;;
+ 10) echo Oct
+ ;;
+ 11) echo Nov
+ ;;
+ 12) echo Dec
+ ;;
+ *) echo unknown
+ ;;
+ esac
+}
+
+MY_P=${PN}-$((10#${PV:6:2}))$(convert_month ${PV:4:2})${PV:2:2}
+
+DESCRIPTION="Large-scale Atomic/Molecular Massively Parallel Simulator"
+HOMEPAGE="http://lammps.sandia.gov/"
+SRC_URI="http://lammps.sandia.gov/tars/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc examples gzip lammps-memalign mpi static-libs"
+
+DEPEND="mpi? ( virtual/mpi )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+lmp_emake() {
+ local LAMMPS_INCLUDEFLAGS
+ LAMMPS_INCLUDEFLAGS="$(usex gzip '-DLAMMPS_GZIP' '')"
+ LAMMPS_INCLUDEFLAGS+="$(usex lammps-memalign ' -DLAMMPS_MEMALIGN' '')"
+
+ # The lammps makefile uses CC to indicate the C++ compiler.
+ emake \
+ ARCHIVE=$(tc-getAR) \
+ CC=$(usex mpi "mpic++" "$(tc-getCXX)") \
+ F90=$(usex mpi "mpif90" "$(tc-getFC)") \
+ LINK=$(usex mpi "mpic++" "$(tc-getCXX)") \
+ CCFLAGS="${CXXFLAGS}" \
+ F90FLAGS="${FCFLAGS}" \
+ LINKFLAGS="${LDFLAGS}" \
+ LMP_INC="${LAMMPS_INCLUDEFLAGS}" \
+ MPI_INC=$(usex mpi '' "-I../STUBS") \
+ MPI_PATH=$(usex mpi '' '-L../STUBS') \
+ MPI_LIB=$(usex mpi '' '-lmpi_stubs') \
+ "$@"
+}
+
+src_prepare() {
+ # Fix inconsistent use of SHFLAGS.
+ sed -i -e 's:$(CCFLAGS):$(CCFLAGS) -fPIC:' src/STUBS/Makefile || die
+ sed -i -e 's:$(F90FLAGS):$(F90FLAGS) -fPIC:' lib/meam/Makefile.gfortran || die
+ sed -i -e 's:$(F90FLAGS):$(F90FLAGS) -fPIC:' lib/reax/Makefile.gfortran || die
+
+ # Fix makefile in tools.
+ sed -i \
+ -e 's:g++:$(CXX) $(CXXFLAGS):' \
+ -e 's:gcc:$(CC) $(CCFLAGS):' \
+ -e 's:ifort:$(FC) $(FCFLAGS):' \
+ tools/Makefile
+}
+
+src_compile() {
+ # Compile stubs for serial version.
+ use mpi || lmp_emake -C src stubs
+
+ # Build packages
+ emake -C src yes-dipole
+ emake -C src yes-kspace
+ emake -C src yes-mc
+ lmp_emake -C src yes-meam
+ lmp_emake -j1 -C lib/meam -f Makefile.gfortran
+ emake -C src yes-reax
+ emake -C src yes-replica
+ lmp_emake -j1 -C lib/reax -f Makefile.gfortran
+ emake -C src yes-rigid
+ emake -C src yes-shock
+ emake -C src yes-xtc
+
+ if use static-libs; then
+ # Build static library.
+ lmp_emake -C src makelib
+ lmp_emake -C src -f Makefile.lib serial
+ fi
+
+ # Build shared library.
+ lmp_emake -C src makeshlib
+ lmp_emake -C src -f Makefile.shlib serial
+
+ # Compile main executable.
+ lmp_emake -C src serial
+
+ # Compile tools.
+ emake -C tools binary2txt
+}
+
+src_install() {
+ use static-libs && newlib.a "src/liblammps_serial.a" "liblammps.a"
+ newlib.so "src/liblammps_serial.so" "liblammps.so"
+ newbin "src/lmp_serial" "lmp"
+ dobin tools/binary2txt
+ # Don't forget to add header files of optional packages as they are added
+ # to this ebuild. There may also be .mod files from Fortran based
+ # packages.
+ doheader -r src/*.h lib/meam/*.mod
+
+ local LAMMPS_POTENTIALS="/usr/share/${PN}/potentials"
+ insinto "${LAMMPS_POTENTIALS}"
+ doins potentials/*
+ echo "LAMMPS_POTENTIALS=${LAMMPS_POTENTIALS}" > 99lammps
+ doenvd 99lammps
+
+ if use examples; then
+ local LAMMPS_EXAMPLES="/usr/share/${PN}/examples"
+ insinto "${LAMMPS_EXAMPLES}"
+ doins -r examples/*
+ fi
+
+ dodoc README
+ if use doc; then
+ dodoc doc/Manual.pdf
+ dohtml -r doc/*
+ fi
+}
diff --git a/sci-physics/lammps/lammps-20140214.ebuild b/sci-physics/lammps/lammps-20140214.ebuild
index 8c56916c8ad7..d00dd7093b16 100644
--- a/sci-physics/lammps/lammps-20140214.ebuild
+++ b/sci-physics/lammps/lammps-20140214.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/lammps/lammps-20140214.ebuild,v 1.4 2014/02/19 19:05:49 nicolasbock Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/lammps/lammps-20140214.ebuild,v 1.5 2014/02/19 20:12:04 nicolasbock Exp $
EAPI=5
@@ -105,11 +105,9 @@ src_compile() {
emake -C src yes-shock
emake -C src yes-xtc
- if use static-libs; then
- # Build static library.
- lmp_emake -C src makelib
- lmp_emake -C src -f Makefile.lib serial
- fi
+ # Build static library.
+ lmp_emake -C src makelib
+ lmp_emake -C src -f Makefile.lib serial
# Build shared library.
lmp_emake -C src makeshlib
@@ -127,19 +125,15 @@ src_install() {
newlib.so "src/liblammps_serial.so" "liblammps.so"
newbin "src/lmp_serial" "lmp"
dobin tools/binary2txt
- # Don't forget to add header files of optional packages as they are added
- # to this ebuild. There may also be .mod files from Fortran based
- # packages.
- doheader -r src/*.h lib/meam/*.mod
- local LAMMPS_POTENTIALS="/usr/share/${PN}/potentials"
+ local LAMMPS_POTENTIALS="/usr/share/${PF}/potentials"
insinto "${LAMMPS_POTENTIALS}"
doins potentials/*
echo "LAMMPS_POTENTIALS=${LAMMPS_POTENTIALS}" > 99lammps
doenvd 99lammps
if use examples; then
- local LAMMPS_EXAMPLES="/usr/share/${PN}/examples"
+ local LAMMPS_EXAMPLES="/usr/share/${PF}/examples"
insinto "${LAMMPS_EXAMPLES}"
doins -r examples/*
fi