summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcus D. Hanwell <cryos@gentoo.org>2006-11-05 11:48:52 +0000
committerMarcus D. Hanwell <cryos@gentoo.org>2006-11-05 11:48:52 +0000
commitc53908674d49024ff13ade3baa1afb984fbc7b0a (patch)
tree928421e89b23eca4441c361420646baf779c0397 /sci-misc
parentadd CRON_SYSTEM_CRONTAB=yes - to support more generic eclass - see bug #89213... (diff)
downloadgentoo-2-c53908674d49024ff13ade3baa1afb984fbc7b0a.tar.gz
gentoo-2-c53908674d49024ff13ade3baa1afb984fbc7b0a.tar.bz2
gentoo-2-c53908674d49024ff13ade3baa1afb984fbc7b0a.zip
Ressurect until new setiathome version is in the tree.
(Portage version: 2.1.2_rc1-r2)
Diffstat (limited to 'sci-misc')
-rw-r--r--sci-misc/boinc/ChangeLog6
-rw-r--r--sci-misc/boinc/boinc-4.72.20050813-r3.ebuild89
-rw-r--r--sci-misc/boinc/files/boinc-4.72.20050813-gcc4-fix.patch11
-rw-r--r--sci-misc/boinc/files/digest-boinc-4.72.20050813-r33
4 files changed, 108 insertions, 1 deletions
diff --git a/sci-misc/boinc/ChangeLog b/sci-misc/boinc/ChangeLog
index 1a087e66ab32..8240acb98558 100644
--- a/sci-misc/boinc/ChangeLog
+++ b/sci-misc/boinc/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-misc/boinc
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-misc/boinc/ChangeLog,v 1.27 2006/11/03 15:28:30 cryos Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-misc/boinc/ChangeLog,v 1.28 2006/11/05 11:48:52 cryos Exp $
+
+ 05 Nov 2006; Marcus D. Hanwell <cryos@gentoo.org>
+ +files/boinc-4.72.20050813-gcc4-fix.patch, +boinc-4.72.20050813-r3.ebuild:
+ Ressurect until new setiathome version is in the tree.
*boinc-5.4.11 (03 Nov 2006)
diff --git a/sci-misc/boinc/boinc-4.72.20050813-r3.ebuild b/sci-misc/boinc/boinc-4.72.20050813-r3.ebuild
new file mode 100644
index 000000000000..7817b670622a
--- /dev/null
+++ b/sci-misc/boinc/boinc-4.72.20050813-r3.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-misc/boinc/boinc-4.72.20050813-r3.ebuild,v 1.4 2006/11/05 11:48:52 cryos Exp $
+
+inherit eutils
+
+MY_PN="boinc_public-cvs"
+MY_PV="2005-08-13"
+S=${WORKDIR}/boinc_public
+
+DESCRIPTION="The Berkeley Open Infrastructure for Network Computing"
+HOMEPAGE="http://boinc.ssl.berkeley.edu/"
+SRC_URI="http://boinc.ssl.berkeley.edu/source/nightly/${MY_PN}-${MY_PV}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
+IUSE="server X"
+
+RDEPEND="sys-libs/zlib
+ X? ( >=x11-libs/wxGTK-2.6.1 )
+ server? ( net-www/apache
+ >=dev-db/mysql-4.0.24
+ virtual/php
+ >=dev-lang/python-2.2.3
+ >=dev-python/mysql-python-0.9.2 )"
+DEPEND=">=sys-devel/gcc-3.0.4
+ >=sys-devel/autoconf-2.59
+ >=sys-devel/automake-1.9.3
+ X? ( || ( ( x11-libs/libXmu
+ x11-libs/libXt
+ x11-libs/libX11
+ x11-proto/xproto )
+ virtual/x11 )
+ virtual/glut
+ virtual/glu
+ media-libs/jpeg )
+ server? ( virtual/imap-c-client )
+ ${RDEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # GCC 4 patch, bug 112133.
+ epatch ${FILESDIR}/${P}-gcc4-fix.patch
+
+ # point to a proper mouse device
+ sed -e "s:/dev/mouse:/dev/input/mice:g" -i client/hostinfo_unix.C || die
+}
+
+src_compile() {
+ econf \
+ --enable-client \
+ --disable-static-client \
+ --with-wx-config=$(which wx-config-2.6) \
+ $(use_enable server) \
+ $(use_with X x) || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make install DESTDIR=${D} || die "make install failed"
+
+ newinitd ${FILESDIR}/boinc.init boinc
+ newconfd ${FILESDIR}/boinc.conf boinc
+
+ make_desktop_entry boinc_gui BOINC boinc Science /var/lib/boinc
+}
+
+pkg_preinst() {
+ enewgroup boinc
+ enewuser boinc -1 -1 /var/lib/boinc boinc
+}
+
+pkg_postinst() {
+ echo
+ einfo "You need to attach to a project to do anything useful with boinc."
+ einfo "You can do this by running /etc/init.d/boinc attach"
+ einfo "BOINC The howto for configuration is located at:"
+ einfo "http://boinc.berkeley.edu/anonymous_platform.php"
+ if use server;then
+ echo
+ einfo "You have chosen to enable server mode. this ebuild has installed"
+ einfo "the necessary packages to be a server. You will need to have a"
+ einfo "project. Contact BOINC directly for further information."
+ fi
+ echo
+}
diff --git a/sci-misc/boinc/files/boinc-4.72.20050813-gcc4-fix.patch b/sci-misc/boinc/files/boinc-4.72.20050813-gcc4-fix.patch
new file mode 100644
index 000000000000..a0624b3e05a2
--- /dev/null
+++ b/sci-misc/boinc/files/boinc-4.72.20050813-gcc4-fix.patch
@@ -0,0 +1,11 @@
+--- boinc_public/lib/shmem.C.orig 2005-11-11 02:46:07.000000000 +0100
++++ boinc_public/lib/shmem.C 2005-11-11 02:46:20.000000000 +0100
+@@ -128,7 +128,7 @@
+ return ERR_SHMGET;
+ }
+ p = shmat(id, 0, 0);
+- if ((int)p == -1) {
++ if ((long)p == -1) {
+ return ERR_SHMAT;
+ }
+ *pp = p;
diff --git a/sci-misc/boinc/files/digest-boinc-4.72.20050813-r3 b/sci-misc/boinc/files/digest-boinc-4.72.20050813-r3
new file mode 100644
index 000000000000..55e46bfc29ab
--- /dev/null
+++ b/sci-misc/boinc/files/digest-boinc-4.72.20050813-r3
@@ -0,0 +1,3 @@
+MD5 af114631d61e117de9bafa197864a8ff boinc_public-cvs-2005-08-13.tar.gz 6054534
+RMD160 2585effd13c1b6e093141dbc34bebd770c6041be boinc_public-cvs-2005-08-13.tar.gz 6054534
+SHA256 3a8b7f3d462a0fa5f1d0ad14c77f790a3cf12b1237a09636cd82b9bfefc2afb7 boinc_public-cvs-2005-08-13.tar.gz 6054534