summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2008-08-24 17:29:46 +0000
committerUlrich Müller <ulm@gentoo.org>2008-08-24 17:29:46 +0000
commita892992e944c0af576eb7cbfe65a548a4ef90206 (patch)
tree6fcb04580543b987c2da4bd553be42932754bb3c /sci-misc/gri
parentStable on alpha, bug #235017 (diff)
downloadgentoo-2-a892992e944c0af576eb7cbfe65a548a4ef90206.tar.gz
gentoo-2-a892992e944c0af576eb7cbfe65a548a4ef90206.tar.bz2
gentoo-2-a892992e944c0af576eb7cbfe65a548a4ef90206.zip
Fix Emacs support, bug 235602. Remove old.
(Portage version: 2.2_rc8/cvs/Linux 2.6.26-gentoo-r1 i686)
Diffstat (limited to 'sci-misc/gri')
-rw-r--r--sci-misc/gri/ChangeLog6
-rw-r--r--sci-misc/gri/gri-2.12.14.ebuild59
-rw-r--r--sci-misc/gri/gri-2.12.16-r1.ebuild15
-rw-r--r--sci-misc/gri/gri-2.12.17.ebuild15
4 files changed, 21 insertions, 74 deletions
diff --git a/sci-misc/gri/ChangeLog b/sci-misc/gri/ChangeLog
index c06768b6230d..7fd24e3f7b58 100644
--- a/sci-misc/gri/ChangeLog
+++ b/sci-misc/gri/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-misc/gri
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-misc/gri/ChangeLog,v 1.21 2008/06/09 10:46:40 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-misc/gri/ChangeLog,v 1.22 2008/08/24 17:29:46 ulm Exp $
+
+ 24 Aug 2008; Ulrich Mueller <ulm@gentoo.org> -gri-2.12.14.ebuild,
+ gri-2.12.16-r1.ebuild, gri-2.12.17.ebuild:
+ Fix Emacs support, bug 235602. Remove old.
*gri-2.12.17 (09 Jun 2008)
diff --git a/sci-misc/gri/gri-2.12.14.ebuild b/sci-misc/gri/gri-2.12.14.ebuild
deleted file mode 100644
index 22a3e5c32373..000000000000
--- a/sci-misc/gri/gri-2.12.14.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-misc/gri/gri-2.12.14.ebuild,v 1.5 2008/06/09 10:46:40 markusle Exp $
-
-inherit eutils elisp-common
-
-IUSE="emacs"
-
-DESCRIPTION="language for scientific graphics programming"
-HOMEPAGE="http://gri.sourceforge.net/"
-SRC_URI="mirror://sourceforge/gri/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ~ppc x86"
-RESTRICT="test"
-
-DEPEND=">=sci-libs/netcdf-3.5.0
- virtual/latex-base
- media-gfx/imagemagick
- virtual/ghostscript
- emacs? ( virtual/emacs )"
-
-SITEFILE="50gri-gentoo.el"
-
-src_compile() {
- econf || die "econf failed."
- emake || die "emake failed."
- if use emacs; then
- pushd src; elisp-comp *.el; popd
- fi
-}
-
-src_install() {
- # Replace PREFIX now and correct paths in the startup message.
- sed -e s,PREFIX/share/doc/gri/,/usr/share/doc/${P}/, -i "${S}/src/startup.msg"
-
- einstall || die "einstall failed."
-
- dodoc README
- #move docs to the proper place
- mv "${D}"/usr/share/gri/doc/* "${D}/usr/share/doc/${PF}"
- rmdir "${D}/usr/share/gri/doc/"
-
- if use emacs; then
- pushd src
- elisp-install gri *.{el,elc}
- elisp-site-file-install "${FILESDIR}/${SITEFILE}"
- popd
- fi
-}
-
-pkg_postinst() {
- use emacs && elisp-site-regen
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
-}
diff --git a/sci-misc/gri/gri-2.12.16-r1.ebuild b/sci-misc/gri/gri-2.12.16-r1.ebuild
index 27a58df4a97a..29a679a788bd 100644
--- a/sci-misc/gri/gri-2.12.16-r1.ebuild
+++ b/sci-misc/gri/gri-2.12.16-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-misc/gri/gri-2.12.16-r1.ebuild,v 1.4 2008/06/09 10:46:40 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-misc/gri/gri-2.12.16-r1.ebuild,v 1.5 2008/08/24 17:29:46 ulm Exp $
inherit eutils elisp-common
@@ -26,8 +26,7 @@ src_compile() {
econf || die "econf failed."
emake || die "emake failed."
if use emacs; then
- cd src
- elisp-comp *.el || die "elisp-comp failed"
+ elisp-compile src/*.el || die "elisp-compile failed"
fi
}
@@ -40,8 +39,9 @@ src_install() {
# license text not necessary
rm "${D}"/usr/share/gri/doc/license.txt
- # install target installs it always
- use emacs || rm -rf "${D}"/usr/share/emacs
+ # install target installs it always and in the wrong location
+ # remove it here and call elisp-install in case of USE=emacs below
+ rm -rf "${D}"/usr/share/emacs
if ! use doc; then
sed -e "s/Manual at.*//" -i "${D}"/usr/share/gri/startup.msg
@@ -62,8 +62,9 @@ src_install() {
if use emacs; then
cd src
- elisp-install gri *.{el,elc} || die "elisp-install failed"
- elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ elisp-install ${PN} *.{el,elc} || die "elisp-install failed"
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" \
+ || die "elisp-site-file-install failed"
fi
}
diff --git a/sci-misc/gri/gri-2.12.17.ebuild b/sci-misc/gri/gri-2.12.17.ebuild
index 850b9bf1d33a..90162ea8ff03 100644
--- a/sci-misc/gri/gri-2.12.17.ebuild
+++ b/sci-misc/gri/gri-2.12.17.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-misc/gri/gri-2.12.17.ebuild,v 1.1 2008/06/09 10:46:40 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-misc/gri/gri-2.12.17.ebuild,v 1.2 2008/08/24 17:29:46 ulm Exp $
inherit eutils elisp-common
@@ -26,8 +26,7 @@ src_compile() {
econf || die "econf failed."
emake || die "emake failed."
if use emacs; then
- cd src
- elisp-comp *.el || die "elisp-comp failed"
+ elisp-compile src/*.el || die "elisp-compile failed"
fi
}
@@ -40,8 +39,9 @@ src_install() {
# license text not necessary
rm "${D}"/usr/share/gri/doc/license.txt
- # install target installs it always
- use emacs || rm -rf "${D}"/usr/share/emacs
+ # install target installs it always and in the wrong location
+ # remove it here and call elisp-install in case of USE=emacs below
+ rm -rf "${D}"/usr/share/emacs
if ! use doc; then
sed -e "s/Manual at.*//" -i "${D}"/usr/share/gri/startup.msg
@@ -62,8 +62,9 @@ src_install() {
if use emacs; then
cd src
- elisp-install gri *.{el,elc} || die "elisp-install failed"
- elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ elisp-install ${PN} *.{el,elc} || die "elisp-install failed"
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" \
+ || die "elisp-site-file-install failed"
fi
}