summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2012-05-17 14:52:29 +0000
committerAlexis Ballier <aballier@gentoo.org>2012-05-17 14:52:29 +0000
commitb31fabe751c4bc6bc10be764bbadb6a5af2f5d81 (patch)
treeee98de726744eeae951d147047785dc4736bd304 /sci-mathematics
parentkeyword ~amd64-fbsd (diff)
downloadgentoo-2-b31fabe751c4bc6bc10be764bbadb6a5af2f5d81.tar.gz
gentoo-2-b31fabe751c4bc6bc10be764bbadb6a5af2f5d81.tar.bz2
gentoo-2-b31fabe751c4bc6bc10be764bbadb6a5af2f5d81.zip
version bump, by Christian D., bug #416389
(Portage version: 2.2.0_alpha107/cvs/Linux x86_64)
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/coq/ChangeLog7
-rw-r--r--sci-mathematics/coq/coq-8.3_p4.ebuild82
2 files changed, 88 insertions, 1 deletions
diff --git a/sci-mathematics/coq/ChangeLog b/sci-mathematics/coq/ChangeLog
index 2196c6f840ee..44cc26d91b70 100644
--- a/sci-mathematics/coq/ChangeLog
+++ b/sci-mathematics/coq/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-mathematics/coq
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/coq/ChangeLog,v 1.69 2012/03/24 13:59:39 gienah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/coq/ChangeLog,v 1.70 2012/05/17 14:52:29 aballier Exp $
+
+*coq-8.3_p4 (17 May 2012)
+
+ 17 May 2012; Alexis Ballier <aballier@gentoo.org> +coq-8.3_p4.ebuild:
+ version bump, by Christian D., bug #416389
24 Mar 2012; Mark Wright <gienah@gentoo.org> coq-8.3_p2.ebuild,
coq-8.3_p3.ebuild:
diff --git a/sci-mathematics/coq/coq-8.3_p4.ebuild b/sci-mathematics/coq/coq-8.3_p4.ebuild
new file mode 100644
index 000000000000..208172c49e02
--- /dev/null
+++ b/sci-mathematics/coq/coq-8.3_p4.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/coq/coq-8.3_p4.ebuild,v 1.1 2012/05/17 14:52:29 aballier Exp $
+
+EAPI="2"
+
+inherit eutils multilib
+
+MY_PV=${PV/_p/pl}
+MY_P=${PN}-${MY_PV}
+
+DESCRIPTION="Coq is a proof assistant written in O'Caml"
+HOMEPAGE="http://coq.inria.fr/"
+SRC_URI="http://${PN}.inria.fr/V${MY_PV}/files/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="gtk debug +ocamlopt doc"
+
+RDEPEND=">=dev-lang/ocaml-3.10[ocamlopt?]
+ >=dev-ml/camlp5-5.09[ocamlopt?]
+ gtk? ( >=dev-ml/lablgtk-2.10.1[ocamlopt?] )"
+DEPEND="${RDEPEND}
+ doc? (
+ media-libs/netpbm[png,zlib]
+ virtual/latex-base
+ dev-tex/hevea
+ dev-tex/xcolor
+ dev-texlive/texlive-pictures
+ dev-texlive/texlive-mathextra
+ dev-texlive/texlive-latexextra
+ )"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ # configure has an error at line 640 leading to closing a
+ # string to early in the generated coq_config.ml. Here is a
+ # wild sed which replaces \"$LABLGTKLIB\" by $LABLGTKLIB. Note
+ # during pl2-bump: Hmm, my patch did not get applied upstream?
+ sed -i "s/\\\\\"\\\$LABLGTKLIB\\\\\"/\\\$LABLGTKLIB/" configure
+}
+
+src_configure() {
+ ocaml_lib=`ocamlc -where`
+ local myconf="--prefix /usr
+ --bindir /usr/bin
+ --libdir /usr/$(get_libdir)/coq
+ --mandir /usr/share/man
+ --emacslib /usr/share/emacs/site-lisp
+ --coqdocdir /usr/$(get_libdir)/coq/coqdoc
+ --docdir /usr/share/doc/${PF}
+ --camlp5dir ${ocaml_lib}/camlp5
+ --lablgtkdir ${ocaml_lib}/lablgtk2"
+
+ use debug && myconf="--debug $myconf"
+ use doc || myconf="$myconf --with-doc no"
+
+ if use gtk; then
+ use ocamlopt && myconf="$myconf --coqide opt"
+ use ocamlopt || myconf="$myconf --coqide byte"
+ else
+ myconf="$myconf --coqide no"
+ fi
+ use ocamlopt || myconf="$myconf -byte-only"
+ use ocamlopt && myconf="$myconf --opt"
+
+ export CAML_LD_LIBRARY_PATH="${S}/kernel/byterun/"
+ ./configure $myconf || die "configure failed"
+}
+
+src_compile() {
+ emake STRIP="true" -j1 || die "make failed"
+}
+
+src_install() {
+ emake STRIP="true" COQINSTALLPREFIX="${D}" install || die
+ dodoc README CREDITS CHANGES
+
+ use gtk && domenu "${FILESDIR}/coqide.desktop"
+}