summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2010-02-12 03:20:21 +0000
committerMarkus Dittrich <markusle@gentoo.org>2010-02-12 03:20:21 +0000
commit97f0e2d137dfa559ca02852ea65c0e256d1fd99c (patch)
tree2f15913311a4a7d101f77b71b835f16aab3c3ffc /sci-mathematics
parentDrop old ebuild (diff)
downloadgentoo-2-97f0e2d137dfa559ca02852ea65c0e256d1fd99c.tar.gz
gentoo-2-97f0e2d137dfa559ca02852ea65c0e256d1fd99c.tar.bz2
gentoo-2-97f0e2d137dfa559ca02852ea65c0e256d1fd99c.zip
If hdf5 is compiled against MPI we need to use the mpi wrappers to compile octave to avoid linker errors (#302621, #303391).
(Portage version: 2.1.7.17/cvs/Linux x86_64)
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/octave/ChangeLog6
-rw-r--r--sci-mathematics/octave/octave-3.2.4.ebuild10
2 files changed, 14 insertions, 2 deletions
diff --git a/sci-mathematics/octave/ChangeLog b/sci-mathematics/octave/ChangeLog
index c63328793974..90f33f5ef1e9 100644
--- a/sci-mathematics/octave/ChangeLog
+++ b/sci-mathematics/octave/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-mathematics/octave
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/ChangeLog,v 1.82 2010/02/03 10:14:06 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/ChangeLog,v 1.83 2010/02/12 03:20:21 markusle Exp $
+
+ 12 Feb 2010; Markus Dittrich <markusle@gentoo.org> octave-3.2.4.ebuild:
+ If hdf5 is compiled against MPI we need to use the mpi wrappers to compile
+ octave to avoid linker errors (#302621, #303391).
03 Feb 2010; Christian Faulhammer <fauli@gentoo.org>
octave-3.2.3-r1.ebuild:
diff --git a/sci-mathematics/octave/octave-3.2.4.ebuild b/sci-mathematics/octave/octave-3.2.4.ebuild
index 614097aa96b0..ede3b2d5fe53 100644
--- a/sci-mathematics/octave/octave-3.2.4.ebuild
+++ b/sci-mathematics/octave/octave-3.2.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/octave-3.2.4.ebuild,v 1.1 2010/02/01 07:09:46 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/octave-3.2.4.ebuild,v 1.2 2010/02/12 03:20:21 markusle Exp $
EAPI="2"
inherit flag-o-matic xemacs-elisp-common
@@ -50,6 +50,14 @@ DEPEND="${RDEPEND}
src_prepare() {
epatch "${FILESDIR}"/${PN}-3.2.0_parallel_make.patch
epatch "${FILESDIR}"/${PN}-3.2.0_as_needed.patch
+
+ # without this we get MPI linker errors if hdf5
+ # was compiled against mpi (see #302621)
+ if has_version sci-libs/hdf5[mpi]; then
+ export CC=mpicc
+ export FC=mpif90
+ export CXX=mpicxx
+ fi
}
src_configure() {