summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2014-09-07 12:59:59 +0000
committerMark Wright <gienah@gentoo.org>2014-09-07 12:59:59 +0000
commit63fdd57250f56cb8039d0e5ae451d5929c3d0b20 (patch)
treeabedc84acd67008bee956569639e11b52249541f /sci-mathematics
parentRemove masked for removal package (diff)
downloadgentoo-2-63fdd57250f56cb8039d0e5ae451d5929c3d0b20.tar.gz
gentoo-2-63fdd57250f56cb8039d0e5ae451d5929c3d0b20.tar.bz2
gentoo-2-63fdd57250f56cb8039d0e5ae451d5929c3d0b20.zip
Bump octave to 3.8.2, fixes bump request Bug 520368, thanks to mrueg for reporting. Add deps to USE java, fixes Bug 519756, thanks to M. B. for reporting and the fix.
(Portage version: 2.2.12/cvs/Linux x86_64, signed Manifest commit with key 618E971F)
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/octave/ChangeLog10
-rw-r--r--sci-mathematics/octave/octave-3.8.1-r1.ebuild4
-rw-r--r--sci-mathematics/octave/octave-3.8.2.ebuild163
3 files changed, 175 insertions, 2 deletions
diff --git a/sci-mathematics/octave/ChangeLog b/sci-mathematics/octave/ChangeLog
index 1b54bfa66e87..a483d4e16686 100644
--- a/sci-mathematics/octave/ChangeLog
+++ b/sci-mathematics/octave/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sci-mathematics/octave
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/ChangeLog,v 1.166 2014/04/18 14:18:56 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/ChangeLog,v 1.167 2014/09/07 12:59:59 gienah Exp $
+
+*octave-3.8.2 (07 Sep 2014)
+
+ 07 Sep 2014; Mark Wright <gienah@gentoo.org> +octave-3.8.2.ebuild,
+ octave-3.8.1-r1.ebuild:
+ Bump octave to 3.8.2, fixes bump request Bug 520368, thanks to mrueg for
+ reporting. Add deps to USE java, fixes Bug 519756, thanks to M. B. for
+ reporting and the fix.
17 Apr 2014; Sébastien Fabbro <bicatali@gentoo.org> octave-3.8.1-r1.ebuild:
Removed checking of symbols in linear algebra libraries bug #507782
diff --git a/sci-mathematics/octave/octave-3.8.1-r1.ebuild b/sci-mathematics/octave/octave-3.8.1-r1.ebuild
index 95a8ab33b49b..b7230cebee31 100644
--- a/sci-mathematics/octave/octave-3.8.1-r1.ebuild
+++ b/sci-mathematics/octave/octave-3.8.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/octave-3.8.1-r1.ebuild,v 1.3 2014/04/17 16:02:52 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/octave-3.8.1-r1.ebuild,v 1.4 2014/09/07 12:59:59 gienah Exp $
EAPI=5
@@ -33,6 +33,7 @@ RDEPEND="
imagemagick? ( || (
media-gfx/graphicsmagick:0=[cxx]
media-gfx/imagemagick:0=[cxx] ) )
+ java? ( >=virtual/jre-1.6.0 )
jit? ( sys-devel/llvm )
opengl? (
media-libs/freetype:2=
@@ -61,6 +62,7 @@ RDEPEND="
DEPEND="${RDEPEND}
qrupdate? ( app-misc/pax-utils )
sparse? ( app-misc/pax-utils )
+ java? ( >=virtual/jdk-1.6.0 )
doc? (
virtual/latex-base
dev-texlive/texlive-genericrecommended
diff --git a/sci-mathematics/octave/octave-3.8.2.ebuild b/sci-mathematics/octave/octave-3.8.2.ebuild
new file mode 100644
index 000000000000..c42ab9776453
--- /dev/null
+++ b/sci-mathematics/octave/octave-3.8.2.ebuild
@@ -0,0 +1,163 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/octave-3.8.2.ebuild,v 1.1 2014/09/07 12:59:59 gienah Exp $
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=1
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+inherit autotools-utils multilib toolchain-funcs fortran-2 flag-o-matic java-pkg-opt-2 pax-utils
+
+DESCRIPTION="High-level interactive language for numerical computations"
+LICENSE="GPL-3"
+HOMEPAGE="http://www.octave.org/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.bz2"
+
+SLOT="0/${PV}"
+IUSE="curl doc fftw +glpk gnuplot gui hdf5 +imagemagick java jit opengl
+ postscript +qhull +qrupdate readline +sparse static-libs X zlib"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ app-text/ghostscript-gpl
+ dev-libs/libpcre:3=
+ sys-libs/ncurses:5=
+ virtual/lapack
+ curl? ( net-misc/curl:0= )
+ fftw? ( sci-libs/fftw:3.0= )
+ glpk? ( sci-mathematics/glpk:0= )
+ gnuplot? ( sci-visualization/gnuplot )
+ gui? ( x11-libs/qscintilla:0= )
+ hdf5? ( sci-libs/hdf5:0= )
+ imagemagick? ( || (
+ media-gfx/graphicsmagick:0=[cxx]
+ media-gfx/imagemagick:0=[cxx] ) )
+ java? ( >=virtual/jre-1.6.0 )
+ jit? ( sys-devel/llvm )
+ opengl? (
+ media-libs/freetype:2=
+ media-libs/fontconfig:1.0=
+ >=x11-libs/fltk-1.3:1=[opengl]
+ x11-libs/gl2ps:0=
+ virtual/glu )
+ postscript? (
+ app-text/epstool
+ media-gfx/pstoedit
+ media-gfx/transfig )
+ qhull? ( media-libs/qhull:0= )
+ qrupdate? ( sci-libs/qrupdate:0= )
+ readline? ( sys-libs/readline:0= )
+ sparse? (
+ sci-libs/arpack:0=
+ sci-libs/camd:0=
+ sci-libs/ccolamd:0=
+ sci-libs/cholmod:0=
+ sci-libs/colamd:0=
+ sci-libs/cxsparse:0=
+ sci-libs/umfpack:0= )
+ X? ( x11-libs/libX11:0= )
+ zlib? ( sys-libs/zlib:0= )"
+
+DEPEND="${RDEPEND}
+ qrupdate? ( app-misc/pax-utils )
+ sparse? ( app-misc/pax-utils )
+ java? ( >=virtual/jdk-1.6.0 )
+ doc? (
+ virtual/latex-base
+ dev-texlive/texlive-genericrecommended
+ dev-texlive/texlive-metapost
+ sys-apps/texinfo )
+ dev-util/gperf
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.4.3-texi.patch
+ "${FILESDIR}"/${PN}-3.8.0-disable-getcwd-path-max-test-as-it-is-too-slow.patch
+ "${FILESDIR}"/${PN}-3.8.0-imagemagick-configure.patch
+ "${FILESDIR}"/${PN}-3.8.0-llvm-configure.patch
+ "${FILESDIR}"/${PN}-3.8.1-imagemagick.patch
+ "${FILESDIR}"/${PN}-3.8.1-pkgbuilddir.patch
+)
+
+src_prepare() {
+ # nasty prefix hacks for fltk:1 and qt4 linking
+ if use prefix; then
+ use opengl && append-ldflags -Wl,-rpath,"${EPREFIX}/usr/$(get_libdir)/fltk-1"
+ use gui && append-ldflags -Wl,-rpath,"${EPREFIX}/usr/$(get_libdir)/qt4"
+ fi
+
+ has_version ">=sys-devel/llvm-3.4" && \
+ epatch "${FILESDIR}"/${PN}-3.8.0-llvm-3.4.patch
+
+ # Fix bug 501756
+ sed -i \
+ -e 's@A-Za-z0-9@[:alnum:]@g' \
+ -e 's@A-Za-z@[:alpha:]@g' \
+ libinterp/mkbuiltins || die
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ # occasional fail on install, force regeneration (bug #401189)
+ rm doc/interpreter/contributors.texi || die
+
+ # unfortunate dependency on mpi from hdf5 (bug #302621)
+ use hdf5 && has_version sci-libs/hdf5[mpi] && \
+ export CXX=mpicxx CC=mpicc FC=mpif77 F77=mpif77
+
+ local myeconfargs=(
+ --localstatedir="${EPREFIX}/var/state/octave"
+ --with-blas="$($(tc-getPKG_CONFIG) --libs blas)"
+ --with-lapack="$($(tc-getPKG_CONFIG) --libs lapack)"
+ $(use_enable doc docs)
+ $(use_enable java)
+ $(use_enable gui)
+ $(use_enable jit)
+ $(use_enable readline)
+ $(use_with curl)
+ $(use_with fftw fftw3)
+ $(use_with fftw fftw3f)
+ $(use_enable fftw fftw-threads)
+ $(use_with glpk)
+ $(use_with hdf5)
+ $(use_with opengl)
+ $(use_with qhull)
+ $(use_with qrupdate)
+ $(use_with sparse arpack)
+ $(use_with sparse umfpack)
+ $(use_with sparse colamd)
+ $(use_with sparse ccolamd)
+ $(use_with sparse cholmod)
+ $(use_with sparse cxsparse)
+ $(use_with X x)
+ $(use_with zlib z)
+ )
+ if use imagemagick; then
+ if has_version media-gfx/graphicsmagick[cxx]; then
+ myeconfargs+=( "--with-magick=GraphicsMagick" )
+ else
+ myeconfargs+=( "--with-magick=ImageMagick" )
+ fi
+ else
+ myeconfargs+=( "--without-magick" )
+ fi
+ autotools-utils_src_configure
+}
+
+src_compile() {
+ emake
+ if use java || use jit ; then
+ pax-mark m "${S}/src/.libs/octave-cli"
+ fi
+}
+
+src_install() {
+ autotools-utils_src_install
+ use doc && dodoc $(find doc -name \*.pdf)
+ [[ -e test/fntests.log ]] && dodoc test/fntests.log
+ use java && \
+ java-pkg_regjar "${ED}/usr/share/${PN}/${PV}/m/java/octave.jar"
+ echo "LDPATH=${EROOT}usr/$(get_libdir)/${PN}/${PV}" > 99octave
+ doenvd 99octave
+}