summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Januszewski <spock@gentoo.org>2008-06-29 08:59:38 +0000
committerMichael Januszewski <spock@gentoo.org>2008-06-29 08:59:38 +0000
commiteacc5532e32d503c6b673dd10d1847eb1bef9507 (patch)
treed13c55677faaec8156e676ab87a78d3ede05ebe2 /sci-mathematics/xmds
parentAdd missing die: || "..." -> || die "..." (diff)
downloadgentoo-2-eacc5532e32d503c6b673dd10d1847eb1bef9507.tar.gz
gentoo-2-eacc5532e32d503c6b673dd10d1847eb1bef9507.tar.bz2
gentoo-2-eacc5532e32d503c6b673dd10d1847eb1bef9507.zip
Fix bug #229691.
(Portage version: 2.2_rc1/cvs/Linux 2.6.26-rc8 x86_64)
Diffstat (limited to 'sci-mathematics/xmds')
-rw-r--r--sci-mathematics/xmds/ChangeLog6
-rw-r--r--sci-mathematics/xmds/files/xmds-1.6.5-gcc43.patch108
-rw-r--r--sci-mathematics/xmds/xmds-1.6.5.ebuild7
3 files changed, 119 insertions, 2 deletions
diff --git a/sci-mathematics/xmds/ChangeLog b/sci-mathematics/xmds/ChangeLog
index 0df05dd0e1be..a1c397a88a4d 100644
--- a/sci-mathematics/xmds/ChangeLog
+++ b/sci-mathematics/xmds/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-mathematics/xmds
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/xmds/ChangeLog,v 1.3 2008/03/15 15:46:33 spock Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/xmds/ChangeLog,v 1.4 2008/06/29 08:59:38 spock Exp $
+
+ 29 Jun 2008; Michał Januszewski <spock@gentoo.org>
+ +files/xmds-1.6.5-gcc43.patch, xmds-1.6.5.ebuild:
+ Fix bug #229691.
15 Mar 2008; Michał Januszewski <spock@gentoo.org> xmds-1.6.5.ebuild:
Fix installation of docs and examples.
diff --git a/sci-mathematics/xmds/files/xmds-1.6.5-gcc43.patch b/sci-mathematics/xmds/files/xmds-1.6.5-gcc43.patch
new file mode 100644
index 000000000000..766056d5ae51
--- /dev/null
+++ b/sci-mathematics/xmds/files/xmds-1.6.5-gcc43.patch
@@ -0,0 +1,108 @@
+diff -Naurp xmds-1.6.5-orig/source/xmds_integrate_ark45.cc xmds-1.6.5/source/xmds_integrate_ark45.cc
+--- xmds-1.6.5-orig/source/xmds_integrate_ark45.cc 2008-06-28 21:48:21.000000000 +0200
++++ xmds-1.6.5/source/xmds_integrate_ark45.cc 2008-06-28 21:48:57.000000000 +0200
+@@ -35,6 +35,7 @@
+ #include <xmds_simulation.h>
+ #include <xmds_vector.h>
+ #include <cstdlib>
++#include <cstring>
+
+ // **************************************************************************
+ // **************************************************************************
+@@ -289,7 +290,7 @@ void xmdsIntegrateARK45::writeTimestepEr
+ fprintf(outfile, "for(unsigned long _i0=0; _i0<_%s_size; _i0++){\n", fieldName);
+ }
+ fprintf(outfile, " for(unsigned long _i1=0; _i1<_%s_main_ncomponents; _i1++){\n", fieldName);
+- if (strcmp(typeName, "complex") == 0) {
++ if (std::strcmp(typeName, "complex") == 0) {
+ fprintf(outfile, " _temp_mod=mod2(_%s_main[_%s_main_index_pointer + _i1]);\n", fieldName, fieldName);
+ }
+ else {
+@@ -347,7 +348,7 @@ void xmdsIntegrateARK45::writeTimestepEr
+ }
+ fprintf(outfile, " for(unsigned long _i1=0; _i1<_%s_main_ncomponents; _i1++)\n", fieldName);
+
+- if (strcmp(typeName, "complex") == 0) {
++ if (std::strcmp(typeName, "complex") == 0) {
+ fprintf(outfile, " if(mod2(_%s_main[_%s_main_index_pointer + _i1])>_peak[_i1]){\n", fieldName, fieldName);
+ fprintf(outfile, " _temp_error=mod(_%s_main[_%s_main_index_pointer + _i1]-_checkfield[_%s_main_index_pointer + _i1])/(mod(_%s_main[_%s_main_index_pointer + _i1])+1e-20);\n", fieldName, fieldName, fieldName, fieldName, fieldName);
+ }
+@@ -364,7 +365,7 @@ void xmdsIntegrateARK45::writeTimestepEr
+ else{ // if ndims==0
+ fprintf(outfile, " for(unsigned long _i1=0; _i1<_%s_main_ncomponents; _i1++){\n", fieldName);
+
+- if (strcmp(typeName, "complex") == 0) {
++ if (std::strcmp(typeName, "complex") == 0) {
+ fprintf(outfile, " _temp_error=mod(_%s_main[_i1]-_checkfield[_i1])/(mod(_%s_main[_i1])+1e-20);\n", fieldName, fieldName);
+ }
+ else{
+diff -Naurp xmds-1.6.5-orig/source/xmds_integrate_ark89.cc xmds-1.6.5/source/xmds_integrate_ark89.cc
+--- xmds-1.6.5-orig/source/xmds_integrate_ark89.cc 2008-06-28 21:48:21.000000000 +0200
++++ xmds-1.6.5/source/xmds_integrate_ark89.cc 2008-06-28 21:48:57.000000000 +0200
+@@ -35,6 +35,7 @@
+ #include <xmds_simulation.h>
+ #include <xmds_vector.h>
+ #include <cstdlib>
++#include <cstring>
+
+ // **************************************************************************
+ // **************************************************************************
+@@ -284,7 +285,7 @@ void xmdsIntegrateARK89::writeTimestepEr
+ fprintf(outfile, "for (unsigned long _i0=0; _i0<_%s_size; _i0++){\n", fieldName);
+ }
+ fprintf(outfile, " for (unsigned long _i1=0; _i1<_%s_main_ncomponents; _i1++){\n", fieldName);
+- if (strcmp(typeName, "complex") == 0) {
++ if (std::strcmp(typeName, "complex") == 0) {
+ fprintf(outfile, " _temp_mod=mod2(_%s_main[_%s_main_index_pointer + _i1]);\n", fieldName, fieldName);
+ }
+ else {
+@@ -334,7 +335,7 @@ void xmdsIntegrateARK89::writeTimestepEr
+ }
+ fprintf(outfile, " for (unsigned long _i1=0; _i1<_%s_main_ncomponents; _i1++)\n", fieldName);
+
+- if (strcmp(typeName, "complex") == 0) {
++ if (std::strcmp(typeName, "complex") == 0) {
+ fprintf(outfile, " if (mod2(_%s_main[_%s_main_index_pointer + _i1])>_peak[_i1]){\n", fieldName, fieldName);
+ fprintf(outfile, " _temp_error=mod(_%s_main[_%s_main_index_pointer + _i1]-_checkfield[_%s_main_index_pointer + _i1])/(mod(_%s_main[_%s_main_index_pointer + _i1])+1e-20);\n", fieldName, fieldName, fieldName, fieldName, fieldName);
+ }
+@@ -352,7 +353,7 @@ void xmdsIntegrateARK89::writeTimestepEr
+
+ fprintf(outfile, " for (unsigned long _i1=0; _i1<_%s_main_ncomponents; _i1++){\n", fieldName);
+
+- if (strcmp(typeName, "complex") == 0){
++ if (std::strcmp(typeName, "complex") == 0){
+ fprintf(outfile, " _temp_error=mod(_%s_main[_i1]-_checkfield[_i1])/(mod(_%s_main[_i1])+1e-20);\n", fieldName, fieldName);
+ }
+ else{
+diff -Naurp xmds-1.6.5-orig/source/xmds_simulation.h xmds-1.6.5/source/xmds_simulation.h
+--- xmds-1.6.5-orig/source/xmds_simulation.h 2008-06-28 21:48:21.000000000 +0200
++++ xmds-1.6.5/source/xmds_simulation.h 2008-06-28 21:48:57.000000000 +0200
+@@ -40,6 +40,8 @@
+ #include <xmds_sequence.h>
+ #include <xmds_globals.h>
+
++#include <string>
++
+ // *****************************************************************************
+ // *****************************************************************************
+ // xmdsSimulation
+diff -Naurp xmds-1.6.5-orig/source/xsil2graphics.cc xmds-1.6.5/source/xsil2graphics.cc
+--- xmds-1.6.5-orig/source/xsil2graphics.cc 2008-06-28 21:48:21.000000000 +0200
++++ xmds-1.6.5/source/xsil2graphics.cc 2008-06-28 21:48:57.000000000 +0200
+@@ -40,6 +40,7 @@
+ #include <xsil_field.h>
+ #include <getopt_xmds.h>
+ #include <iostream>
++#include <cstring>
+
+ // **********************************************************************
+
+@@ -306,7 +307,7 @@ int main(
+
+ const DOMString *mgName = nextElement->getAttribute("Name");
+ int mgNumber = i+1;
+- if (strcmp("breakpoint", mgName->c_str()) == 0) {
++ if (std::strcmp("breakpoint", mgName->c_str()) == 0) {
+ mgNumber = 1;
+ }
+ else {
diff --git a/sci-mathematics/xmds/xmds-1.6.5.ebuild b/sci-mathematics/xmds/xmds-1.6.5.ebuild
index 33c83e90d24a..cef99e39faf1 100644
--- a/sci-mathematics/xmds/xmds-1.6.5.ebuild
+++ b/sci-mathematics/xmds/xmds-1.6.5.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/xmds/xmds-1.6.5.ebuild,v 1.2 2008/03/15 15:46:33 spock Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/xmds/xmds-1.6.5.ebuild,v 1.3 2008/06/29 08:59:38 spock Exp $
+
+inherit eutils
doc_ver=20080226
@@ -20,6 +22,9 @@ src_unpack() {
unpack ${P}.tar.gz
cd "${S}"
+ epatch "${FILESDIR}"/${PN}-1.6.5-gcc43.patch
+ touch "${S}/source/version.h"
+
# Fix broken installation of sample scripts.
sed -i -e 's/install-data-am: install-dist_doc_examplesDATA install-man/install-data-am: install-man/' Makefile.in
}