summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaweł Hajdan <phajdan.jr@gentoo.org>2010-10-12 11:16:29 +0000
committerPaweł Hajdan <phajdan.jr@gentoo.org>2010-10-12 11:16:29 +0000
commit5e27a267a3d4c8f9819e0101b90b0d4d6fbbad26 (patch)
tree93f8e890dbeae412bd69112b1e2946dd0e9b773b /sci-mathematics/spin
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-5e27a267a3d4c8f9819e0101b90b0d4d6fbbad26.tar.gz
gentoo-2-5e27a267a3d4c8f9819e0101b90b0d4d6fbbad26.tar.bz2
gentoo-2-5e27a267a3d4c8f9819e0101b90b0d4d6fbbad26.zip
Respect LDFLAGS, bug #337093 by flameeyes. Remove old.
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'sci-mathematics/spin')
-rw-r--r--sci-mathematics/spin/ChangeLog6
-rw-r--r--sci-mathematics/spin/files/spin-makefile.patch13
-rw-r--r--sci-mathematics/spin/spin-5.2.4.ebuild54
-rw-r--r--sci-mathematics/spin/spin-5.2.5.ebuild54
4 files changed, 16 insertions, 111 deletions
diff --git a/sci-mathematics/spin/ChangeLog b/sci-mathematics/spin/ChangeLog
index a7792b253a24..f925b7dc7509 100644
--- a/sci-mathematics/spin/ChangeLog
+++ b/sci-mathematics/spin/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-mathematics/spin
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/spin/ChangeLog,v 1.3 2010/06/22 17:49:59 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/spin/ChangeLog,v 1.4 2010/10/12 11:16:28 phajdan.jr Exp $
+
+ 12 Oct 2010; Pawel Hajdan jr <phajdan.jr@gentoo.org> -spin-5.2.4.ebuild,
+ -spin-5.2.5.ebuild, files/spin-makefile.patch:
+ Respect LDFLAGS, bug #337093 by flameeyes. Remove old.
*spin-5.2.5-r1 (22 Jun 2010)
diff --git a/sci-mathematics/spin/files/spin-makefile.patch b/sci-mathematics/spin/files/spin-makefile.patch
index 83fa9e95e12f..4f4c6dd12fc5 100644
--- a/sci-mathematics/spin/files/spin-makefile.patch
+++ b/sci-mathematics/spin/files/spin-makefile.patch
@@ -1,5 +1,5 @@
---- makefile.orig 2010-04-03 12:13:41.000000000 +0200
-+++ makefile 2010-04-03 12:14:21.000000000 +0200
+--- makefile.orig 2010-10-12 13:13:59.000000000 +0200
++++ makefile 2010-10-12 13:15:19.000000000 +0200
@@ -10,10 +10,6 @@
# Documentation: http://spinroot.com/
# Bug-reports: bugs@spinroot.com
@@ -11,3 +11,12 @@
# for a more picky compilation:
# CFLAGS=-std=c99 -Wstrict-prototypes -pedantic -fno-strength-reduce -fno-builtin -W -Wshadow -Wpointer-arith -Wcast-qual -Winline -Wall -g
+@@ -37,7 +33,7 @@
+ tl_mem.o tl_rewrt.o tl_cache.o
+
+ spin: $(SPIN_OS) $(TL_OS)
+- $(CC) $(CFLAGS) -o spin $(SPIN_OS) $(TL_OS)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o spin $(SPIN_OS) $(TL_OS)
+
+ spin.o: spin.y
+ $(YACC) $(YFLAGS) spin.y
diff --git a/sci-mathematics/spin/spin-5.2.4.ebuild b/sci-mathematics/spin/spin-5.2.4.ebuild
deleted file mode 100644
index 6835d92186f0..000000000000
--- a/sci-mathematics/spin/spin-5.2.4.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/spin/spin-5.2.4.ebuild,v 1.1 2010/04/11 12:50:07 phajdan.jr Exp $
-
-EAPI="2"
-
-inherit eutils versionator
-
-MY_PV=$(replace_all_version_separators '')
-MY_P="${PN}${MY_PV}"
-
-DESCRIPTION="Tool for formal verification of distributed software systems."
-HOMEPAGE="http://spinroot.com/"
-SRC_URI="http://spinroot.com/spin/Src/${MY_P}.tar.gz
- http://spinroot.com/spin/Src/xspin523.tcl"
-
-LICENSE="|| ( spin-commercial spin-educational )"
-SLOT="0"
-KEYWORDS="~x86"
-IUSE="graphviz tk"
-
-DEPEND="sys-devel/bison"
-RDEPEND="sys-devel/gcc
- sys-process/time
- tk? (
- dev-lang/tk
- graphviz? ( media-gfx/graphviz )
- )"
-
-S="${WORKDIR}/Spin/Src${PV}"
-
-src_unpack() {
- unpack "${MY_P}.tar.gz"
- cp "${DISTDIR}/xspin523.tcl" "${S}" || die "cp failed"
-}
-
-src_prepare() {
- epatch "${FILESDIR}/${PN}-makefile.patch"
- epatch "${FILESDIR}/${PN}-xspin.patch"
-}
-
-src_compile() {
- emake -j1 || die "emake failed"
-}
-
-src_install() {
- dobin spin || die "dobin failed"
- doman ../Man/spin.1 || die "doman failed"
- dodoc ../Doc/* || die "dodoc failed"
- if use tk; then
- newbin xspin523.tcl xspin || die "newbin failed"
- make_desktop_entry xspin XSpin
- fi
-}
diff --git a/sci-mathematics/spin/spin-5.2.5.ebuild b/sci-mathematics/spin/spin-5.2.5.ebuild
deleted file mode 100644
index 7977a990ee44..000000000000
--- a/sci-mathematics/spin/spin-5.2.5.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/spin/spin-5.2.5.ebuild,v 1.1 2010/06/11 14:31:38 phajdan.jr Exp $
-
-EAPI="2"
-
-inherit eutils versionator
-
-MY_PV=$(replace_all_version_separators '')
-MY_P="${PN}${MY_PV}"
-
-DESCRIPTION="Tool for formal verification of distributed software systems."
-HOMEPAGE="http://spinroot.com/"
-SRC_URI="http://spinroot.com/spin/Src/${MY_P}.tar.gz
- http://spinroot.com/spin/Src/xspin525.tcl"
-
-LICENSE="|| ( spin-commercial spin-educational )"
-SLOT="0"
-KEYWORDS="~x86"
-IUSE="graphviz tk"
-
-DEPEND="sys-devel/bison"
-RDEPEND="sys-devel/gcc
- sys-process/time
- tk? (
- dev-lang/tk
- graphviz? ( media-gfx/graphviz )
- )"
-
-S="${WORKDIR}/Spin/Src${PV}"
-
-src_unpack() {
- unpack "${MY_P}.tar.gz"
- cp "${DISTDIR}/xspin525.tcl" "${S}/xspin.tcl" || die "cp failed"
-}
-
-src_prepare() {
- epatch "${FILESDIR}/${PN}-makefile.patch"
- epatch "${FILESDIR}/${PN}-xspin-r1.patch"
-}
-
-src_compile() {
- emake -j1 || die "emake failed"
-}
-
-src_install() {
- dobin spin || die "dobin failed"
- doman ../Man/spin.1 || die "doman failed"
- dodoc ../Doc/* || die "dodoc failed"
- if use tk; then
- newbin xspin.tcl xspin || die "newbin failed"
- make_desktop_entry xspin XSpin
- fi
-}