summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2010-12-17 22:36:07 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2010-12-17 22:36:07 +0000
commit070e580ea7f3d551b066f5f1a0dff666bf67645f (patch)
treee6af2730f3fd23824cec2f337814528ee413edb4 /sci-mathematics/rngstreams
parentForce ignoring of -w in MAKEOPTS #338970 by Drake Wyrm. (diff)
downloadgentoo-2-070e580ea7f3d551b066f5f1a0dff666bf67645f.tar.gz
gentoo-2-070e580ea7f3d551b066f5f1a0dff666bf67645f.tar.bz2
gentoo-2-070e580ea7f3d551b066f5f1a0dff666bf67645f.zip
moved to the main tree
(Portage version: 2.1.9.25/cvs/Linux x86_64)
Diffstat (limited to 'sci-mathematics/rngstreams')
-rw-r--r--sci-mathematics/rngstreams/ChangeLog14
-rw-r--r--sci-mathematics/rngstreams/metadata.xml12
-rw-r--r--sci-mathematics/rngstreams/rngstreams-1.0.1.ebuild38
3 files changed, 64 insertions, 0 deletions
diff --git a/sci-mathematics/rngstreams/ChangeLog b/sci-mathematics/rngstreams/ChangeLog
new file mode 100644
index 000000000000..8e992428d9e9
--- /dev/null
+++ b/sci-mathematics/rngstreams/ChangeLog
@@ -0,0 +1,14 @@
+# ChangeLog for sci-mathematics/rngstreams
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/rngstreams/ChangeLog,v 1.1 2010/12/17 22:36:07 bicatali Exp $
+
+ 17 Dec 2010; Sébastien Fabbro <bicatali@gentoo.org>
+ +rngstreams-1.0.1.ebuild, +metadata.xml:
+ Moved to the main tree
+
+*rngstreams-1.0.1 (16 Oct 2010)
+
+ 16 Oct 2010; Sébastien Fabbro <bicatali@gentoo.org>
+ +rngstreams-1.0.1.ebuild, +metadata.xml:
+ Initial import
+
diff --git a/sci-mathematics/rngstreams/metadata.xml b/sci-mathematics/rngstreams/metadata.xml
new file mode 100644
index 000000000000..232b1e848442
--- /dev/null
+++ b/sci-mathematics/rngstreams/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci-mathematics</herd>
+<longdescription lang="en">
+ RngStreams is a C implementation of a high quality uniform random
+ number generator that supports multiple "independent" streams of
+ uniform random numbers. It has been written by Pierre L'Ecuyer and
+ Richard Simard.
+ This is the GNU-style package maintained by Josef Leydold.
+</longdescription>
+</pkgmetadata>
diff --git a/sci-mathematics/rngstreams/rngstreams-1.0.1.ebuild b/sci-mathematics/rngstreams/rngstreams-1.0.1.ebuild
new file mode 100644
index 000000000000..d23c084fedaf
--- /dev/null
+++ b/sci-mathematics/rngstreams/rngstreams-1.0.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/rngstreams/rngstreams-1.0.1.ebuild,v 1.1 2010/12/17 22:36:07 bicatali Exp $
+
+EAPI=2
+
+DESCRIPTION="Multiple independent streams of pseudo-random numbers"
+HOMEPAGE="http://statmath.wu.ac.at/software/RngStreams/"
+SRC_URI="${HOMEPAGE}${P}.tar.gz"
+
+LICENSE="GPL-3"
+
+SLOT=0
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples static-libs"
+DEPEND=""
+RDEPEND=""
+
+src_configure() {
+ econf \
+ --enable-shared \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS README NEWS
+ insinto /usr/share/doc/${PF}
+ if use doc; then
+ dohtml -r doc/rngstreams.html/* || die
+ doins doc/${PN}.pdf || die
+ fi
+ if use examples; then
+ emake distclean -C examples
+ rm -f examples/Makefile*
+ doins -r examples
+ fi
+}