summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Kahle <tomka@gentoo.org>2013-11-13 20:00:34 +0000
committerThomas Kahle <tomka@gentoo.org>2013-11-13 20:00:34 +0000
commite3e985503fc47749af87d216d5a555441176f620 (patch)
tree504c32f3758b6a32edac2cff2fa83c98bd00fdb7 /sci-mathematics/gimps
parentFix a possible crash in the presence interface (from 3.8 branch), blacklist n... (diff)
downloadgentoo-2-e3e985503fc47749af87d216d5a555441176f620.tar.gz
gentoo-2-e3e985503fc47749af87d216d5a555441176f620.tar.bz2
gentoo-2-e3e985503fc47749af87d216d5a555441176f620.zip
pax-mark m on the binary (bug 491074)
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0x89DEB219565C32BC!)
Diffstat (limited to 'sci-mathematics/gimps')
-rw-r--r--sci-mathematics/gimps/ChangeLog7
-rw-r--r--sci-mathematics/gimps/gimps-27.9-r1.ebuild65
2 files changed, 71 insertions, 1 deletions
diff --git a/sci-mathematics/gimps/ChangeLog b/sci-mathematics/gimps/ChangeLog
index 8ca069c743bb..75aa0560bbdf 100644
--- a/sci-mathematics/gimps/ChangeLog
+++ b/sci-mathematics/gimps/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-mathematics/gimps
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/gimps/ChangeLog,v 1.60 2013/04/12 10:07:19 tomka Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/gimps/ChangeLog,v 1.61 2013/11/13 20:00:34 tomka Exp $
+
+*gimps-27.9-r1 (13 Nov 2013)
+
+ 13 Nov 2013; Thomas Kahle <tomka@gentoo.org> +gimps-27.9-r1.ebuild:
+ pax-mark m on the binary (bug 491074)
12 Apr 2013; Thomas Kahle <tomka@gentoo.org> gimps-27.9.ebuild:
Migrate from as-is license to GIMPS (bug 465568)
diff --git a/sci-mathematics/gimps/gimps-27.9-r1.ebuild b/sci-mathematics/gimps/gimps-27.9-r1.ebuild
new file mode 100644
index 000000000000..ba6bcc2e051c
--- /dev/null
+++ b/sci-mathematics/gimps/gimps-27.9-r1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/gimps/gimps-27.9-r1.ebuild,v 1.1 2013/11/13 20:00:34 tomka Exp $
+
+EAPI=4
+
+inherit pax-utils
+
+DESCRIPTION="The Great Internet Mersenne Prime Search"
+HOMEPAGE="http://mersenne.org/"
+SRC_URI="
+ amd64? ( ftp://mersenne.org/gimps/p95v${PV/./}.linux64.tar.gz )
+ x86? ( ftp://mersenne.org/gimps/p95v${PV/./}.linux32.tar.gz )"
+
+SLOT="0"
+LICENSE="GIMPS"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+
+# Since there are no statically linked binaries for this version of mprime,
+# and no static binaries for amd64 in general, we use the dynamically linked
+# ones and try to cover the .so deps with the packages listed in RDEPEND.
+DEPEND=""
+RDEPEND="net-misc/curl"
+
+RESTRICT="binchecks"
+
+S="${WORKDIR}"
+I="/opt/gimps"
+
+QA_PREBUILT="opt/gimps/mprime"
+
+src_install() {
+ dodir ${I} /var/lib/gimps
+ pax-mark m mprime
+ cp mprime "${D}/${I}"
+ fperms a-w "${I}/mprime"
+ fowners root:0 "${I}"
+ fowners root:0 "${I}/mprime"
+
+ dodoc license.txt readme.txt stress.txt whatsnew.txt undoc.txt
+
+ newinitd "${FILESDIR}/${PN}-26.6-r1-init.d" gimps
+ newconfd "${FILESDIR}/${PN}-25.6-conf.d" gimps
+}
+
+pkg_postinst() {
+ echo
+ einfo "You can use \`/etc/init.d/gimps start\` to start a GIMPS client in the"
+ einfo "background at boot. Have a look at /etc/conf.d/gimps and check some"
+ einfo "configuration options."
+ einfo
+ einfo "If you don't want to use the init script to start gimps, remember to"
+ einfo "pass it an additional command line parameter specifying where the data"
+ einfo "files are to be stored, e.g.:"
+ einfo " ${I}/mprime -w/var/lib/gimps"
+ echo
+}
+
+pkg_postrm() {
+ echo
+ einfo "GIMPS data files were not removed."
+ einfo "Remove them manually from /var/lib/gimps/"
+ echo
+}