summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2013-04-30 16:22:04 +0000
committerAndrey Grozin <grozin@gentoo.org>2013-04-30 16:22:04 +0000
commitca8caa65cd998abe1bb717c51583b0c45edca993 (patch)
tree7fea3550ba804f78feab4ede9c71b131b19517b8 /sci-mathematics/fricas
parentLicense for dev-tcltk/tkpiechart and dev-tcltk/scwoop, bugs 464988 and 465030. (diff)
downloadgentoo-2-ca8caa65cd998abe1bb717c51583b0c45edca993.tar.gz
gentoo-2-ca8caa65cd998abe1bb717c51583b0c45edca993.tar.bz2
gentoo-2-ca8caa65cd998abe1bb717c51583b0c45edca993.zip
A patch not to load init files in some lisps
(Portage version: 2.2.0_alpha173/cvs/Linux i686, signed Manifest commit with key 0x3AFFCE974D34BD8C!)
Diffstat (limited to 'sci-mathematics/fricas')
-rw-r--r--sci-mathematics/fricas/ChangeLog6
-rw-r--r--sci-mathematics/fricas/files/fricas-1.2.0-noinit.patch13
-rw-r--r--sci-mathematics/fricas/fricas-1.2.0.ebuild11
-rw-r--r--sci-mathematics/fricas/metadata.xml2
4 files changed, 28 insertions, 4 deletions
diff --git a/sci-mathematics/fricas/ChangeLog b/sci-mathematics/fricas/ChangeLog
index 9b09827088f9..7a58e405e96d 100644
--- a/sci-mathematics/fricas/ChangeLog
+++ b/sci-mathematics/fricas/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-mathematics/fricas
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/fricas/ChangeLog,v 1.18 2013/04/20 14:56:08 grozin Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/fricas/ChangeLog,v 1.19 2013/04/30 16:22:04 grozin Exp $
+
+ 30 Apr 2013; Andrey Grozin <grozin@gentoo.org> fricas-1.2.0.ebuild,
+ +files/fricas-1.2.0-noinit.patch, metadata.xml:
+ A patch not to load init files in some lisps
*fricas-1.2.0 (20 Apr 2013)
diff --git a/sci-mathematics/fricas/files/fricas-1.2.0-noinit.patch b/sci-mathematics/fricas/files/fricas-1.2.0-noinit.patch
new file mode 100644
index 000000000000..1e44269e4731
--- /dev/null
+++ b/sci-mathematics/fricas/files/fricas-1.2.0-noinit.patch
@@ -0,0 +1,13 @@
+diff -r -U1 fricas-1.2.0.orig/configure.ac fricas-1.2.0/configure.ac
+--- fricas-1.2.0.orig/configure.ac 2013-04-08 10:26:54.000000000 +0700
++++ fricas-1.2.0/configure.ac 2013-05-01 01:34:31.338461653 +0700
+@@ -424,3 +424,3 @@
+ cmucl)
+- fricas_quiet_flags='-batch -noinit'
++ fricas_quiet_flags='-batch -nositeinit -noinit'
+ fricas_eval_flags='-eval'
+@@ -432,3 +432,3 @@
+ openmcl)
+- fricas_quiet_flags=
++ fricas_quiet_flags='--no-init'
+ fricas_eval_flags='--eval'
diff --git a/sci-mathematics/fricas/fricas-1.2.0.ebuild b/sci-mathematics/fricas/fricas-1.2.0.ebuild
index 6bf7f3a9f16c..6dfa190934b7 100644
--- a/sci-mathematics/fricas/fricas-1.2.0.ebuild
+++ b/sci-mathematics/fricas/fricas-1.2.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/fricas/fricas-1.2.0.ebuild,v 1.1 2013/04/20 14:56:08 grozin Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/fricas/fricas-1.2.0.ebuild,v 1.2 2013/04/30 16:22:04 grozin Exp $
EAPI=5
inherit eutils multilib elisp-common autotools
@@ -12,9 +12,9 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
# Supported lisps, number 0 is the default
-LISPS=( sbcl cmucl gcl ecl clisp clozurecl )
+LISPS=( sbcl cmucl gcl ecls clisp clozurecl )
# command name: . means just ${LISP}
-COMS=( . lisp . . . ccl )
+COMS=( . lisp . ecl . ccl )
IUSE="${LISPS[*]} X emacs gmp"
RDEPEND="X? ( x11-libs/libXpm x11-libs/libICE )
@@ -38,6 +38,11 @@ DEPEND="${RDEPEND}"
# necessary for clisp and gcl
RESTRICT="strip"
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-noinit.patch
+ eautoreconf
+}
+
src_configure() {
local LISP n
LISP=sbcl
diff --git a/sci-mathematics/fricas/metadata.xml b/sci-mathematics/fricas/metadata.xml
index 36dc623ca456..4e58d5435894 100644
--- a/sci-mathematics/fricas/metadata.xml
+++ b/sci-mathematics/fricas/metadata.xml
@@ -20,6 +20,8 @@ FriCAS is a fork of Axiom computer algebra system.
(<pkg>dev-lisp/sbcl</pkg>)</flag>
<flag name='ecl'>Add support for Embeddable Common Lisp
(<pkg>dev-lisp/ecls</pkg>)</flag>
+ <flag name='ecls'>Add support for Embeddable Common Lisp
+ (<pkg>dev-lisp/ecls</pkg>)</flag>
<flag name='clozurecl'>Add support for Clozure Common Lisp
(<pkg>dev-lisp/clozurecl</pkg>)</flag>
</use>