summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Loeser <halcy0n@gentoo.org>2009-07-25 02:31:16 +0000
committerMark Loeser <halcy0n@gentoo.org>2009-07-25 02:31:16 +0000
commite3e18040b694f254878de76f05bf356c22d47137 (patch)
tree9442a12b192006a2ac47c789647532dfd60de5e4 /sci-mathematics/freemat
parentFix compilation with gcc-4.4. Thanks to Victor Ostorga <vostorga AT gentoo D... (diff)
downloadgentoo-2-e3e18040b694f254878de76f05bf356c22d47137.tar.gz
gentoo-2-e3e18040b694f254878de76f05bf356c22d47137.tar.bz2
gentoo-2-e3e18040b694f254878de76f05bf356c22d47137.zip
Patch to fix compilation with gcc-4.4 by Martin Väth <vaeth AT mathematik.uni-wuerzburg DOT de>; bug #269278
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'sci-mathematics/freemat')
-rw-r--r--sci-mathematics/freemat/ChangeLog7
-rw-r--r--sci-mathematics/freemat/files/freemat-3.6-gcc44.patch20
-rw-r--r--sci-mathematics/freemat/freemat-3.6.ebuild3
3 files changed, 28 insertions, 2 deletions
diff --git a/sci-mathematics/freemat/ChangeLog b/sci-mathematics/freemat/ChangeLog
index 935d8c285959..9ba0850876cc 100644
--- a/sci-mathematics/freemat/ChangeLog
+++ b/sci-mathematics/freemat/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-mathematics/freemat
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/freemat/ChangeLog,v 1.15 2009/01/29 09:51:12 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/freemat/ChangeLog,v 1.16 2009/07/25 02:31:15 halcy0n Exp $
+
+ 25 Jul 2009; Mark Loeser <halcy0n@gentoo.org> freemat-3.6.ebuild,
+ +files/freemat-3.6-gcc44.patch:
+ Patch to fix compilation with gcc-4.4 by Martin Väth <vaeth AT
+ mathematik.uni-wuerzburg DOT de>; bug #269278
29 Jan 2009; Sébastien Fabbro <bicatali@gentoo.org> freemat-3.6.ebuild:
Added qt-svg dependency, switch to eapi 2
diff --git a/sci-mathematics/freemat/files/freemat-3.6-gcc44.patch b/sci-mathematics/freemat/files/freemat-3.6-gcc44.patch
new file mode 100644
index 000000000000..b145d25e3405
--- /dev/null
+++ b/sci-mathematics/freemat/files/freemat-3.6-gcc44.patch
@@ -0,0 +1,20 @@
+--- configure.in
++++ configure.in
+@@ -64,6 +64,7 @@
+ platform="--linux"
+ MP_WITH_CURSES
+ LIBS="$LIBS $CURSES_LIB $FLIBS $QT_LIBS"
++ LIBS="$LIBS -lGLU"
+ fi
+
+ if (test "$cross_compiling" = "yes"); then
+--- libs/libFreeMat/IEEEFP.cpp
++++ libs/libFreeMat/IEEEFP.cpp
+@@ -17,6 +17,7 @@
+ *
+ */
+ #include "IEEEFP.hpp"
++#include <cstdio>
+
+ static bool endianDetected = false;
+ static bool bigEndian = false;
diff --git a/sci-mathematics/freemat/freemat-3.6.ebuild b/sci-mathematics/freemat/freemat-3.6.ebuild
index b4109a78b838..473f50839cb6 100644
--- a/sci-mathematics/freemat/freemat-3.6.ebuild
+++ b/sci-mathematics/freemat/freemat-3.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/freemat/freemat-3.6.ebuild,v 1.6 2009/01/29 09:51:13 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/freemat/freemat-3.6.ebuild,v 1.7 2009/07/25 02:31:15 halcy0n Exp $
EAPI="2"
inherit eutils autotools fdo-mime
@@ -38,6 +38,7 @@ src_prepare() {
# allow enable/disable for configure
epatch "${FILESDIR}"/${P}-optional-deps.patch
epatch "${FILESDIR}"/${P}-includes.patch
+ epatch "${FILESDIR}"/${P}-gcc44.patch
eautoreconf
}